| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 3704 | Ingress Filtering for Multihomed NetworksF. Baker, P. Savola | Best Current Practice | March 2004 |
| 3947 | Negotiation of NAT-Traversal in the IKET. Kivinen, B. Swander, A. Huttunen, V. Volpe | Proposed Standard | January 2005 |
| 3948 | UDP Encapsulation of IPsec ESP PacketsA. Huttunen, B. Swander, V. Volpe, L. DiBurro, M. Stenberg | Proposed Standard | January 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4787 | Network Address Translation (NAT) Behavioral Requirements for Unicast UDPF. Audet, Ed., C. Jennings | Best Current Practice | January 2007 |
| 5245 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer ProtocolsJ. Rosenberg · obsoleted by RFC 8445, RFC 8839 | Proposed Standard | April 2010 |
| 5382 | NAT Behavioral Requirements for TCPS. Guha, Ed., K. Biswas, B. Ford, S. Sivakumar, P. Srisuresh | Best Current Practice | October 2008 |
| 5424 | The Syslog ProtocolR. Gerhards | Proposed Standard | March 2009 |
| 5580 | Carrying Location Objects in RADIUS and DiameterH. Tschofenig, Ed., F. Adrangi, M. Jones, A. Lior, B. Aboba | Proposed Standard | August 2009 |
| 5722 | Handling of Overlapping IPv6 FragmentsS. Krishnan | Proposed Standard | December 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5798 | Virtual Router Redundancy Protocol (VRRP) Version 3 for IPv4 and IPv6S. Nadas, Ed. · obsoleted by RFC 9568 | Proposed Standard | March 2010 |
| 5880 | Bidirectional Forwarding Detection (BFD)D. Katz, D. Ward | Proposed Standard | June 2010 |
| 6036 | Emerging Service Provider Scenarios for IPv6 DeploymentB. Carpenter, S. Jiang · obsoleted by RFC 9386 | Informational | October 2010 |
| 6052 | IPv6 Addressing of IPv4/IPv6 TranslatorsC. Bao, C. Huitema, M. Bagnulo, M. Boucadair, X. Li | Proposed Standard | October 2010 |
| 6056 | Recommendations for Transport-Protocol Port RandomizationM. Larsen, F. Gont | Best Current Practice | January 2011 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6144 | Framework for IPv4/IPv6 TranslationF. Baker, X. Li, C. Bao, K. Yin | Informational | April 2011 |
| 6145 | IP/ICMP Translation AlgorithmX. Li, C. Bao, F. Baker · obsoleted by RFC 7915 | Proposed Standard | April 2011 |
| 6146 | Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6147 | DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, A. Sullivan, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6157 | IPv6 Transition in the Session Initiation Protocol (SIP)G. Camarillo, K. El Malki, V. Gurbani | Proposed Standard | April 2011 |
| 6346 | The Address plus Port (A+P) Approach to the IPv4 Address ShortageR. Bush, Ed. | Experimental | August 2011 |
| 6384 | An FTP Application Layer Gateway (ALG) for IPv6-to-IPv4 TranslationI. van Beijnum | Proposed Standard | October 2011 |
| 6459 | IPv6 in 3rd Generation Partnership Project (3GPP) Evolved Packet System (EPS)J. Korhonen, Ed., J. Soininen, B. Patil, T. Savolainen, G. Bajko, K. Iisakkila | Informational | January 2012 |
| 6555 | Happy Eyeballs: Success with Dual-Stack HostsD. Wing, A. Yourtchenko · obsoleted by RFC 8305 | Proposed Standard | April 2012 |
| 6586 | Experiences from an IPv6-Only NetworkJ. Arkko, A. Keranen | Informational | April 2012 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 6877 | 464XLAT: Combination of Stateful and Stateless TranslationM. Mawatari, M. Kawashima, C. Byrne | Informational | April 2013 |
| 6883 | IPv6 Guidance for Internet Content Providers and Application Service ProvidersB. Carpenter, S. Jiang | Informational | March 2013 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 6946 | Processing of IPv6 "Atomic" FragmentsF. Gont | Proposed Standard | May 2013 |
| 6967 | Analysis of Potential Solutions for Revealing a Host Identifier (HOST_ID) in Shared Address DeploymentsM. Boucadair, J. Touch, P. Levis, R. Penno | Informational | June 2013 |
| 7050 | Discovery of the IPv6 Prefix Used for IPv6 Address SynthesisT. Savolainen, J. Korhonen, D. Wing | Proposed Standard | November 2013 |
| 7239 | Forwarded HTTP ExtensionA. Petersson, M. Nilsson | Proposed Standard | June 2014 |