| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 8936 | Poll-Based Security Event Token (SET) Delivery Using HTTPA. Backman, Ed., M. Jones, Ed., M. Scurtescu, M. Ansari, A. Nadalin | Proposed Standard | November 2020 |
| 8935 | Push-Based Security Event Token (SET) Delivery Using HTTPA. Backman, Ed., M. Jones, Ed., M. Scurtescu, M. Ansari, A. Nadalin | Proposed Standard | November 2020 |
| 8887 | A JSON Meta Application Protocol (JMAP) Subprotocol for WebSocketK. Murchison | Proposed Standard | August 2020 |
| 8835 | Transports for WebRTCH. Alvestrand | Proposed Standard | January 2021 |
| 8802 | The Quality for Service (Q4S) ProtocolJ.J. Aranda, M. Cortes, J. Salvachúa, M. Narganes, I. Martínez-Sarriegui | Informational | July 2020 |
| 8565 | Hypertext Jeopardy Protocol (HTJP/1.0)E. Fokschaner | Informational | 1 April 2019 |
| 8484 | DNS Queries over HTTPS (DoH)P. Hoffman, P. McManus | Proposed Standard | October 2018 |
| 8292 | Voluntary Application Server Identification (VAPID) for Web PushM. Thomson, P. Beverloo | Proposed Standard | November 2017 |
| 8280 | Research into Human Rights Protocol ConsiderationsN. ten Oever, C. Cath | Informational | October 2017 |
| 8188 | Encrypted Content-Encoding for HTTPM. Thomson | Proposed Standard | June 2017 |
| 8120 | Mutual Authentication Protocol for HTTPY. Oiwa, H. Watanabe, H. Takagi, K. Maeda, T. Hayashi, Y. Ioku | Experimental | April 2017 |
| 8095 | Services Provided by IETF Transport Protocols and Congestion Control MechanismsG. Fairhurst, Ed., B. Trammell, Ed., M. Kuehlewind, Ed. | Informational | March 2017 |
| 8075 | Guidelines for Mapping Implementations: HTTP to the Constrained Application Protocol (CoAP)A. Castellani, S. Loreto, A. Rahman, T. Fossati, E. Dijk | Proposed Standard | February 2017 |
| 8053 | HTTP Authentication Extensions for Interactive ClientsY. Oiwa, H. Watanabe, H. Takagi, K. Maeda, T. Hayashi, Y. Ioku | Experimental | January 2017 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8010 | Internet Printing Protocol/1.1: Encoding and TransportM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 7977 | The WebSocket Protocol as a Transport for the Message Session Relay Protocol (MSRP)P. Dunkley, G. Llewellyn, V. Pascual, G. Salgueiro, R. Ravindranath | Proposed Standard | September 2016 |
| 7937 | Content Distribution Network Interconnection (CDNI) Logging InterfaceF. Le Faucheur, Ed., G. Bertrand, Ed., I. Oprescu, Ed., R. Peterkofsky | Proposed Standard | August 2016 |
| 7878 | Session Peering Provisioning (SPP) Protocol over SOAPK. Cartwright, V. Bhatia, J-F. Mule, A. Mayrhofer | Proposed Standard | August 2016 |
| 7826 | Real-Time Streaming Protocol Version 2.0H. Schulzrinne, A. Rao, R. Lanphier, M. Westerlund, M. Stiemerling, Ed. | Proposed Standard | December 2016 |
| 7808 | Time Zone Data Distribution ServiceM. Douglass, C. Daboo | Proposed Standard | March 2016 |
| 7804 | Salted Challenge Response HTTP Authentication MechanismA. Melnikov | Experimental | March 2016 |
| 7644 | System for Cross-domain Identity Management: ProtocolP. Hunt, Ed., K. Grizzle, M. Ansari, E. Wahlstroem, C. Mortimore | Proposed Standard | September 2015 |
| 7617 | The 'Basic' HTTP Authentication SchemeJ. Reschke | Proposed Standard | September 2015 |
| 7616 | HTTP Digest Access AuthenticationR. Shekh-Yusef, Ed., D. Ahrens, S. Bremer | Proposed Standard | September 2015 |
| 7615 | HTTP Authentication-Info and Proxy-Authentication-Info Response Header FieldsJ. Reschke · obsoleted by RFC 9110 | Proposed Standard | September 2015 |
| 7612 | Lightweight Directory Access Protocol (LDAP): Schema for Printer ServicesP. Fleming, I. McDonald | Informational | June 2015 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7486 | HTTP Origin-Bound Authentication (HOBA)S. Farrell, P. Hoffman, M. Thomas | Experimental | March 2015 |
| 7481 | Security Services for the Registration Data Access Protocol (RDAP)S. Hollenbeck, N. Kong | Internet Standard | March 2015 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7236 | Initial Hypertext Transfer Protocol (HTTP) Authentication Scheme RegistrationsJ. Reschke | Informational | June 2014 |
| 7234 | Hypertext Transfer Protocol (HTTP/1.1): CachingR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. · obsoleted by RFC 9111 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |