| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 8802 | The Quality for Service (Q4S) ProtocolJ.J. Aranda, M. Cortes, J. Salvachúa, M. Narganes, I. Martínez-Sarriegui | Informational | July 2020 |
| 8565 | Hypertext Jeopardy Protocol (HTJP/1.0)E. Fokschaner | Informational | 1 April 2019 |
| 8484 | DNS Queries over HTTPS (DoH)P. Hoffman, P. McManus | Proposed Standard | October 2018 |
| 8280 | Research into Human Rights Protocol ConsiderationsN. ten Oever, C. Cath | Informational | October 2017 |
| 8246 | HTTP Immutable ResponsesP. McManus | Proposed Standard | September 2017 |
| 8182 | The RPKI Repository Delta Protocol (RRDP)T. Bruijnzeels, O. Muravskiy, B. Weber, R. Austein | Proposed Standard | July 2017 |
| 8164 | Opportunistic Security for HTTP/2M. Nottingham, M. Thomson | Historic | May 2017 |
| 8144 | Use of the Prefer Header Field in Web Distributed Authoring and Versioning (WebDAV)K. Murchison | Proposed Standard | April 2017 |
| 8095 | Services Provided by IETF Transport Protocols and Congestion Control MechanismsG. Fairhurst, Ed., B. Trammell, Ed., M. Kuehlewind, Ed. | Informational | March 2017 |
| 8075 | Guidelines for Mapping Implementations: HTTP to the Constrained Application Protocol (CoAP)A. Castellani, S. Loreto, A. Rahman, T. Fossati, E. Dijk | Proposed Standard | February 2017 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8030 | Generic Event Delivery Using HTTP PushM. Thomson, E. Damaggio, B. Raymor, Ed. | Proposed Standard | December 2016 |
| 8010 | Internet Printing Protocol/1.1: Encoding and TransportM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 8007 | Content Delivery Network Interconnection (CDNI) Control Interface / TriggersR. Murray, B. Niven-Jenkins | Proposed Standard | December 2016 |
| 7937 | Content Distribution Network Interconnection (CDNI) Logging InterfaceF. Le Faucheur, Ed., G. Bertrand, Ed., I. Oprescu, Ed., R. Peterkofsky | Proposed Standard | August 2016 |
| 7826 | Real-Time Streaming Protocol Version 2.0H. Schulzrinne, A. Rao, R. Lanphier, M. Westerlund, M. Stiemerling, Ed. | Proposed Standard | December 2016 |
| 7808 | Time Zone Data Distribution ServiceM. Douglass, C. Daboo | Proposed Standard | March 2016 |
| 7644 | System for Cross-domain Identity Management: ProtocolP. Hunt, Ed., K. Grizzle, M. Ansari, E. Wahlstroem, C. Mortimore | Proposed Standard | September 2015 |
| 7643 | System for Cross-domain Identity Management: Core SchemaP. Hunt, Ed., K. Grizzle, E. Wahlstroem, C. Mortimore | Proposed Standard | September 2015 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7239 | Forwarded HTTP ExtensionA. Petersson, M. Nilsson | Proposed Standard | June 2014 |
| 7234 | Hypertext Transfer Protocol (HTTP/1.1): CachingR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. · obsoleted by RFC 9111 | Proposed Standard | June 2014 |
| 7233 | Hypertext Transfer Protocol (HTTP/1.1): Range RequestsR. Fielding, Ed., Y. Lafon, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |