| 1112 | Host extensions for IP multicastingS.E. Deering | Internet Standard | August 1989 |
| 2326 | Real Time Streaming Protocol (RTSP)H. Schulzrinne, A. Rao, R. Lanphier · obsoleted by RFC 7826 | Proposed Standard | April 1998 |
| 3365 | Strong Security Requirements for Internet Engineering Task Force Standard ProtocolsJ. Schiller | Best Current Practice | August 2002 |
| 3550 | RTP: A Transport Protocol for Real-Time ApplicationsH. Schulzrinne, S. Casner, R. Frederick, V. Jacobson | Internet Standard | July 2003 |
| 3640 | RTP Payload Format for Transport of MPEG-4 Elementary StreamsJ. van der Meer, D. Mackie, V. Swaminathan, D. Singer, P. Gentric | Proposed Standard | December 2003 |
| 3711 | The Secure Real-time Transport Protocol (SRTP)M. Baugher, D. McGrew, M. Naslund, E. Carrara, K. Norrman | Proposed Standard | March 2004 |
| 3830 | MIKEY: Multimedia Internet KEYingJ. Arkko, E. Carrara, F. Lindholm, M. Naslund, K. Norrman | Proposed Standard | August 2004 |
| 4107 | Guidelines for Cryptographic Key ManagementS. Bellovin, R. Housley | Best Current Practice | June 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4383 | The Use of Timed Efficient Stream Loss-Tolerant Authentication (TESLA) in the Secure Real-time Transport Protocol (SRTP)M. Baugher, E. Carrara | Proposed Standard | February 2006 |
| 4474 | Enhancements for Authenticated Identity Management in the Session Initiation Protocol (SIP)J. Peterson, C. Jennings · obsoleted by RFC 8224 | Proposed Standard | August 2006 |
| 4566 | SDP: Session Description ProtocolM. Handley, V. Jacobson, C. Perkins · obsoleted by RFC 8866 | Proposed Standard | July 2006 |
| 4567 | Key Management Extensions for Session Description Protocol (SDP) and Real Time Streaming Protocol (RTSP)J. Arkko, F. Lindholm, M. Naslund, K. Norrman, E. Carrara | Proposed Standard | July 2006 |
| 4568 | Session Description Protocol (SDP) Security Descriptions for Media StreamsF. Andreasen, M. Baugher, D. Wing | Proposed Standard | July 2006 |
| 4571 | Framing Real-time Transport Protocol (RTP) and RTP Control Protocol (RTCP) Packets over Connection-Oriented TransportJ. Lazzaro | Proposed Standard | July 2006 |
| 4572 | Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)J. Lennox · obsoleted by RFC 8122 | Proposed Standard | July 2006 |
| 4607 | Source-Specific Multicast for IPH. Holbrook, B. Cain | Proposed Standard | August 2006 |
| 4650 | HMAC-Authenticated Diffie-Hellman for Multimedia Internet KEYing (MIKEY)M. Euchner | Proposed Standard | September 2006 |
| 4738 | MIKEY-RSA-R: An Additional Mode of Key Distribution in Multimedia Internet KEYing (MIKEY)D. Ignjatic, L. Dondeti, F. Audet, P. Lin | Proposed Standard | November 2006 |
| 4771 | Integrity Transform Carrying Roll-Over Counter for the Secure Real-time Transport Protocol (SRTP)V. Lehtovirta, M. Naslund, K. Norrman | Proposed Standard | January 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 5117 | RTP TopologiesM. Westerlund, S. Wenger · obsoleted by RFC 7667 | Informational | January 2008 |
| 5197 | On the Applicability of Various Multimedia Internet KEYing (MIKEY) Modes and ExtensionsS. Fries, D. Ignjatic | Informational | June 2008 |
| 5245 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer ProtocolsJ. Rosenberg · obsoleted by RFC 8445, RFC 8839 | Proposed Standard | April 2010 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5479 | Requirements and Analysis of Media Security Management ProtocolsD. Wing, Ed., S. Fries, H. Tschofenig, F. Audet | Informational | April 2009 |
| 5669 | The SEED Cipher Algorithm and Its Use with the Secure Real-Time Transport Protocol (SRTP)S. Yoon, J. Kim, H. Park, H. Jeong, Y. Won | Proposed Standard | August 2010 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5760 | RTP Control Protocol (RTCP) Extensions for Single-Source Multicast Sessions with Unicast FeedbackJ. Ott, J. Chesterfield, E. Schooler | Proposed Standard | February 2010 |
| 5763 | Framework for Establishing a Secure Real-time Transport Protocol (SRTP) Security Context Using Datagram Transport Layer Security (DTLS)J. Fischl, H. Tschofenig, E. Rescorla | Proposed Standard | May 2010 |
| 5764 | Datagram Transport Layer Security (DTLS) Extension to Establish Keys for the Secure Real-time Transport Protocol (SRTP)D. McGrew, E. Rescorla | Proposed Standard | May 2010 |
| 5766 | Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)R. Mahy, P. Matthews, J. Rosenberg · obsoleted by RFC 8656 | Proposed Standard | April 2010 |
| 6043 | MIKEY-TICKET: Ticket-Based Modes of Key Distribution in Multimedia Internet KEYing (MIKEY)J. Mattsson, T. Tian | Informational | March 2011 |
| 6188 | The Use of AES-192 and AES-256 in Secure RTPD. McGrew | Proposed Standard | March 2011 |
| 6189 | ZRTP: Media Path Key Agreement for Unicast Secure RTPP. Zimmermann, A. Johnston, Ed., J. Callas | Informational | April 2011 |
| 6267 | MIKEY-IBAKE: Identity-Based Authenticated Key Exchange (IBAKE) Mode of Key Distribution in Multimedia Internet KEYing (MIKEY)V. Cakulev, G. Sundaram | Informational | June 2011 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6509 | MIKEY-SAKKE: Sakai-Kasahara Key Encryption in Multimedia Internet KEYing (MIKEY)M. Groves | Informational | February 2012 |
| 6562 | Guidelines for the Use of Variable Bit Rate Audio with Secure RTPC. Perkins, JM. Valin | Proposed Standard | March 2012 |
| 6904 | Encryption of Header Extensions in the Secure Real-time Transport Protocol (SRTP)J. Lennox | Proposed Standard | April 2013 |
| 7022 | Guidelines for Choosing RTP Control Protocol (RTCP) Canonical Names (CNAMEs)A. Begen, C. Perkins, D. Wing, E. Rescorla | Proposed Standard | September 2013 |
| 7202 | Securing the RTP Framework: Why RTP Does Not Mandate a Single Media Security SolutionC. Perkins, M. Westerlund | Informational | April 2014 |