| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 4222 | Prioritized Treatment of Specific OSPF Version 2 Packets and Congestion AvoidanceG. Choudhury, Ed. | Best Current Practice | October 2005 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4552 | Authentication/Confidentiality for OSPFv3M. Gupta, N. Melam | Proposed Standard | June 2006 |
| 4822 | RIPv2 Cryptographic AuthenticationR. Atkinson, M. Fanto | Proposed Standard | February 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5310 | IS-IS Generic Cryptographic AuthenticationM. Bhatia, V. Manral, T. Li, R. Atkinson, R. White, M. Fanto | Proposed Standard | February 2009 |
| 5340 | OSPF for IPv6R. Coltun, D. Ferguson, J. Moy, A. Lindem | Proposed Standard | July 2008 |
| 5613 | OSPF Link-Local SignalingA. Zinin, A. Roy, L. Nguyen, B. Friedman, D. Yeung | Proposed Standard | August 2009 |
| 5709 | OSPFv2 HMAC-SHA Cryptographic AuthenticationM. Bhatia, V. Manral, M. Fanto, R. White, M. Barnes, T. Li, R. Atkinson | Proposed Standard | October 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5879 | Heuristics for Detecting ESP-NULL PacketsT. Kivinen, D. McDonald | Informational | May 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 6039 | Issues with Existing Cryptographic Protection Methods for Routing ProtocolsV. Manral, M. Bhatia, J. Jaeggli, R. White | Informational | October 2010 |
| 6506 | Supporting Authentication Trailer for OSPFv3M. Bhatia, V. Manral, A. Lindem · obsoleted by RFC 7166 | Proposed Standard | February 2012 |