| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 1038 | Draft revised IP security optionM. St. Johns · obsoleted by RFC 1108 | Unknown | January 1988 |
| 1063 | IP MTU discovery optionsJ.C. Mogul, C.A. Kent, C. Partridge, K. McCloghrie · obsoleted by RFC 1191 | Unknown | July 1988 |
| 1108 | U.S. Department of Defense Security Options for the Internet ProtocolS. Kent | Historic | November 1991 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1385 | EIP: The Extended Internet ProtocolZ. Wang · obsoleted by RFC 6814 | Historic | November 1992 |
| 1393 | Traceroute Using an IP OptionG. Malkin · obsoleted by RFC 6814 | Historic | January 1993 |
| 1475 | TP/IX: The Next InternetR. Ullmann · obsoleted by RFC 6814 | Historic | June 1993 |
| 1770 | IPv4 Option for Sender Directed Multi-Destination DeliveryC. Graff · obsoleted by RFC 6814 | Historic | March 1995 |
| 1812 | Requirements for IP Version 4 RoutersF. Baker, Ed. | Proposed Standard | June 1995 |
| 2113 | IP Router Alert OptionD. Katz | Proposed Standard | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2205 | Resource ReSerVation Protocol (RSVP) -- Version 1 Functional SpecificationR. Braden, Ed., L. Zhang, S. Berson, S. Herzog, S. Jamin | Proposed Standard | September 1997 |
| 2407 | The Internet IP Security Domain of Interpretation for ISAKMPD. Piper · obsoleted by RFC 4306 | Historic | November 1998 |
| 3585 | IPsec Configuration Policy Information ModelJ. Jason, L. Rafalow, E. Vyncke | Proposed Standard | August 2003 |
| 3692 | Assigning Experimental and Testing Numbers Considered UsefulT. Narten | Best Current Practice | January 2004 |
| 4306 | Internet Key Exchange (IKEv2) ProtocolC. Kaufman, Ed. · obsoleted by RFC 5996 | Proposed Standard | December 2005 |
| 4727 | Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP HeadersB. Fenner | Proposed Standard | November 2006 |
| 4782 | Quick-Start for TCP and IPS. Floyd, M. Allman, A. Jain, P. Sarolahti | Experimental | January 2007 |
| 4807 | IPsec Security Policy Database Configuration MIBM. Baer, R. Charlet, W. Hardaker, R. Story, C. Wang | Proposed Standard | March 2007 |
| 4821 | Packetization Layer Path MTU DiscoveryM. Mathis, J. Heffner | Proposed Standard | March 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 5015 | Bidirectional Protocol Independent Multicast (BIDIR-PIM)M. Handley, I. Kouvelas, T. Speakman, L. Vicisano | Proposed Standard | October 2007 |
| 5350 | IANA Considerations for the IPv4 and IPv6 Router Alert OptionsJ. Manner, A. McDonald | Proposed Standard | September 2008 |
| 5570 | Common Architecture Label IPv6 Security Option (CALIPSO)M. StJohns, R. Atkinson, G. Thomas | Informational | July 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 6192 | Protecting the Router Control PlaneD. Dugal, C. Pignataro, R. Dunn | Informational | March 2011 |
| 6274 | Security Assessment of the Internet Protocol Version 4F. Gont | Informational | July 2011 |
| 6398 | IP Router Alert Considerations and UsageF. Le Faucheur, Ed. | Best Current Practice | October 2011 |
| 6814 | Formally Deprecating Some IPv4 OptionsC. Pignataro, F. Gont | Proposed Standard | November 2012 |