| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 1933 | Transition Mechanisms for IPv6 Hosts and RoutersR. Gilligan, E. Nordmark · obsoleted by RFC 2893 | Proposed Standard | April 1996 |
| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2516 | A Method for Transmitting PPP Over Ethernet (PPPoE)L. Mamakos, K. Lidl, J. Evarts, D. Carrel, D. Simone, R. Wheeler | Informational | February 1999 |
| 2529 | Transmission of IPv6 over IPv4 Domains without Explicit TunnelsB. Carpenter, C. Jung | Proposed Standard | March 1999 |
| 2663 | IP Network Address Translator (NAT) Terminology and ConsiderationsP. Srisuresh, M. Holdrege | Informational | August 1999 |
| 2784 | Generic Routing Encapsulation (GRE)D. Farinacci, T. Li, S. Hanks, D. Meyer, P. Traina | Proposed Standard | March 2000 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 2893 | Transition Mechanisms for IPv6 Hosts and RoutersR. Gilligan, E. Nordmark · obsoleted by RFC 4213 | Proposed Standard | August 2000 |
| 3056 | Connection of IPv6 Domains via IPv4 CloudsB. Carpenter, K. Moore | Proposed Standard | February 2001 |
| 3068 | An Anycast Prefix for 6to4 Relay RoutersC. Huitema · obsoleted by RFC 7526 | Historic | June 2001 |
| 3489 | STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)J. Rosenberg, J. Weinberger, C. Huitema, R. Mahy · obsoleted by RFC 5389 | Proposed Standard | March 2003 |
| 3964 | Security Considerations for 6to4P. Savola, C. Patel | Informational | December 2004 |
| 4213 | Basic Transition Mechanisms for IPv6 Hosts and RoutersE. Nordmark, R. Gilligan | Proposed Standard | October 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4380 | Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)C. Huitema | Proposed Standard | February 2006 |
| 4787 | Network Address Translation (NAT) Behavioral Requirements for Unicast UDPF. Audet, Ed., C. Jennings | Best Current Practice | January 2007 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4891 | Using IPsec to Secure IPv6-in-IPv4 TunnelsR. Graveman, M. Parthasarathy, P. Savola, H. Tschofenig | Informational | May 2007 |
| 5214 | Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)F. Templin, T. Gleeson, D. Thaler | Informational | March 2008 |
| 5389 | Session Traversal Utilities for NAT (STUN)J. Rosenberg, R. Mahy, P. Matthews, D. Wing · obsoleted by RFC 8489 | Proposed Standard | October 2008 |
| 5572 | IPv6 Tunnel Broker with the Tunnel Setup Protocol (TSP)M. Blanchet, F. Parent | Experimental | February 2010 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5969 | IPv6 Rapid Deployment on IPv4 Infrastructures (6rd) -- Protocol SpecificationW. Townsley, O. Troan | Proposed Standard | August 2010 |
| 6145 | IP/ICMP Translation AlgorithmX. Li, C. Bao, F. Baker · obsoleted by RFC 7915 | Proposed Standard | April 2011 |
| 6169 | Security Concerns with IP TunnelingS. Krishnan, D. Thaler, J. Hoagland | Informational | April 2011 |
| 6333 | Dual-Stack Lite Broadband Deployments Following IPv4 ExhaustionA. Durand, R. Droms, J. Woodyatt, Y. Lee | Proposed Standard | August 2011 |
| 6343 | Advisory Guidelines for 6to4 DeploymentB. Carpenter | Informational | August 2011 |
| 6598 | IANA-Reserved IPv4 Prefix for Shared Address SpaceJ. Weil, V. Kuarsingh, C. Donley, C. Liljenstolpe, M. Azinger | Best Current Practice | April 2012 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 6732 | 6to4 Provider Managed TunnelsV. Kuarsingh, Ed., Y. Lee, O. Vautrin · obsoleted by RFC 7526 | Historic | September 2012 |
| 6751 | Native IPv6 behind IPv4-to-IPv4 NAT Customer Premises Equipment (6a44)R. Despres, Ed., B. Carpenter, D. Wing, S. Jiang | Experimental | October 2012 |
| 6830 | The Locator/ID Separation Protocol (LISP)D. Farinacci, V. Fuller, D. Meyer, D. Lewis · obsoleted by RFC 9300, RFC 9301 | Experimental | January 2013 |
| 6832 | Interworking between Locator/ID Separation Protocol (LISP) and Non-LISP SitesD. Lewis, D. Meyer, D. Farinacci, V. Fuller | Experimental | January 2013 |
| 6833 | Locator/ID Separation Protocol (LISP) Map-Server InterfaceV. Fuller, D. Farinacci · obsoleted by RFC 9301 | Experimental | January 2013 |