| 1964 | The Kerberos Version 5 GSS-API MechanismJ. Linn | Proposed Standard | June 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2743 | Generic Security Service Application Program Interface Version 2, Update 1J. Linn | Proposed Standard | January 2000 |
| 2744 | Generic Security Service API Version 2 : C-bindingsJ. Wray | Proposed Standard | January 2000 |
| 3575 | IANA Considerations for RADIUS (Remote Authentication Dial In User Service)B. Aboba | Proposed Standard | July 2003 |
| 3579 | RADIUS (Remote Authentication Dial In User Service) Support For Extensible Authentication Protocol (EAP)B. Aboba, P. Calhoun | Informational | September 2003 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 3961 | Encryption and Checksum Specifications for Kerberos 5K. Raeburn | Proposed Standard | February 2005 |
| 4072 | Diameter Extensible Authentication Protocol (EAP) ApplicationP. Eronen, Ed., T. Hiller, G. Zorn | Proposed Standard | August 2005 |
| 4121 | The Kerberos Version 5 Generic Security Service Application Program Interface (GSS-API) Mechanism: Version 2L. Zhu, K. Jaganathan, S. Hartman | Proposed Standard | July 2005 |
| 4178 | The Simple and Protected Generic Security Service Application Program Interface (GSS-API) Negotiation MechanismL. Zhu, P. Leach, K. Jaganathan, W. Ingersoll | Proposed Standard | October 2005 |
| 4282 | The Network Access IdentifierB. Aboba, M. Beadles, J. Arkko, P. Eronen · obsoleted by RFC 7542 | Proposed Standard | December 2005 |
| 4401 | A Pseudo-Random Function (PRF) API Extension for the Generic Security Service Application Program Interface (GSS-API)N. Williams | Proposed Standard | February 2006 |
| 4402 | A Pseudo-Random Function (PRF) for the Kerberos V Generic Security Service Application Program Interface (GSS-API) MechanismN. Williams · obsoleted by RFC 7802 | Historic | February 2006 |
| 4422 | Simple Authentication and Security Layer (SASL)A. Melnikov, Ed., K. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4462 | Generic Security Service Application Program Interface (GSS-API) Authentication and Key Exchange for the Secure Shell (SSH) ProtocolJ. Hutzelman, J. Salowey, J. Galbraith, V. Welch | Proposed Standard | May 2006 |
| 4559 | SPNEGO-based Kerberos and NTLM HTTP Authentication in Microsoft WindowsK. Jaganathan, L. Zhu, J. Brezak | Informational | June 2006 |
| 5056 | On the Use of Channel Bindings to Secure ChannelsN. Williams | Proposed Standard | November 2007 |
| 5178 | Generic Security Service Application Program Interface (GSS-API) Internationalization and Domain-Based Service Names and Name TypeN. Williams, A. Melnikov | Proposed Standard | May 2008 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5247 | Extensible Authentication Protocol (EAP) Key Management FrameworkB. Aboba, D. Simon, P. Eronen | Proposed Standard | August 2008 |
| 5554 | Clarifications and Extensions to the Generic Security Service Application Program Interface (GSS-API) for the Use of Channel BindingsN. Williams | Proposed Standard | May 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5801 | Using Generic Security Service Application Program Interface (GSS-API) Mechanisms in Simple Authentication and Security Layer (SASL): The GS2 Mechanism FamilyS. Josefsson, N. Williams | Proposed Standard | July 2010 |
| 5891 | Internationalized Domain Names in Applications (IDNA): ProtocolJ. Klensin | Proposed Standard | August 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6614 | Transport Layer Security (TLS) Encryption for RADIUSS. Winter, M. McCauley, S. Venaas, K. Wierenga | Experimental | May 2012 |
| 6677 | Channel-Binding Support for Extensible Authentication Protocol (EAP) MethodsS. Hartman, Ed., T. Clancy, K. Hoeper | Proposed Standard | July 2012 |
| 6929 | Remote Authentication Dial In User Service (RADIUS) Protocol ExtensionsA. DeKok, A. Lior | Proposed Standard | April 2013 |
| 7057 | Update to the Extensible Authentication Protocol (EAP) Applicability Statement for Application Bridging for Federated Access Beyond Web (ABFAB)S. Winter, J. Salowey | Proposed Standard | December 2013 |