| 1075 | Distance Vector Multicast Routing ProtocolD. Waitzman, C. Partridge, S.E. Deering | Experimental | November 1988 |
| 2710 | Multicast Listener Discovery (MLD) for IPv6S. Deering, W. Fenner, B. Haberman | Proposed Standard | October 1999 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3376 | Internet Group Management Protocol, Version 3B. Cain, S. Deering, I. Kouvelas, B. Fenner, A. Thyagarajan · obsoleted by RFC 9776 | Proposed Standard | October 2002 |
| 3493 | Basic Socket Interface Extensions for IPv6R. Gilligan, S. Thomson, J. Bound, J. McCann, W. Stevens | Informational | March 2003 |
| 3678 | Socket Interface Extensions for Multicast Source FiltersD. Thaler, B. Fenner, B. Quinn | Informational | January 2004 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4395 | Guidelines and Registration Procedures for New URI SchemesT. Hansen, T. Hardie, L. Masinter · obsoleted by RFC 7595 | Best Current Practice | February 2006 |
| 4601 | Protocol Independent Multicast - Sparse Mode (PIM-SM): Protocol Specification (Revised)B. Fenner, M. Handley, H. Holbrook, I. Kouvelas · obsoleted by RFC 7761 | Proposed Standard | August 2006 |
| 4604 | Using Internet Group Management Protocol Version 3 (IGMPv3) and Multicast Listener Discovery Protocol Version 2 (MLDv2) for Source-Specific MulticastH. Holbrook, B. Cain, B. Haberman | Proposed Standard | August 2006 |
| 5015 | Bidirectional Protocol Independent Multicast (BIDIR-PIM)M. Handley, I. Kouvelas, T. Speakman, L. Vicisano | Proposed Standard | October 2007 |
| 5058 | Explicit Multicast (Xcast) Concepts and OptionsR. Boivie, N. Feldman, Y. Imai, W. Livens, D. Ooms | Experimental | November 2007 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5757 | Multicast Mobility in Mobile IP Version 6 (MIPv6): Problem Statement and Brief SurveyT. Schmidt, M. Waehlisch, G. Fairhurst | Informational | February 2010 |
| 6219 | The China Education and Research Network (CERNET) IVI Translation Design and Deployment for the IPv4/IPv6 Coexistence and TransitionX. Li, C. Bao, M. Chen, H. Zhang, J. Wu | Informational | May 2011 |
| 6920 | Naming Things with HashesS. Farrell, D. Kutscher, C. Dannewitz, B. Ohlman, A. Keranen, P. Hallam-Baker | Proposed Standard | April 2013 |
| 7019 | Application-Layer Multicast Extensions to REsource LOcation And Discovery (RELOAD)J. Buford, M. Kolberg, Ed. | Experimental | September 2013 |