| 9911 | Common YANG Data TypesJ. Schönwälder, Ed. | Proposed Standard | December 2025 |
| 9907 | Guidelines for Authors and Reviewers of Documents Containing YANG Data ModelsA. Bierman, M. Boucadair, Ed., Q. Wu | Best Current Practice | March 2026 |
| 9903 | A YANG Data Model for OSPF Segment Routing over the MPLS Data PlaneY. Qu, A. Lindem, J. Zhang, I. Chen | Proposed Standard | December 2025 |
| 9902 | A YANG Data Model for IS-IS Segment Routing over the MPLS Data PlaneS. Litkowski, Y. Qu, A. Lindem, I. Chen, J. Tantsura | Proposed Standard | December 2025 |
| 9899 | Extensions to the YANG Data Model for Access Control Lists (ACLs)O. Gonzalez de Dios, S. Barguil, M. Boucadair, Q. Wu | Proposed Standard | December 2025 |
| 9844 | Entering IPv6 Zone Identifiers in User InterfacesB. Carpenter, R. Hinden | Proposed Standard | August 2025 |
| 9835 | A Network YANG Data Model for Attachment CircuitsM. Boucadair, Ed., R. Roberts, O. Gonzalez de Dios, S. Barguil, B. Wu | Proposed Standard | September 2025 |
| 9834 | YANG Data Models for Bearers and Attachment Circuits as a Service (ACaaS)M. Boucadair, Ed., R. Roberts, Ed., O. Gonzalez de Dios, S. Barguil, B. Wu | Proposed Standard | September 2025 |
| 9833 | A Common YANG Data Model for Attachment CircuitsM. Boucadair, Ed., R. Roberts, Ed., O. Gonzalez de Dios, S. Barguil, B. Wu | Proposed Standard | September 2025 |
| 9826 | A YANG Data Model for the Path Computation Element Communication Protocol (PCEP)D. Dhody, Ed., V. Beeram, J. Hardwick, J. Tantsura | Proposed Standard | September 2025 |
| 9825 | Extensions to OSPF for Advertising Prefix Administrative TagsA. Lindem, Ed., P. Psenak, Y. Qu | Proposed Standard | July 2025 |
| 9742 | A YANG Data Model for Syslog ManagementJ. Clarke, Ed., M. Jethanandani, Ed., C. Wildes, Ed., K. Koushik, Ed. | Proposed Standard | April 2025 |
| 9731 | A YANG Data Model for Virtual Network (VN) OperationsY. Lee, Ed., D. Dhody, Ed., D. Ceccarelli, I. Bryskin, B. Yoon | Proposed Standard | March 2025 |
| 9719 | YANG Data Model for Routing in Fat Trees (RIFT)Z. Zhang, Y. Wei, S. Ma, X. Liu, B. Rijsman | Proposed Standard | April 2025 |
| 9684 | A YANG Data Model for Challenge-Response-Based Remote Attestation (CHARRA) Procedures Using Trusted Platform Modules (TPMs)H. Birkholz, M. Eckel, S. Bhandari, E. Voit, B. Sulzen, L. Xia, T. Laffey, G. C. Fedorkow | Proposed Standard | December 2024 |
| 9675 | Delay-Tolerant Networking Management Architecture (DTNMA)E. Birrane, III, S. Heiner, E. Annis | Informational | November 2024 |
| 9648 | YANG Data Model for TCPM. Scharf, M. Jethanandani, V. Murgai | Proposed Standard | October 2024 |
| 9647 | A YANG Data Model for BabelM. Jethanandani, B. Stark | Proposed Standard | October 2024 |
| 9644 | YANG Groupings for SSH Clients and SSH ServersK. Watsen | Proposed Standard | October 2024 |
| 9643 | YANG Groupings for TCP Clients and TCP ServersK. Watsen, M. Scharf | Proposed Standard | October 2024 |
| 9640 | YANG Data Types and Groupings for CryptographyK. Watsen | Proposed Standard | October 2024 |
| 9633 | Deterministic Networking (DetNet) YANG Data ModelX. Geng, Y. Ryoo, D. Fedyk, R. Rahman, Z. Li | Proposed Standard | October 2024 |
| 9595 | YANG Schema Item iDentifier (YANG SID)M. Veillette, Ed., A. Pelov, Ed., I. Petrov, Ed., C. Bormann, M. Richardson | Proposed Standard | July 2024 |
| 9587 | YANG Data Model for OSPFv3 Extended Link State Advertisements (LSAs)A. Lindem, S. Palani, Y. Qu | Proposed Standard | June 2024 |
| 9472 | A YANG Data Model for Reporting Software Bills of Materials (SBOMs) and Vulnerability InformationE. Lear, S. Rose | Proposed Standard | October 2023 |
| 9418 | A YANG Data Model for Service AssuranceB. Claise, J. Quilbeuf, P. Lucente, P. Fasano, T. Arumugam | Proposed Standard | July 2023 |
| 9408 | A YANG Network Data Model for Service Attachment Points (SAPs)M. Boucadair, Ed., O. Gonzalez de Dios, S. Barguil, Q. Wu, V. Lopez | Proposed Standard | June 2023 |
| 9403 | A YANG Data Model for RIB ExtensionsA. Lindem, Y. Qu | Proposed Standard | November 2023 |
| 9398 | A YANG Data Model for Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Proxy DevicesH. Zhao, X. Liu, Y. Liu, M. Panchanathan, M. Sivakumar | Proposed Standard | May 2023 |
| 9375 | A YANG Data Model for Network and VPN Service Performance MonitoringB. Wu, Ed., Q. Wu, Ed., M. Boucadair, Ed., O. Gonzalez de Dios, B. Wen | Proposed Standard | April 2023 |
| 9348 | A YANG Data Model for IP Traffic Flow SecurityD. Fedyk, C. Hopps | Proposed Standard | January 2023 |
| 9314 | YANG Data Model for Bidirectional Forwarding Detection (BFD)M. Jethanandani, Ed., R. Rahman, Ed., L. Zheng, Ed., S. Pallagatti, G. Mirsky | Proposed Standard | September 2022 |
| 9296 | ifStackTable for the Point-to-Point (P2P) Interface over a LAN Type: Definition and ExamplesD. Liu, J. Halpern, C. Zhang | Informational | August 2022 |
| 9291 | A YANG Network Data Model for Layer 2 VPNsM. Boucadair, Ed., O. Gonzalez de Dios, Ed., S. Barguil, L. Munoz | Proposed Standard | September 2022 |
| 9254 | Encoding of Data Modeled with YANG in the Concise Binary Object Representation (CBOR)M. Veillette, Ed., I. Petrov, Ed., A. Pelov, C. Bormann, M. Richardson | Proposed Standard | July 2022 |
| 9249 | A YANG Data Model for NTPN. Wu, D. Dhody, Ed., A. Sinha, Ed., A. Kumar S N, Y. Zhao | Proposed Standard | July 2022 |
| 9244 | Distributed Denial-of-Service Open Threat Signaling (DOTS) TelemetryM. Boucadair, Ed., T. Reddy.K, Ed., E. Doron, M. Chen, J. Shallow | Proposed Standard | June 2022 |
| 9243 | A YANG Data Model for DHCPv6 ConfigurationI. Farrer, Ed. | Proposed Standard | June 2022 |
| 9195 | A File Format for YANG Instance DataB. Lengyel, B. Claise | Proposed Standard | February 2022 |
| 9182 | A YANG Network Data Model for Layer 3 VPNsS. Barguil, O. Gonzalez de Dios, Ed., M. Boucadair, Ed., L. Munoz, A. Aguado | Proposed Standard | February 2022 |
| 9181 | A Common YANG Data Model for Layer 2 and Layer 3 VPNsS. Barguil, O. Gonzalez de Dios, Ed., M. Boucadair, Ed., Q. Wu | Proposed Standard | February 2022 |
| 9179 | A YANG Grouping for Geographic LocationsC. Hopps | Proposed Standard | February 2022 |
| 9166 | A YANG Data Model for Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) SnoopingH. Zhao, X. Liu, Y. Liu, A. Peter, M. Sivakumar | Proposed Standard | February 2022 |
| 9164 | Concise Binary Object Representation (CBOR) Tags for IPv4 and IPv6 Addresses and PrefixesM. Richardson, C. Bormann | Proposed Standard | December 2021 |
| 9144 | Comparison of Network Management Datastore Architecture (NMDA) DatastoresA. Clemm, Y. Qu, J. Tantsura, A. Bierman | Proposed Standard | December 2021 |
| 9132 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationM. Boucadair, Ed., J. Shallow, T. Reddy.K | Proposed Standard | September 2021 |
| 9130 | YANG Data Model for the IS-IS ProtocolS. Litkowski, Ed., D. Yeung, A. Lindem, J. Zhang, L. Lhotka | Proposed Standard | October 2022 |
| 9129 | YANG Data Model for the OSPF ProtocolD. Yeung, Y. Qu, Z. Zhang, I. Chen, A. Lindem | Proposed Standard | October 2022 |
| 9128 | YANG Data Model for Protocol Independent Multicast (PIM)X. Liu, P. McAllister, A. Peter, M. Sivakumar, Y. Liu, F. Hu | Proposed Standard | October 2022 |
| 9127 | YANG Data Model for Bidirectional Forwarding Detection (BFD)R. Rahman, Ed., L. Zheng, Ed., M. Jethanandani, Ed., S. Pallagatti, G. Mirsky | Proposed Standard | October 2021 |
| 9105 | A YANG Data Model for Terminal Access Controller Access-Control System Plus (TACACS+)B. Wu, Ed., G. Zheng, M. Wang, Ed. · obsoleted by RFC 9950 | Proposed Standard | August 2021 |
| 9070 | YANG Data Model for MPLS LDPK. Raza, Ed., R. Asati, X. Liu, S. Esale, X. Chen, H. Shah | Proposed Standard | March 2022 |
| 9067 | A YANG Data Model for Routing PolicyY. Qu, J. Tantsura, A. Lindem, X. Liu | Proposed Standard | October 2021 |
| 9066 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Call HomeT. Reddy.K, M. Boucadair, Ed., J. Shallow | Proposed Standard | December 2021 |
| 9061 | A YANG Data Model for IPsec Flow Protection Based on Software-Defined Networking (SDN)R. Marin-Lopez, G. Lopez-Millan, F. Pereniguez-Garcia | Proposed Standard | July 2021 |
| 9020 | YANG Data Model for Segment RoutingS. Litkowski, Y. Qu, A. Lindem, P. Sarkar, J. Tantsura | Proposed Standard | May 2021 |
| 8960 | A YANG Data Model for MPLS BaseT. Saad, K. Raza, R. Gandhi, X. Liu, V. Beeram | Proposed Standard | December 2020 |
| 8944 | A YANG Data Model for Layer 2 Network TopologiesJ. Dong, X. Wei, Q. Wu, M. Boucadair, A. Liu | Proposed Standard | November 2020 |
| 8916 | A YANG Data Model for the Multicast Source Discovery Protocol (MSDP)X. Liu, Z. Zhang, Ed., A. Peter, M. Sivakumar, F. Guo, P. McAllister | Proposed Standard | October 2020 |
| 8913 | Two-Way Active Measurement Protocol (TWAMP) YANG Data ModelR. Civil, A. Morton, R. Rahman, M. Jethanandani, K. Pentikousis, Ed. | Proposed Standard | November 2021 |
| 8912 | Initial Performance Metrics Registry EntriesA. Morton, M. Bagnulo, P. Eardley, K. D'Souza | Proposed Standard | November 2021 |
| 8911 | Registry for Performance MetricsM. Bagnulo, B. Claise, P. Eardley, A. Morton, A. Akhter | Proposed Standard | November 2021 |
| 8877 | Guidelines for Defining Packet TimestampsT. Mizrahi, J. Fabini, A. Morton | Informational | September 2020 |
| 8795 | YANG Data Model for Traffic Engineering (TE) TopologiesX. Liu, I. Bryskin, V. Beeram, T. Saad, H. Shah, O. Gonzalez de Dios | Proposed Standard | August 2020 |
| 8783 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Data Channel SpecificationM. Boucadair, Ed., T. Reddy.K, Ed. | Proposed Standard | May 2020 |
| 8782 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationT. Reddy.K, Ed., M. Boucadair, Ed., P. Patil, A. Mortensen, N. Teague · obsoleted by RFC 9132 | Proposed Standard | May 2020 |
| 8776 | Common YANG Data Types for Traffic EngineeringT. Saad, R. Gandhi, X. Liu, V. Beeram, I. Bryskin | Proposed Standard | June 2020 |
| 8695 | A YANG Data Model for the Routing Information Protocol (RIP)X. Liu, P. Sarda, V. Choudhary | Proposed Standard | February 2020 |
| 8676 | YANG Modules for IPv4-in-IPv6 Address plus Port (A+P) SoftwiresI. Farrer, Ed., M. Boucadair, Ed. | Proposed Standard | November 2019 |
| 8675 | A YANG Data Model for Tunnel Interface TypesM. Boucadair, I. Farrer, R. Asati | Proposed Standard | November 2019 |
| 8652 | A YANG Data Model for the Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD)X. Liu, F. Guo, M. Sivakumar, P. McAllister, A. Peter | Proposed Standard | November 2019 |
| 8641 | Subscription to YANG Notifications for Datastore UpdatesA. Clemm, E. Voit | Proposed Standard | September 2019 |
| 8639 | Subscription to YANG NotificationsE. Voit, A. Clemm, A. Gonzalez Prieto, E. Nilsen-Nygaard, A. Tripathy | Proposed Standard | September 2019 |
| 8632 | A YANG Data Model for Alarm ManagementS. Vallin, M. Bjorklund | Proposed Standard | September 2019 |
| 8575 | YANG Data Model for the Precision Time Protocol (PTP)Y. Jiang, Ed., X. Liu, J. Xu, R. Cummings, Ed. | Proposed Standard | May 2019 |
| 8572 | Secure Zero Touch Provisioning (SZTP)K. Watsen, I. Farrer, M. Abrahamsson | Proposed Standard | April 2019 |
| 8561 | A YANG Data Model for Microwave Radio LinkJ. Ahlberg, M. Ye, X. Li, D. Spreafico, M. Vaupotic | Proposed Standard | June 2019 |
| 8532 | Generic YANG Data Model for the Management of Operations, Administration, and Maintenance (OAM) Protocols That Use Connectionless CommunicationsD. Kumar, Z. Wang, Q. Wu, Ed., R. Rahman, S. Raghavan | Proposed Standard | April 2019 |
| 8531 | Generic YANG Data Model for Connection-Oriented Operations, Administration, and Maintenance (OAM) ProtocolsD. Kumar, Q. Wu, Z. Wang | Proposed Standard | April 2019 |
| 8528 | YANG Schema MountM. Bjorklund, L. Lhotka | Proposed Standard | March 2019 |
| 8526 | NETCONF Extensions to Support the Network Management Datastore ArchitectureM. Bjorklund, J. Schoenwaelder, P. Shafer, K. Watsen, R. Wilton | Proposed Standard | March 2019 |
| 8525 | YANG LibraryA. Bierman, M. Bjorklund, J. Schoenwaelder, K. Watsen, R. Wilton | Proposed Standard | March 2019 |
| 8520 | Manufacturer Usage Description SpecificationE. Lear, R. Droms, D. Romascanu | Proposed Standard | March 2019 |
| 8519 | YANG Data Model for Network Access Control Lists (ACLs)M. Jethanandani, S. Agarwal, L. Huang, D. Blair | Proposed Standard | March 2019 |
| 8513 | A YANG Data Model for Dual-Stack Lite (DS-Lite)M. Boucadair, C. Jacquenet, S. Sivakumar | Proposed Standard | January 2019 |
| 8512 | A YANG Module for Network Address Translation (NAT) and Network Prefix Translation (NPT)M. Boucadair, Ed., S. Sivakumar, C. Jacquenet, S. Vinapamula, Q. Wu | Proposed Standard | January 2019 |
| 8466 | A YANG Data Model for Layer 2 Virtual Private Network (L2VPN) Service DeliveryB. Wen, G. Fioccola, Ed., C. Xie, L. Jalil | Proposed Standard | October 2018 |
| 8431 | A YANG Data Model for the Routing Information Base (RIB)L. Wang, M. Chen, A. Dass, H. Ananthakrishnan, S. Kini, N. Bahadur | Proposed Standard | September 2018 |
| 8407 | Guidelines for Authors and Reviewers of Documents Containing YANG Data ModelsA. Bierman · obsoleted by RFC 9907 | Best Current Practice | October 2018 |
| 8366 | A Voucher Artifact for Bootstrapping ProtocolsK. Watsen, M. Richardson, M. Pritikin, T. Eckert | Proposed Standard | May 2018 |
| 8349 | A YANG Data Model for Routing Management (NMDA Version)L. Lhotka, A. Lindem, Y. Qu | Proposed Standard | March 2018 |
| 8348 | A YANG Data Model for Hardware ManagementA. Bierman, M. Bjorklund, J. Dong, D. Romascanu | Proposed Standard | March 2018 |
| 8347 | A YANG Data Model for the Virtual Router Redundancy Protocol (VRRP)X. Liu, Ed., A. Kyparlis, R. Parikh, A. Lindem, M. Zhang | Proposed Standard | March 2018 |
| 8346 | A YANG Data Model for Layer 3 TopologiesA. Clemm, J. Medved, R. Varga, X. Liu, H. Ananthakrishnan, N. Bahadur | Proposed Standard | March 2018 |
| 8345 | A YANG Data Model for Network TopologiesA. Clemm, J. Medved, R. Varga, N. Bahadur, H. Ananthakrishnan, X. Liu | Proposed Standard | March 2018 |
| 8344 | A YANG Data Model for IP ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8294 | Common YANG Data Types for the Routing AreaX. Liu, Y. Qu, A. Lindem, C. Hopps, L. Berger | Proposed Standard | December 2017 |
| 8194 | A YANG Data Model for LMAP Measurement AgentsJ. Schoenwaelder, V. Bajpai | Proposed Standard | August 2017 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8022 | A YANG Data Model for Routing ManagementL. Lhotka, A. Lindem · obsoleted by RFC 8349 | Proposed Standard | November 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 7921 | An Architecture for the Interface to the Routing SystemA. Atlas, J. Halpern, S. Hares, D. Ward, T. Nadeau | Informational | June 2016 |
| 7895 | YANG Module LibraryA. Bierman, M. Bjorklund, K. Watsen · obsoleted by RFC 8525 | Proposed Standard | June 2016 |
| 7839 | Access-Network-Identifier Option in DHCPS. Bhandari, S. Gundavelli, M. Grayson, B. Volz, J. Korhonen | Proposed Standard | June 2016 |
| 7758 | Time Capability in NETCONFT. Mizrahi, Y. Moses | Experimental | February 2016 |
| 7407 | A YANG Data Model for SNMP ConfigurationM. Bjorklund, J. Schoenwaelder | Proposed Standard | December 2014 |
| 7317 | A YANG Data Model for System ManagementA. Bierman, M. Bjorklund | Proposed Standard | August 2014 |
| 7277 | A YANG Data Model for IP ManagementM. Bjorklund · obsoleted by RFC 8344 | Proposed Standard | June 2014 |
| 7223 | A YANG Data Model for Interface ManagementM. Bjorklund · obsoleted by RFC 8343 | Proposed Standard | May 2014 |