| 882 | Domain names: Concepts and facilitiesP. Mockapetris · obsoleted by RFC 1034, RFC 1035 | Unknown | November 1983 |
| 883 | Domain names: Implementation specificationP. Mockapetris · obsoleted by RFC 1034, RFC 1035 | Unknown | November 1983 |
| 974 | Mail routing and the domain systemC. Partridge · obsoleted by RFC 2821 | Historic | January 1986 |
| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1464 | Using the Domain Name System To Store Arbitrary String AttributesR. Rosenbaum | Experimental | May 1993 |
| 1530 | Principles of Operation for the TPC.INT Subdomain: General Principles and PolicyC. Malamud, M. Rose | Informational | October 1993 |
| 1794 | DNS Support for Load BalancingT. Brisco | Informational | April 1995 |
| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 1995 | Incremental Zone Transfer in DNSM. Ohta | Proposed Standard | August 1996 |
| 2052 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie · obsoleted by RFC 2782 | Experimental | October 1996 |
| 2168 | Resolution of Uniform Resource Identifiers using the Domain Name SystemR. Daniel, M. Mealling · obsoleted by RFC 3401, RFC 3402, RFC 3403, RFC 3404 | Experimental | June 1997 |
| 2181 | Clarifications to the DNS SpecificationR. Elz, R. Bush | Proposed Standard | July 1997 |
| 2397 | The "data" URL schemeL. Masinter | Proposed Standard | August 1998 |
| 2671 | Extension Mechanisms for DNS (EDNS0)P. Vixie · obsoleted by RFC 6891 | Proposed Standard | August 1999 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 2826 | IAB Technical Comment on the Unique DNS RootInternet Architecture Board | Informational | May 2000 |
| 2845 | Secret Key Transaction Authentication for DNS (TSIG)P. Vixie, O. Gudmundsson, D. Eastlake 3rd, B. Wellington · obsoleted by RFC 8945 | Proposed Standard | May 2000 |
| 2915 | The Naming Authority Pointer (NAPTR) DNS Resource RecordM. Mealling, R. Daniel · obsoleted by RFC 3401, RFC 3402, RFC 3403, RFC 3404 | Proposed Standard | September 2000 |
| 2916 | E.164 number and DNSP. Faltstrom · obsoleted by RFC 3761 | Proposed Standard | September 2000 |
| 3007 | Secure Domain Name System (DNS) Dynamic UpdateB. Wellington | Proposed Standard | November 2000 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3263 | Session Initiation Protocol (SIP): Locating SIP ServersJ. Rosenberg, H. Schulzrinne | Proposed Standard | July 2002 |
| 3401 | Dynamic Delegation Discovery System (DDDS) Part One: The Comprehensive DDDSM. Mealling | Informational | October 2002 |
| 3402 | Dynamic Delegation Discovery System (DDDS) Part Two: The AlgorithmM. Mealling | Proposed Standard | October 2002 |
| 3403 | Dynamic Delegation Discovery System (DDDS) Part Three: The Domain Name System (DNS) DatabaseM. Mealling | Proposed Standard | October 2002 |
| 3596 | DNS Extensions to Support IP Version 6S. Thomson, C. Huitema, V. Ksinant, M. Souissi | Internet Standard | October 2003 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4367 | What's in a Name: False Assumptions about DNS NamesJ. Rosenberg, Ed., IAB | Informational | February 2006 |
| 4398 | Storing Certificates in the Domain Name System (DNS)S. Josefsson | Proposed Standard | March 2006 |
| 4732 | Internet Denial-of-Service ConsiderationsM. Handley, Ed., E. Rescorla, Ed., IAB | Informational | December 2006 |
| 4985 | Internet X.509 Public Key Infrastructure Subject Alternative Name for Expression of Service NameS. Santesson | Proposed Standard | August 2007 |
| 5486 | Session Peering for Multimedia Interconnect (SPEERMINT) TerminologyD. Malas, Ed., D. Meyer, Ed. | Informational | March 2009 |
| 5507 | Design Choices When Expanding the DNSIAB, P. Faltstrom, Ed., R. Austein, Ed., P. Koch, Ed. | Informational | April 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5922 | Domain Certificates in the Session Initiation Protocol (SIP)V. Gurbani, S. Lawrence, A. Jeffrey | Proposed Standard | June 2010 |
| 6055 | IAB Thoughts on Encodings for Internationalized Domain NamesD. Thaler, J. Klensin, S. Cheshire | Informational | February 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6269 | Issues with IP Address SharingM. Ford, Ed., M. Boucadair, A. Durand, P. Levis, P. Roberts | Informational | June 2011 |
| 6376 | DomainKeys Identified Mail (DKIM) SignaturesD. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed. | Internet Standard | September 2011 |
| 6394 | Use Cases and Requirements for DNS-Based Authentication of Named Entities (DANE)R. Barnes | Informational | October 2011 |
| 6763 | DNS-Based Service DiscoveryS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6891 | Extension Mechanisms for DNS (EDNS(0))J. Damas, M. Graff, P. Vixie | Internet Standard | April 2013 |