| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1123 | Requirements for Internet Hosts - Application and SupportR. Braden, Ed. | Internet Standard | October 1989 |
| 2277 | IETF Policy on Character Sets and LanguagesH. Alvestrand | Best Current Practice | January 1998 |
| 3490 | Internationalizing Domain Names in Applications (IDNA)P. Faltstrom, P. Hoffman, A. Costello · obsoleted by RFC 5890, RFC 5891 | Proposed Standard | March 2003 |
| 3492 | Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)A. Costello | Proposed Standard | March 2003 |
| 3493 | Basic Socket Interface Extensions for IPv6R. Gilligan, S. Thomson, J. Bound, J. McCann, W. Stevens | Informational | March 2003 |
| 3696 | Application Techniques for Checking and Transformation of NamesJ. Klensin | Informational | February 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4007 | IPv6 Scoped Address ArchitectureS. Deering, B. Haberman, T. Jinmei, E. Nordmark, B. Zill | Proposed Standard | March 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4790 | Internet Application Protocol Collation RegistryC. Newman, M. Duerst, A. Gulbrandsen | Proposed Standard | March 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5321 | Simple Mail Transfer ProtocolJ. Klensin | Draft Standard | October 2008 |
| 5322 | Internet Message FormatP. Resnick, Ed. | Draft Standard | October 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5952 | A Recommendation for IPv6 Address Text RepresentationS. Kawamura, M. Kawashima | Proposed Standard | August 2010 |
| 6055 | IAB Thoughts on Encodings for Internationalized Domain NamesD. Thaler, J. Klensin, S. Cheshire | Informational | February 2011 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6335 | Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number RegistryM. Cotton, L. Eggert, J. Touch, M. Westerlund, S. Cheshire | Best Current Practice | August 2011 |
| 6530 | Overview and Framework for Internationalized EmailJ. Klensin, Y. Ko | Proposed Standard | February 2012 |
| 6532 | Internationalized Email HeadersA. Yang, S. Steele, N. Freed | Proposed Standard | February 2012 |
| 6818 | Updates to the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileP. Yee | Proposed Standard | January 2013 |
| 6874 | Representing IPv6 Zone Identifiers in Address Literals and Uniform Resource IdentifiersB. Carpenter, S. Cheshire, R. Hinden · obsoleted by RFC 9844 | Proposed Standard | February 2013 |
| 6885 | Stringprep Revision and Problem Statement for the Preparation and Comparison of Internationalized Strings (PRECIS)M. Blanchet, A. Sullivan | Informational | March 2013 |