| 2045 | Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message BodiesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 3766 | Determining Strengths For Public Keys Used For Exchanging Symmetric KeysH. Orman, P. Hoffman | Best Current Practice | April 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4395 | Guidelines and Registration Procedures for New URI SchemesT. Hansen, T. Hardie, L. Masinter · obsoleted by RFC 7595 | Best Current Practice | February 2006 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 4773 | Administration of the IANA Special Purpose IPv6 Address BlockG. Huston · obsoleted by RFC 6890 | Informational | December 2006 |
| 4843 | An IPv6 Prefix for Overlay Routable Cryptographic Hash Identifiers (ORCHID)P. Nikander, J. Laganier, F. Dupont · obsoleted by RFC 7343 | Experimental | April 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5513 | IANA Considerations for Three Letter AcronymsA. Farrel | Informational | 1 April 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5785 | Defining Well-Known Uniform Resource Identifiers (URIs)M. Nottingham, E. Hammer-Lahav · obsoleted by RFC 8615 | Proposed Standard | April 2010 |
| 6149 | MD2 to Historic StatusS. Turner, L. Chen | Informational | March 2011 |
| 6150 | MD4 to Historic StatusS. Turner, L. Chen | Informational | March 2011 |
| 6151 | Updated Security Considerations for the MD5 Message-Digest and the HMAC-MD5 AlgorithmsS. Turner, L. Chen | Informational | March 2011 |
| 6454 | The Web Origin ConceptA. Barth | Proposed Standard | December 2011 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6797 | HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. Barth | Proposed Standard | November 2012 |
| 6838 | Media Type Specifications and Registration ProceduresN. Freed, J. Klensin, T. Hansen | Best Current Practice | January 2013 |