| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3542 | Advanced Sockets Application Program Interface (API) for IPv6W. Stevens, M. Thomas, E. Nordmark, T. Jinmei | Informational | June 2003 |
| 4584 | Extension to Sockets API for Mobile IPv6S. Chakrabarti, E. Nordmark | Informational | July 2006 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6181 | Threat Analysis for TCP Extensions for Multipath Operation with Multiple AddressesM. Bagnulo | Informational | March 2011 |
| 6182 | Architectural Guidelines for Multipath TCP DevelopmentA. Ford, C. Raiciu, M. Handley, S. Barre, J. Iyengar | Informational | March 2011 |
| 6316 | Sockets Application Program Interface (API) for Multihoming ShimM. Komu, M. Bagnulo, K. Slavov, S. Sugimoto, Ed. | Informational | July 2011 |
| 6317 | Basic Socket Interface Extensions for the Host Identity Protocol (HIP)M. Komu, T. Henderson | Experimental | July 2011 |
| 6356 | Coupled Congestion Control for Multipath Transport ProtocolsC. Raiciu, M. Handley, D. Wischik | Experimental | October 2011 |
| 6418 | Multiple Interfaces and Provisioning Domains Problem StatementM. Blanchet, P. Seite | Informational | November 2011 |
| 6419 | Current Practices for Multiple-Interface HostsM. Wasserman, P. Seite | Informational | November 2011 |
| 6458 | Sockets API Extensions for the Stream Control Transmission Protocol (SCTP)R. Stewart, M. Tuexen, K. Poon, P. Lei, V. Yasevich | Informational | December 2011 |
| 6555 | Happy Eyeballs: Success with Dual-Stack HostsD. Wing, A. Yourtchenko · obsoleted by RFC 8305 | Proposed Standard | April 2012 |
| 6824 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure · obsoleted by RFC 8684 | Experimental | January 2013 |