| 952 | DoD Internet host table specificationK. Harrenstien, M.K. Stahl, E.J. Feinler | Unknown | October 1985 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3454 | Preparation of Internationalized Strings ("stringprep")P. Hoffman, M. Blanchet · obsoleted by RFC 7564 | Proposed Standard | January 2003 |
| 3490 | Internationalizing Domain Names in Applications (IDNA)P. Faltstrom, P. Hoffman, A. Costello · obsoleted by RFC 5890, RFC 5891 | Proposed Standard | March 2003 |
| 3491 | Nameprep: A Stringprep Profile for Internationalized Domain Names (IDN)P. Hoffman, M. Blanchet · obsoleted by RFC 5891 | Proposed Standard | March 2003 |
| 3492 | Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)A. Costello | Proposed Standard | March 2003 |
| 3501 | INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1M. Crispin · obsoleted by RFC 9051 | Proposed Standard | March 2003 |
| 3530 | Network File System (NFS) version 4 ProtocolS. Shepler, B. Callaghan, D. Robinson, R. Thurlow, C. Beame, M. Eisler, D. Noveck · obsoleted by RFC 7530 | Proposed Standard | April 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3720 | Internet Small Computer Systems Interface (iSCSI)J. Satran, K. Meth, C. Sapuntzakis, M. Chadalapaka, E. Zeidner · obsoleted by RFC 7143 | Proposed Standard | April 2004 |
| 3721 | Internet Small Computer Systems Interface (iSCSI) Naming and DiscoveryM. Bakke, J. Hafner, J. Hufferd, K. Voruganti, M. Krueger | Informational | April 2004 |
| 3722 | String Profile for Internet Small Computer Systems Interface (iSCSI) NamesM. Bakke | Proposed Standard | April 2004 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 3920 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre, Ed. · obsoleted by RFC 6120 | Proposed Standard | October 2004 |
| 3922 | Mapping the Extensible Messaging and Presence Protocol (XMPP) to Common Presence and Instant Messaging (CPIM)P. Saint-Andre | Proposed Standard | October 2004 |
| 4011 | Policy Based Management MIBS. Waldbusser, J. Saperia, T. Hongal | Proposed Standard | March 2005 |
| 4013 | SASLprep: Stringprep Profile for User Names and PasswordsK. Zeilenga · obsoleted by RFC 7613 | Proposed Standard | March 2005 |
| 4279 | Pre-Shared Key Ciphersuites for Transport Layer Security (TLS)P. Eronen, Ed., H. Tschofenig, Ed. | Proposed Standard | December 2005 |
| 4314 | IMAP4 Access Control List (ACL) ExtensionA. Melnikov | Proposed Standard | December 2005 |
| 4422 | Simple Authentication and Security Layer (SASL)A. Melnikov, Ed., K. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4505 | Anonymous Simple Authentication and Security Layer (SASL) MechanismK. Zeilenga | Proposed Standard | June 2006 |
| 4511 | Lightweight Directory Access Protocol (LDAP): The ProtocolJ. Sermersheim, Ed. | Proposed Standard | June 2006 |
| 4513 | Lightweight Directory Access Protocol (LDAP): Authentication Methods and Security MechanismsR. Harrison, Ed. | Proposed Standard | June 2006 |
| 4518 | Lightweight Directory Access Protocol (LDAP): Internationalized String PreparationK. Zeilenga | Proposed Standard | June 2006 |
| 4616 | The PLAIN Simple Authentication and Security Layer (SASL) MechanismK. Zeilenga, Ed. | Proposed Standard | August 2006 |
| 4643 | Network News Transfer Protocol (NNTP) Extension for AuthenticationJ. Vinocur, K. Murchison | Proposed Standard | October 2006 |
| 4683 | Internet X.509 Public Key Infrastructure Subject Identification Method (SIM)J. Park, J. Lee, H. Lee, S. Park, T. Polk | Proposed Standard | October 2006 |
| 4690 | Review and Recommendations for Internationalized Domain Names (IDNs)J. Klensin, P. Faltstrom, C. Karp, IAB | Informational | September 2006 |
| 4790 | Internet Application Protocol Collation RegistryC. Newman, M. Duerst, A. Gulbrandsen | Proposed Standard | March 2007 |
| 4954 | SMTP Service Extension for AuthenticationR. Siemborski, Ed., A. Melnikov, Ed. | Proposed Standard | July 2007 |
| 5034 | The Post Office Protocol (POP3) Simple Authentication and Security Layer (SASL) Authentication MechanismR. Siemborski, A. Menon-Sen | Proposed Standard | July 2007 |
| 5051 | i;unicode-casemap - Simple Unicode Collation AlgorithmM. Crispin | Proposed Standard | October 2007 |
| 5054 | Using the Secure Remote Password (SRP) Protocol for TLS AuthenticationD. Taylor, T. Wu, N. Mavrogiannopoulos, T. Perrin | Informational | November 2007 |
| 5122 | Internationalized Resource Identifiers (IRIs) and Uniform Resource Identifiers (URIs) for the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre | Proposed Standard | February 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5456 | IAX: Inter-Asterisk eXchange Version 2M. Spencer, B. Capouch, E. Guy, Ed., F. Miller, K. Shumard | Informational | February 2010 |
| 5661 | Network File System (NFS) Version 4 Minor Version 1 ProtocolS. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed. · obsoleted by RFC 8881 | Proposed Standard | January 2010 |
| 5738 | IMAP Support for UTF-8P. Resnick, C. Newman · obsoleted by RFC 6855 | Experimental | March 2010 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5802 | Salted Challenge Response Authentication Mechanism (SCRAM) SASL and GSS-API MechanismsC. Newman, A. Menon-Sen, A. Melnikov, N. Williams | Proposed Standard | July 2010 |
| 5804 | A Protocol for Remotely Managing Sieve ScriptsA. Melnikov, Ed., T. Martin | Proposed Standard | July 2010 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5891 | Internationalized Domain Names in Applications (IDNA): ProtocolJ. Klensin | Proposed Standard | August 2010 |
| 5892 | The Unicode Code Points and Internationalized Domain Names for Applications (IDNA)P. Faltstrom, Ed. | Proposed Standard | August 2010 |
| 5893 | Right-to-Left Scripts for Internationalized Domain Names for Applications (IDNA)H. Alvestrand, Ed., C. Karp | Proposed Standard | August 2010 |
| 5894 | Internationalized Domain Names for Applications (IDNA): Background, Explanation, and RationaleJ. Klensin | Informational | August 2010 |
| 5895 | Mapping Characters for Internationalized Domain Names in Applications (IDNA) 2008P. Resnick, P. Hoffman | Informational | September 2010 |
| 6120 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre | Proposed Standard | March 2011 |
| 6365 | Terminology Used in Internationalization in the IETFP. Hoffman, J. Klensin | Best Current Practice | September 2011 |
| 6452 | The Unicode Code Points and Internationalized Domain Names for Applications (IDNA) - Unicode 6.0P. Faltstrom, Ed., P. Hoffman, Ed. | Proposed Standard | November 2011 |