| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1700 | Assigned NumbersJ. Reynolds, J. Postel · obsoleted by RFC 3232 | Historic | October 1994 |
| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2404 | The Use of HMAC-SHA-1-96 within ESP and AHC. Madson, R. Glenn | Proposed Standard | November 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2784 | Generic Routing Encapsulation (GRE)D. Farinacci, T. Li, S. Hanks, D. Meyer, P. Traina | Proposed Standard | March 2000 |
| 3056 | Connection of IPv6 Domains via IPv4 CloudsB. Carpenter, K. Moore | Proposed Standard | February 2001 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3232 | Assigned Numbers: RFC 1700 is Replaced by an On-line DatabaseJ. Reynolds, Ed. | Informational | January 2002 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4107 | Guidelines for Cryptographic Key ManagementS. Bellovin, R. Housley | Best Current Practice | June 2005 |
| 4192 | Procedures for Renumbering an IPv6 Network without a Flag DayF. Baker, E. Lear, R. Droms | Informational | September 2005 |
| 4632 | Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation PlanV. Fuller, T. Li | Best Current Practice | August 2006 |
| 4866 | Enhanced Route Optimization for Mobile IPv6J. Arkko, C. Vogt, W. Haddad | Proposed Standard | May 2007 |
| 4868 | Using HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512 with IPsecS. Kelly, S. Frankel | Proposed Standard | May 2007 |
| 4984 | Report from the IAB Workshop on Routing and AddressingD. Meyer, Ed., L. Zhang, Ed., K. Fall, Ed. | Informational | September 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5496 | The Reverse Path Forwarding (RPF) Vector TLVIJ. Wijnands, A. Boers, E. Rosen | Proposed Standard | March 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5944 | IP Mobility Support for IPv4, RevisedC. Perkins, Ed. | Proposed Standard | November 2010 |
| 6115 | Recommendation for a Routing ArchitectureT. Li, Ed. | Informational | February 2011 |
| 6275 | Mobility Support in IPv6C. Perkins, Ed., D. Johnson, J. Arkko | Proposed Standard | July 2011 |
| 6480 | An Infrastructure to Support Secure Internet RoutingM. Lepinski, S. Kent | Informational | February 2012 |
| 6518 | Keying and Authentication for Routing Protocols (KARP) Design GuidelinesG. Lebovitz, M. Bhatia | Informational | February 2012 |
| 6831 | The Locator/ID Separation Protocol (LISP) for Multicast EnvironmentsD. Farinacci, D. Meyer, J. Zwiebel, S. Venaas | Experimental | January 2013 |
| 6832 | Interworking between Locator/ID Separation Protocol (LISP) and Non-LISP SitesD. Lewis, D. Meyer, D. Farinacci, V. Fuller | Experimental | January 2013 |
| 6833 | Locator/ID Separation Protocol (LISP) Map-Server InterfaceV. Fuller, D. Farinacci · obsoleted by RFC 9301 | Experimental | January 2013 |
| 6834 | Locator/ID Separation Protocol (LISP) Map-VersioningL. Iannone, D. Saucez, O. Bonaventure · obsoleted by RFC 9302 | Experimental | January 2013 |
| 6835 | The Locator/ID Separation Protocol Internet Groper (LIG)D. Farinacci, D. Meyer | Informational | January 2013 |
| 6836 | Locator/ID Separation Protocol Alternative Logical Topology (LISP+ALT)V. Fuller, D. Farinacci, D. Meyer, D. Lewis | Experimental | January 2013 |
| 6837 | NERD: A Not-so-novel Endpoint ID (EID) to Routing Locator (RLOC) DatabaseE. Lear | Experimental | January 2013 |