| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3262 | Reliability of Provisional Responses in Session Initiation Protocol (SIP)J. Rosenberg, H. Schulzrinne | Proposed Standard | July 2002 |
| 3264 | An Offer/Answer Model with Session Description Protocol (SDP)J. Rosenberg, H. Schulzrinne | Proposed Standard | July 2002 |
| 3311 | The Session Initiation Protocol (SIP) UPDATE MethodJ. Rosenberg | Proposed Standard | October 2002 |
| 3428 | Session Initiation Protocol (SIP) Extension for Instant MessagingB. Campbell, Ed., J. Rosenberg, H. Schulzrinne, C. Huitema, D. Gurle | Proposed Standard | December 2002 |
| 3515 | The Session Initiation Protocol (SIP) Refer MethodR. Sparks | Proposed Standard | April 2003 |
| 3725 | Best Current Practices for Third Party Call Control (3pcc) in the Session Initiation Protocol (SIP)J. Rosenberg, J. Peterson, H. Schulzrinne, G. Camarillo | Best Current Practice | April 2004 |
| 3903 | Session Initiation Protocol (SIP) Extension for Event State PublicationA. Niemi, Ed. | Proposed Standard | November 2004 |
| 3968 | The Internet Assigned Number Authority (IANA) Header Field Parameter Registry for the Session Initiation Protocol (SIP)G. Camarillo | Best Current Practice | December 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4566 | SDP: Session Description ProtocolM. Handley, V. Jacobson, C. Perkins · obsoleted by RFC 8866 | Proposed Standard | July 2006 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6080 | A Framework for Session Initiation Protocol User Agent Profile DeliveryD. Petrie, S. Channabasappa, Ed. | Proposed Standard | March 2011 |
| 6086 | Session Initiation Protocol (SIP) INFO Method and Package FrameworkC. Holmberg, E. Burger, H. Kaplan | Proposed Standard | January 2011 |
| 6665 | SIP-Specific Event NotificationA.B. Roach | Proposed Standard | July 2012 |
| 6795 | A Session Initiation Protocol (SIP) Event Package for Session-Specific PoliciesV. Hilt, G. Camarillo | Proposed Standard | December 2012 |
| 6796 | A User Agent Profile Data Set for Media PolicyV. Hilt, G. Camarillo, J. Rosenberg, D. Worley | Proposed Standard | December 2012 |