| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1995 | Incremental Zone Transfer in DNSM. Ohta | Proposed Standard | August 1996 |
| 1996 | A Mechanism for Prompt Notification of Zone Changes (DNS NOTIFY)P. Vixie | Proposed Standard | August 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2308 | Negative Caching of DNS Queries (DNS NCACHE)M. Andrews | Proposed Standard | March 1998 |
| 3007 | Secure Domain Name System (DNS) Dynamic UpdateB. Wellington | Proposed Standard | November 2000 |
| 3375 | Generic Registry-Registrar Protocol RequirementsS. Hollenbeck | Informational | September 2002 |
| 3766 | Determining Strengths For Public Keys Used For Exchanging Symmetric KeysH. Orman, P. Hoffman | Best Current Practice | April 2004 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4509 | Use of SHA-256 in DNSSEC Delegation Signer (DS) Resource Records (RRs)W. Hardaker | Proposed Standard | May 2006 |
| 4641 | DNSSEC Operational PracticesO. Kolkman, R. Gieben · obsoleted by RFC 6781 | Informational | September 2006 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 5011 | Automated Updates of DNS Security (DNSSEC) Trust AnchorsM. StJohns | Internet Standard | September 2007 |
| 5155 | DNS Security (DNSSEC) Hashed Authenticated Denial of ExistenceB. Laurie, G. Sisson, R. Arends, D. Blacka | Proposed Standard | March 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5702 | Use of SHA-2 Algorithms with RSA in DNSKEY and RRSIG Resource Records for DNSSECJ. Jansen | Proposed Standard | October 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5910 | Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)J. Gould, S. Hollenbeck | Proposed Standard | May 2010 |
| 5933 | Use of GOST Signature Algorithms in DNSKEY and RRSIG Resource Records for DNSSECV. Dolmatov, Ed., A. Chuprina, I. Ustinov | Historic | July 2010 |
| 6605 | Elliptic Curve Digital Signature Algorithm (DSA) for DNSSECP. Hoffman, W.C.A. Wijngaards | Proposed Standard | April 2012 |