| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 814 | Name, addresses, ports, and routesD.D. Clark | Informational | July 1982 |
| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 1112 | Host extensions for IP multicastingS.E. Deering | Internet Standard | August 1989 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1498 | On the Naming and Binding of Network DestinationsJ. Saltzer | Informational | August 1993 |
| 1631 | The IP Network Address Translator (NAT)K. Egevang, P. Francis · obsoleted by RFC 3022 | Informational | May 1994 |
| 1825 | Security Architecture for the Internet ProtocolR. Atkinson · obsoleted by RFC 2401 | Proposed Standard | August 1995 |
| 1826 | IP Authentication HeaderR. Atkinson · obsoleted by RFC 2402 | Proposed Standard | August 1995 |
| 1827 | IP Encapsulating Security Payload (ESP)R. Atkinson · obsoleted by RFC 2406 | Proposed Standard | August 1995 |
| 1958 | Architectural Principles of the InternetB. Carpenter, Ed. | Informational | June 1996 |
| 1992 | The Nimrod Routing ArchitectureI. Castineyra, N. Chiappa, M. Steenstrup | Informational | August 1996 |
| 2002 | IP Mobility SupportC. Perkins, Ed. · obsoleted by RFC 3220 | Proposed Standard | October 1996 |
| 2101 | IPv4 Address Behaviour TodayB. Carpenter, J. Crowcroft, Y. Rekhter | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)P. Vixie, Ed., S. Thomson, Y. Rekhter, J. Bound | Proposed Standard | April 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2710 | Multicast Listener Discovery (MLD) for IPv6S. Deering, W. Fenner, B. Haberman | Proposed Standard | October 1999 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 2956 | Overview of 1999 IAB Network Layer WorkshopM. Kaat | Informational | October 2000 |
| 3007 | Secure Domain Name System (DNS) Dynamic UpdateB. Wellington | Proposed Standard | November 2000 |
| 3022 | Traditional IP Network Address Translator (Traditional NAT)P. Srisuresh, K. Egevang | Informational | January 2001 |
| 3027 | Protocol Complications with the IP Network Address TranslatorM. Holdrege, P. Srisuresh | Informational | January 2001 |
| 3177 | IAB/IESG Recommendations on IPv6 Address Allocations to SitesIAB, IESG · obsoleted by RFC 6177 | Informational | September 2001 |
| 3376 | Internet Group Management Protocol, Version 3B. Cain, S. Deering, I. Kouvelas, B. Fenner, A. Thyagarajan · obsoleted by RFC 9776 | Proposed Standard | October 2002 |
| 3704 | Ingress Filtering for Multihomed NetworksF. Baker, P. Savola | Best Current Practice | March 2004 |
| 3715 | IPsec-Network Address Translation (NAT) Compatibility RequirementsB. Aboba, W. Dixon | Informational | March 2004 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 3948 | UDP Encapsulation of IPsec ESP PacketsA. Huttunen, B. Swander, V. Volpe, L. DiBurro, M. Stenberg | Proposed Standard | January 2005 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |
| 3972 | Cryptographically Generated Addresses (CGA)T. Aura | Proposed Standard | March 2005 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4581 | Cryptographically Generated Addresses (CGA) Extension Field FormatM. Bagnulo, J. Arkko | Proposed Standard | October 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 4982 | Support for Multiple Hash Algorithms in Cryptographically Generated Addresses (CGAs)M. Bagnulo, J. Arkko | Proposed Standard | July 2007 |
| 4984 | Report from the IAB Workshop on Routing and AddressingD. Meyer, Ed., L. Zhang, Ed., K. Fall, Ed. | Informational | September 2007 |
| 5061 | Stream Control Transmission Protocol (SCTP) Dynamic Address ReconfigurationR. Stewart, Q. Xie, M. Tuexen, S. Maruyama, M. Kozuka | Proposed Standard | September 2007 |
| 5570 | Common Architecture Label IPv6 Security Option (CALIPSO)M. StJohns, R. Atkinson, G. Thomas | Informational | July 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5944 | IP Mobility Support for IPv4, RevisedC. Perkins, Ed. | Proposed Standard | November 2010 |
| 6177 | IPv6 Address Assignment to End SitesT. Narten, G. Huston, L. Roberts | Best Current Practice | March 2011 |
| 6250 | Evolution of the IP ModelD. Thaler | Informational | May 2011 |
| 6275 | Mobility Support in IPv6C. Perkins, Ed., D. Johnson, J. Arkko | Proposed Standard | July 2011 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 6741 | Identifier-Locator Network Protocol (ILNP) Engineering ConsiderationsRJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6742 | DNS Resource Records for the Identifier-Locator Network Protocol (ILNP)RJ Atkinson, SN Bhatti, S. Rose | Experimental | November 2012 |
| 6743 | ICMP Locator Update Message for the Identifier-Locator Network Protocol for IPv6 (ILNPv6)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6744 | IPv6 Nonce Destination Option for the Identifier-Locator Network Protocol for IPv6 (ILNPv6)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6745 | ICMP Locator Update Message for the Identifier-Locator Network Protocol for IPv4 (ILNPv4)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6746 | IPv4 Options for the Identifier-Locator Network Protocol (ILNP)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6747 | Address Resolution Protocol (ARP) for the Identifier-Locator Network Protocol for IPv4 (ILNPv4)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6748 | Optional Advanced Deployment Scenarios for the Identifier-Locator Network Protocol (ILNP)RJ Atkinson, SN Bhatti | Experimental | November 2012 |