| 1112 | Host extensions for IP multicastingS.E. Deering | Internet Standard | August 1989 |
| 1950 | ZLIB Compressed Data Format Specification version 3.3P. Deutsch, J-L. Gailly | Informational | May 1996 |
| 1951 | DEFLATE Compressed Data Format Specification version 1.3P. Deutsch | Informational | May 1996 |
| 1952 | GZIP file format specification version 4.3P. Deutsch | Informational | May 1996 |
| 2045 | Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message BodiesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2357 | IETF Criteria for Evaluating Reliable Multicast Transport and Application ProtocolsA. Mankin, A. Romanow, S. Bradner, V. Paxson | Informational | June 1998 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2974 | Session Announcement ProtocolM. Handley, C. Perkins, E. Whelan | Experimental | October 2000 |
| 3023 | XML Media TypesM. Murata, S. St. Laurent, D. Kohn · obsoleted by RFC 7303 | Proposed Standard | January 2001 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3275 | (Extensible Markup Language) XML-Signature Syntax and ProcessingD. Eastlake 3rd, J. Reagle, D. Solo | Draft Standard | March 2002 |
| 3365 | Strong Security Requirements for Internet Engineering Task Force Standard ProtocolsJ. Schiller | Best Current Practice | August 2002 |
| 3447 | Public-Key Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.1J. Jonsson, B. Kaliski · obsoleted by RFC 8017 | Informational | February 2003 |
| 3450 | Asynchronous Layered Coding (ALC) Protocol InstantiationM. Luby, J. Gemmell, L. Vicisano, L. Rizzo, J. Crowcroft · obsoleted by RFC 5775 | Experimental | December 2002 |
| 3451 | Layered Coding Transport (LCT) Building BlockM. Luby, J. Gemmell, L. Vicisano, L. Rizzo, M. Handley, J. Crowcroft · obsoleted by RFC 5651 | Experimental | December 2002 |
| 3470 | Guidelines for the Use of Extensible Markup Language (XML) within IETF ProtocolsS. Hollenbeck, M. Rose, L. Masinter | Best Current Practice | January 2003 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 3738 | Wave and Equation Based Rate Control (WEBRC) Building BlockM. Luby, V. Goyal | Experimental | April 2004 |
| 3830 | MIKEY: Multimedia Internet KEYingJ. Arkko, E. Carrara, F. Lindholm, M. Naslund, K. Norrman | Proposed Standard | August 2004 |
| 3926 | FLUTE - File Delivery over Unidirectional TransportT. Paila, M. Luby, R. Lehtonen, V. Roca, R. Walsh · obsoleted by RFC 6726 | Experimental | October 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4082 | Timed Efficient Stream Loss-Tolerant Authentication (TESLA): Multicast Source Authentication Transform IntroductionA. Perrig, D. Song, R. Canetti, J. D. Tygar, B. Briscoe | Informational | June 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4566 | SDP: Session Description ProtocolM. Handley, V. Jacobson, C. Perkins · obsoleted by RFC 8866 | Proposed Standard | July 2006 |
| 5052 | Forward Error Correction (FEC) Building BlockM. Watson, M. Luby, L. Vicisano | Proposed Standard | August 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5445 | Basic Forward Error Correction (FEC) SchemesM. Watson | Proposed Standard | March 2009 |
| 5651 | Layered Coding Transport (LCT) Building BlockM. Luby, M. Watson, L. Vicisano | Proposed Standard | October 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5751 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message SpecificationB. Ramsdell, S. Turner · obsoleted by RFC 8551 | Proposed Standard | January 2010 |
| 5775 | Asynchronous Layered Coding (ALC) Protocol InstantiationM. Luby, M. Watson, L. Vicisano | Proposed Standard | April 2010 |
| 5776 | Use of Timed Efficient Stream Loss-Tolerant Authentication (TESLA) in the Asynchronous Layered Coding (ALC) and NACK-Oriented Reliable Multicast (NORM) ProtocolsV. Roca, A. Francillon, S. Faurite | Experimental | April 2010 |
| 5905 | Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. Kasch | Proposed Standard | June 2010 |
| 6584 | Simple Authentication Schemes for the Asynchronous Layered Coding (ALC) and NACK-Oriented Reliable Multicast (NORM) ProtocolsV. Roca | Proposed Standard | April 2012 |