| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1912 | Common DNS Operational and Configuration ErrorsD. Barr | Informational | February 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)P. Vixie, Ed., S. Thomson, Y. Rekhter, J. Bound | Proposed Standard | April 1997 |
| 2181 | Clarifications to the DNS SpecificationR. Elz, R. Bush | Proposed Standard | July 1997 |
| 2317 | Classless IN-ADDR.ARPA delegationH. Eidnes, G. de Groot, P. Vixie | Best Current Practice | March 1998 |
| 2672 | Non-Terminal DNS Name RedirectionM. Crawford · obsoleted by RFC 6672 | Proposed Standard | August 1999 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 2874 | DNS Extensions to Support IPv6 Address Aggregation and RenumberingM. Crawford, C. Huitema | Historic | July 2000 |
| 3363 | Representing Internet Protocol version 6 (IPv6) Addresses in the Domain Name System (DNS)R. Bush, A. Durand, B. Fink, O. Gudmundsson, T. Hain | Informational | August 2002 |
| 3492 | Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)A. Costello | Proposed Standard | March 2003 |
| 3597 | Handling of Unknown DNS Resource Record (RR) TypesA. Gustafsson | Proposed Standard | September 2003 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4592 | The Role of Wildcards in the Domain Name SystemE. Lewis | Proposed Standard | July 2006 |
| 5155 | DNS Security (DNSSEC) Hashed Authenticated Denial of ExistenceB. Laurie, G. Sisson, R. Arends, D. Blacka | Proposed Standard | March 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |