| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 3221 | Commentary on Inter-Domain Routing in the InternetG. Huston | Informational | December 2001 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3484 | Default Address Selection for Internet Protocol version 6 (IPv6)R. Draves · obsoleted by RFC 6724 | Proposed Standard | March 2003 |
| 3582 | Goals for IPv6 Site-Multihoming ArchitecturesJ. Abley, B. Black, V. Gill | Informational | August 2003 |
| 3963 | Network Mobility (NEMO) Basic Support ProtocolV. Devarapalli, R. Wakikawa, A. Petrescu, P. Thubert | Proposed Standard | January 2005 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |
| 3972 | Cryptographically Generated Addresses (CGA)T. Aura | Proposed Standard | March 2005 |
| 4116 | IPv4 Multihoming Practices and LimitationsJ. Abley, K. Lindqvist, E. Davies, B. Black, V. Gill | Informational | July 2005 |
| 4191 | Default Router Preferences and More-Specific RoutesR. Draves, D. Thaler | Proposed Standard | November 2005 |
| 4218 | Threats Relating to IPv6 Multihoming SolutionsE. Nordmark, T. Li | Informational | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4423 | Host Identity Protocol (HIP) ArchitectureR. Moskowitz, P. Nikander · obsoleted by RFC 9063 | Informational | May 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4864 | Local Network Protection for IPv6G. Van de Velde, T. Hain, R. Droms, B. Carpenter, E. Klein | Informational | May 2007 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 4984 | Report from the IAB Workshop on Routing and AddressingD. Meyer, Ed., L. Zhang, Ed., K. Fall, Ed. | Informational | September 2007 |
| 5201 | Host Identity ProtocolR. Moskowitz, P. Nikander, P. Jokela, Ed., T. Henderson · obsoleted by RFC 7401 | Experimental | April 2008 |
| 5220 | Problem Statement for Default Address Selection in Multi-Prefix Environments: Operational Issues of RFC 3484 Default RulesA. Matsumoto, T. Fujisaki, R. Hiromi, K. Kanayama | Informational | July 2008 |
| 5533 | Shim6: Level 3 Multihoming Shim Protocol for IPv6E. Nordmark, M. Bagnulo | Proposed Standard | June 2009 |
| 5534 | Failure Detection and Locator Pair Exploration Protocol for IPv6 MultihomingJ. Arkko, I. van Beijnum | Proposed Standard | June 2009 |
| 5535 | Hash-Based Addresses (HBA)M. Bagnulo | Proposed Standard | June 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5902 | IAB Thoughts on IPv6 Network Address TranslationD. Thaler, L. Zhang, G. Lebovitz | Informational | July 2010 |
| 6146 | Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6182 | Architectural Guidelines for Multipath TCP DevelopmentA. Ford, C. Raiciu, M. Handley, S. Barre, J. Iyengar | Informational | March 2011 |
| 6275 | Mobility Support in IPv6C. Perkins, Ed., D. Johnson, J. Arkko | Proposed Standard | July 2011 |
| 6296 | IPv6-to-IPv6 Network Prefix TranslationM. Wasserman, F. Baker | Experimental | June 2011 |
| 6316 | Sockets Application Program Interface (API) for Multihoming ShimM. Komu, M. Bagnulo, K. Slavov, S. Sugimoto, Ed. | Informational | July 2011 |
| 6418 | Multiple Interfaces and Provisioning Domains Problem StatementM. Blanchet, P. Seite | Informational | November 2011 |