| 1958 | Architectural Principles of the InternetB. Carpenter, Ed. | Informational | June 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3756 | IPv6 Neighbor Discovery (ND) Trust Models and ThreatsP. Nikander, Ed., J. Kempf, E. Nordmark | Informational | May 2004 |
| 3819 | Advice for Internet Subnetwork DesignersP. Karn, Ed., C. Bormann, G. Fairhurst, D. Grossman, R. Ludwig, J. Mahdavi, G. Montenegro, J. Touch, L. Wood | Best Current Practice | July 2004 |
| 4593 | Generic Threats to Routing ProtocolsA. Barbir, S. Murphy, Y. Yang | Informational | October 2006 |
| 4919 | IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs): Overview, Assumptions, Problem Statement, and GoalsN. Kushalnagar, G. Montenegro, C. Schumacher | Informational | August 2007 |
| 4944 | Transmission of IPv6 Packets over IEEE 802.15.4 NetworksG. Montenegro, N. Kushalnagar, J. Hui, D. Culler | Proposed Standard | September 2007 |
| 5548 | Routing Requirements for Urban Low-Power and Lossy NetworksM. Dohler, Ed., T. Watteyne, Ed., T. Winter, Ed., D. Barthel, Ed. | Informational | May 2009 |
| 5556 | Transparent Interconnection of Lots of Links (TRILL): Problem and Applicability StatementJ. Touch, R. Perlman | Informational | May 2009 |
| 5673 | Industrial Routing Requirements in Low-Power and Lossy NetworksK. Pister, Ed., P. Thubert, Ed., S. Dwars, T. Phinney | Informational | October 2009 |
| 5706 | Guidelines for Considering Operations and Management of New Protocols and Protocol ExtensionsD. Harrington | Informational | November 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5826 | Home Automation Routing Requirements in Low-Power and Lossy NetworksA. Brandt, J. Buron, G. Porcu | Informational | April 2010 |
| 5867 | Building Automation Routing Requirements in Low-Power and Lossy NetworksJ. Martocci, Ed., P. De Mil, N. Riou, W. Vermeylen | Informational | June 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 6282 | Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based NetworksJ. Hui, Ed., P. Thubert | Proposed Standard | September 2011 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |