| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3552 | Guidelines for Writing RFC Text on Security ConsiderationsE. Rescorla, B. Korver | Best Current Practice | July 2003 |
| 3561 | Ad hoc On-Demand Distance Vector (AODV) RoutingC. Perkins, E. Belding-Royer, S. Das | Experimental | July 2003 |
| 4101 | Writing Protocol ModelsE. Rescorla, IAB | Informational | June 2005 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4436 | Detecting Network Attachment in IPv4 (DNAv4)B. Aboba, J. Carlson, S. Cheshire | Proposed Standard | March 2006 |
| 4806 | Online Certificate Status Protocol (OCSP) Extensions to IKEv2M. Myers, H. Tschofenig | Proposed Standard | February 2007 |
| 4903 | Multi-Link Subnet IssuesD. Thaler | Informational | June 2007 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 5191 | Protocol for Carrying Authentication for Network Access (PANA)D. Forsberg, Y. Ohba, Ed., B. Patil, H. Tschofenig, A. Yegin | Proposed Standard | May 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5548 | Routing Requirements for Urban Low-Power and Lossy NetworksM. Dohler, Ed., T. Watteyne, Ed., T. Winter, Ed., D. Barthel, Ed. | Informational | May 2009 |
| 5673 | Industrial Routing Requirements in Low-Power and Lossy NetworksK. Pister, Ed., P. Thubert, Ed., S. Dwars, T. Phinney | Informational | October 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5826 | Home Automation Routing Requirements in Low-Power and Lossy NetworksA. Brandt, J. Buron, G. Porcu | Informational | April 2010 |
| 5867 | Building Automation Routing Requirements in Low-Power and Lossy NetworksJ. Martocci, Ed., P. De Mil, N. Riou, W. Vermeylen | Informational | June 2010 |
| 6059 | Simple Procedures for Detecting Network Attachment in IPv6S. Krishnan, G. Daley | Proposed Standard | November 2010 |
| 6121 | Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and PresenceP. Saint-Andre | Proposed Standard | March 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |