| 1498 | On the Naming and Binding of Network DestinationsJ. Saltzer | Informational | August 1993 |
| 1992 | The Nimrod Routing ArchitectureI. Castineyra, N. Chiappa, M. Steenstrup | Informational | August 1996 |
| 2367 | PF_KEY Key Management API, Version 2D. McDonald, C. Metz, B. Phan | Informational | July 1998 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4380 | Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)C. Huitema | Proposed Standard | February 2006 |
| 4423 | Host Identity Protocol (HIP) ArchitectureR. Moskowitz, P. Nikander · obsoleted by RFC 9063 | Informational | May 2006 |
| 4843 | An IPv6 Prefix for Overlay Routable Cryptographic Hash Identifiers (ORCHID)P. Nikander, J. Laganier, F. Dupont · obsoleted by RFC 7343 | Experimental | April 2007 |
| 5201 | Host Identity ProtocolR. Moskowitz, P. Nikander, P. Jokela, Ed., T. Henderson · obsoleted by RFC 7401 | Experimental | April 2008 |
| 5202 | Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)P. Jokela, R. Moskowitz, P. Nikander · obsoleted by RFC 7402 | Experimental | April 2008 |
| 5203 | Host Identity Protocol (HIP) Registration ExtensionJ. Laganier, T. Koponen, L. Eggert · obsoleted by RFC 8003 | Experimental | April 2008 |
| 5204 | Host Identity Protocol (HIP) Rendezvous ExtensionJ. Laganier, L. Eggert · obsoleted by RFC 8004 | Experimental | April 2008 |
| 5205 | Host Identity Protocol (HIP) Domain Name System (DNS) ExtensionsP. Nikander, J. Laganier · obsoleted by RFC 8005 | Experimental | April 2008 |
| 5206 | End-Host Mobility and Multihoming with the Host Identity ProtocolP. Nikander, T. Henderson, Ed., C. Vogt, J. Arkko · obsoleted by RFC 8046 | Experimental | April 2008 |
| 5207 | NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) CommunicationM. Stiemerling, J. Quittek, L. Eggert | Informational | April 2008 |
| 5338 | Using the Host Identity Protocol with Legacy ApplicationsT. Henderson, P. Nikander, M. Komu | Experimental | September 2008 |
| 5533 | Shim6: Level 3 Multihoming Shim Protocol for IPv6E. Nordmark, M. Bagnulo | Proposed Standard | June 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5770 | Basic Host Identity Protocol (HIP) Extensions for Traversal of Network Address TranslatorsM. Komu, T. Henderson, H. Tschofenig, J. Melen, A. Keranen, Ed. | Experimental | April 2010 |
| 6253 | Host Identity Protocol CertificatesT. Heer, S. Varjonen · obsoleted by RFC 8002 | Experimental | May 2011 |
| 6275 | Mobility Support in IPv6C. Perkins, Ed., D. Johnson, J. Arkko | Proposed Standard | July 2011 |
| 6281 | Understanding Apple's Back to My Mac (BTMM) ServiceS. Cheshire, Z. Zhu, R. Wakikawa, L. Zhang | Informational | June 2011 |
| 6298 | Computing TCP's Retransmission TimerV. Paxson, M. Allman, J. Chu, M. Sargent | Proposed Standard | June 2011 |
| 6316 | Sockets Application Program Interface (API) for Multihoming ShimM. Komu, M. Bagnulo, K. Slavov, S. Sugimoto, Ed. | Informational | July 2011 |
| 6317 | Basic Socket Interface Extensions for the Host Identity Protocol (HIP)M. Komu, T. Henderson | Experimental | July 2011 |
| 6537 | Host Identity Protocol Distributed Hash Table InterfaceJ. Ahrenholz | Experimental | February 2012 |