| 9981 | Resource Public Key Infrastructure (RPKI) Manifest Number HandlingT. Harrison, G. Michaelson, J. Snijders | Proposed Standard | May 2026 |
| 9977 | Publishing End-Site Prefix LengthsO. Gasser, R. Bush, M. Candela, R. Housley | Proposed Standard | May 2026 |
| 9691 | A Profile for Resource Public Key Infrastructure (RPKI) Trust Anchor Keys (TAKs)C. Martinez, G. Michaelson, T. Harrison, T. Bruijnzeels, R. Austein | Proposed Standard | December 2024 |
| 9632 | Finding and Using Geofeed DataR. Bush, M. Candela, W. Kumari, R. Housley | Proposed Standard | August 2024 |
| 9589 | On the Use of the Cryptographic Message Syntax (CMS) Signing-Time Attribute in Resource Public Key Infrastructure (RPKI) Signed ObjectsJ. Snijders, T. Harrison | Proposed Standard | May 2024 |
| 9582 | A Profile for Route Origin Authorizations (ROAs)J. Snijders, B. Maddison, M. Lepinski, D. Kong, S. Kent | Proposed Standard | May 2024 |
| 9323 | A Profile for RPKI Signed Checklists (RSCs)J. Snijders, T. Harrison, B. Maddison | Proposed Standard | November 2022 |
| 9286 | Manifests for the Resource Public Key Infrastructure (RPKI)R. Austein, G. Huston, S. Kent, M. Lepinski | Proposed Standard | June 2022 |
| 8897 | Requirements for Resource Public Key Infrastructure (RPKI) Relying PartiesD. Ma, S. Kent | Informational | September 2020 |
| 8488 | RIPE NCC's Implementation of Resource Public Key Infrastructure (RPKI) Certificate Tree ValidationO. Muravskiy, T. Bruijnzeels | Informational | December 2018 |
| 8211 | Adverse Actions by a Certification Authority (CA) or Repository Manager in the Resource Public Key Infrastructure (RPKI)S. Kent, D. Ma | Informational | September 2017 |
| 8182 | The RPKI Repository Delta Protocol (RRDP)T. Bruijnzeels, O. Muravskiy, B. Weber, R. Austein | Proposed Standard | July 2017 |
| 7935 | The Profile for Algorithms and Key Sizes for Use in the Resource Public Key InfrastructureG. Huston, G. Michaelson, Ed. | Proposed Standard | August 2016 |
| 7132 | Threat Model for BGP Path SecurityS. Kent, A. Chi | Informational | February 2014 |
| 7115 | Origin Validation Operation Based on the Resource Public Key Infrastructure (RPKI)R. Bush | Best Current Practice | January 2014 |
| 6493 | The Resource Public Key Infrastructure (RPKI) Ghostbusters RecordR. Bush | Historic | February 2012 |
| 6489 | Certification Authority (CA) Key Rollover in the Resource Public Key Infrastructure (RPKI)G. Huston, G. Michaelson, S. Kent | Best Current Practice | February 2012 |
| 6487 | A Profile for X.509 PKIX Resource CertificatesG. Huston, G. Michaelson, R. Loomans | Proposed Standard | February 2012 |
| 6486 | Manifests for the Resource Public Key Infrastructure (RPKI)R. Austein, G. Huston, S. Kent, M. Lepinski · obsoleted by RFC 9286 | Proposed Standard | February 2012 |
| 6485 | The Profile for Algorithms and Key Sizes for Use in the Resource Public Key Infrastructure (RPKI)G. Huston · obsoleted by RFC 7935 | Proposed Standard | February 2012 |
| 6482 | A Profile for Route Origin Authorizations (ROAs)M. Lepinski, S. Kent, D. Kong · obsoleted by RFC 9582 | Proposed Standard | February 2012 |
| 6481 | A Profile for Resource Certificate Repository StructureG. Huston, R. Loomans, G. Michaelson | Proposed Standard | February 2012 |
| 6480 | An Infrastructure to Support Secure Internet RoutingM. Lepinski, S. Kent | Informational | February 2012 |