| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1106 | TCP big window and NAK optionsR. Fox · obsoleted by RFC 6247 | Historic | June 1989 |
| 1110 | Problem with the TCP big window optionA.M. McKenzie · obsoleted by RFC 6247 | Historic | August 1989 |
| 1145 | TCP alternate checksum optionsJ. Zweig, C. Partridge · obsoleted by RFC 1146, RFC 6247 | Historic | February 1990 |
| 1146 | TCP alternate checksum optionsJ. Zweig, C. Partridge · obsoleted by RFC 6247 | Historic | March 1990 |
| 1379 | Extending TCP for Transactions -- ConceptsR. Braden · obsoleted by RFC 6247 | Historic | November 1992 |
| 1644 | T/TCP -- TCP Extensions for Transactions Functional SpecificationR. Braden · obsoleted by RFC 6247 | Historic | July 1994 |
| 1693 | An Extension to TCP : Partial Order ServiceT. Connolly, P. Amer, P. Conrad · obsoleted by RFC 6247 | Historic | November 1994 |
| 3493 | Basic Socket Interface Extensions for IPv6R. Gilligan, S. Thomson, J. Bound, J. McCann, W. Stevens | Informational | March 2003 |
| 3542 | Advanced Sockets Application Program Interface (API) for IPv6W. Stevens, M. Thomas, E. Nordmark, T. Jinmei | Informational | June 2003 |
| 3758 | Stream Control Transmission Protocol (SCTP) Partial Reliability ExtensionR. Stewart, M. Ramalho, Q. Xie, M. Tuexen, P. Conrad | Proposed Standard | May 2004 |
| 4895 | Authenticated Chunks for the Stream Control Transmission Protocol (SCTP)M. Tuexen, R. Stewart, P. Lei, E. Rescorla | Proposed Standard | August 2007 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 5061 | Stream Control Transmission Protocol (SCTP) Dynamic Address ReconfigurationR. Stewart, Q. Xie, M. Tuexen, S. Maruyama, M. Kozuka | Proposed Standard | September 2007 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6083 | Datagram Transport Layer Security (DTLS) for Stream Control Transmission Protocol (SCTP)M. Tuexen, R. Seggelmann, E. Rescorla | Proposed Standard | January 2011 |
| 6247 | Moving the Undeployed TCP Extensions RFC 1072, RFC 1106, RFC 1110, RFC 1145, RFC 1146, RFC 1379, RFC 1644, and RFC 1693 to Historic StatusL. Eggert | Informational | May 2011 |