rfc.dk

Cited in: RFC 6455

22 RFCs mentioned in the text of RFC 6455 (The WebSocket Protocol)

RFCTitleStatusDate
1928SOCKS Protocol Version 5M. Leech, M. Ganis, Y. Lee, R. Kuris, D. Koblas, L. JonesProposed StandardMarch 1996
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
2616Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235Draft StandardJune 1999
2817Upgrading to TLS Within HTTP/1.1R. Khare, S. LawrenceProposed StandardMay 2000
2818HTTP Over TLSE. Rescorla · obsoleted by RFC 9110InformationalMay 2000
3629UTF-8, a transformation format of ISO 10646F. YergeauInternet StandardNovember 2003
3864Registration Procedures for Message Header FieldsG. Klyne, M. Nottingham, J. MogulBest Current PracticeSeptember 2004
3986Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. MasinterInternet StandardJanuary 2005
3987Internationalized Resource Identifiers (IRIs)M. Duerst, M. SuignardProposed StandardJanuary 2005
4086Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. CrockerBest Current PracticeJune 2005
4122A Universally Unique IDentifier (UUID) URN NamespaceP. Leach, M. Mealling, R. Salz · obsoleted by RFC 9562Proposed StandardJuly 2005
4270Attacks on Cryptographic Hashes in Internet ProtocolsP. Hoffman, B. SchneierInformationalDecember 2005
4648The Base16, Base32, and Base64 Data EncodingsS. JosefssonProposed StandardOctober 2006
5226Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126Best Current PracticeMay 2008
5234Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. OverellInternet StandardJanuary 2008
5246The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846Proposed StandardAugust 2008
5321Simple Mail Transfer ProtocolJ. KlensinDraft StandardOctober 2008
5741RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841InformationalDecember 2009
6066Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rdProposed StandardJanuary 2011
6202Known Issues and Best Practices for the Use of Long Polling and Streaming in Bidirectional HTTPS. Loreto, P. Saint-Andre, S. Salsano, G. WilkinsInformationalApril 2011
6265HTTP State Management MechanismA. BarthProposed StandardApril 2011
6454The Web Origin ConceptA. BarthProposed StandardDecember 2011