| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 2045 | Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message BodiesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2047 | MIME (Multipurpose Internet Mail Extensions) Part Three: Message Header Extensions for Non-ASCII TextK. Moore | Draft Standard | November 1996 |
| 2049 | Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance Criteria and ExamplesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3447 | Public-Key Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.1J. Jonsson, B. Kaliski · obsoleted by RFC 8017 | Informational | February 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3766 | Determining Strengths For Public Keys Used For Exchanging Symmetric KeysH. Orman, P. Hoffman | Best Current Practice | April 2004 |
| 3833 | Threat Analysis of the Domain Name System (DNS)D. Atkins, R. Austein | Informational | August 2004 |
| 3864 | Registration Procedures for Message Header FieldsG. Klyne, M. Nottingham, J. Mogul | Best Current Practice | September 2004 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4409 | Message Submission for MailR. Gellens, J. Klensin · obsoleted by RFC 6409 | Draft Standard | April 2006 |
| 4686 | Analysis of Threats Motivating DomainKeys Identified Mail (DKIM)J. Fenton | Informational | September 2006 |
| 4732 | Internet Denial-of-Service ConsiderationsM. Handley, Ed., E. Rescorla, Ed., IAB | Informational | December 2006 |
| 4870 | Domain-Based Email Authentication Using Public Keys Advertised in the DNS (DomainKeys)M. Delany · obsoleted by RFC 4871 | Historic | May 2007 |
| 4871 | DomainKeys Identified Mail (DKIM) SignaturesE. Allman, J. Callas, M. Delany, M. Libbey, J. Fenton, M. Thomas · obsoleted by RFC 6376 | Proposed Standard | May 2007 |
| 4880 | OpenPGP Message FormatJ. Callas, L. Donnerhacke, H. Finney, D. Shaw, R. Thayer · obsoleted by RFC 9580 | Proposed Standard | November 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5321 | Simple Mail Transfer ProtocolJ. Klensin | Draft Standard | October 2008 |
| 5322 | Internet Message FormatP. Resnick, Ed. | Draft Standard | October 2008 |
| 5451 | Message Header Field for Indicating Message Authentication StatusM. Kucherawy · obsoleted by RFC 7001 | Proposed Standard | April 2009 |
| 5585 | DomainKeys Identified Mail (DKIM) Service OverviewT. Hansen, D. Crocker, P. Hallam-Baker | Informational | July 2009 |
| 5598 | Internet Mail ArchitectureD. Crocker | Informational | July 2009 |
| 5672 | RFC 4871 DomainKeys Identified Mail (DKIM) Signatures -- UpdateD. Crocker, Ed. · obsoleted by RFC 6376 | Proposed Standard | August 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5751 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message SpecificationB. Ramsdell, S. Turner · obsoleted by RFC 8551 | Proposed Standard | January 2010 |
| 5863 | DomainKeys Identified Mail (DKIM) Development, Deployment, and OperationsT. Hansen, E. Siegel, P. Hallam-Baker, D. Crocker | Informational | May 2010 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 6377 | DomainKeys Identified Mail (DKIM) and Mailing ListsM. Kucherawy | Best Current Practice | September 2011 |