| 2210 | The Use of RSVP with IETF Integrated ServicesJ. Wroclawski | Proposed Standard | September 1997 |
| 2211 | Specification of the Controlled-Load Network Element ServiceJ. Wroclawski | Proposed Standard | September 1997 |
| 2212 | Specification of Guaranteed Quality of ServiceS. Shenker, C. Partridge, R. Guerin | Proposed Standard | September 1997 |
| 3031 | Multiprotocol Label Switching ArchitectureE. Rosen, A. Viswanathan, R. Callon | Proposed Standard | January 2001 |
| 3209 | RSVP-TE: Extensions to RSVP for LSP TunnelsD. Awduche, L. Berger, D. Gan, T. Li, V. Srinivasan, G. Swallow | Proposed Standard | December 2001 |
| 3270 | Multi-Protocol Label Switching (MPLS) Support of Differentiated ServicesF. Le Faucheur, Ed., L. Wu, B. Davie, S. Davari, P. Vaananen, R. Krishnan, P. Cheval, J. Heinanen | Proposed Standard | May 2002 |
| 3468 | The Multiprotocol Label Switching (MPLS) Working Group decision on MPLS signaling protocolsL. Andersson, G. Swallow | Informational | February 2003 |
| 3471 | Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional DescriptionL. Berger, Ed. | Proposed Standard | February 2003 |
| 3472 | Generalized Multi-Protocol Label Switching (GMPLS) Signaling Constraint-based Routed Label Distribution Protocol (CR-LDP) ExtensionsP. Ashwood-Smith, Ed., L. Berger, Ed. | Proposed Standard | February 2003 |
| 3473 | Generalized Multi-Protocol Label Switching (GMPLS) Signaling Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) ExtensionsL. Berger, Ed. | Proposed Standard | February 2003 |
| 3477 | Signalling Unnumbered Links in Resource ReSerVation Protocol - Traffic Engineering (RSVP-TE)K. Kompella, Y. Rekhter | Proposed Standard | February 2003 |
| 3478 | Graceful Restart Mechanism for Label Distribution ProtocolM. Leelanivas, Y. Rekhter, R. Aggarwal | Proposed Standard | February 2003 |
| 3630 | Traffic Engineering (TE) Extensions to OSPF Version 2D. Katz, K. Kompella, D. Yeung | Proposed Standard | October 2003 |
| 3812 | Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB)C. Srinivasan, A. Viswanathan, T. Nadeau | Proposed Standard | June 2004 |
| 3813 | Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB)C. Srinivasan, A. Viswanathan, T. Nadeau | Proposed Standard | June 2004 |
| 3945 | Generalized Multi-Protocol Label Switching (GMPLS) ArchitectureE. Mannie, Ed. | Proposed Standard | November 2004 |
| 3985 | Pseudo Wire Emulation Edge-to-Edge (PWE3) ArchitectureS. Bryant, Ed., P. Pate, Ed. | Informational | March 2005 |
| 4124 | Protocol Extensions for Support of Diffserv-aware MPLS Traffic EngineeringF. Le Faucheur, Ed. | Proposed Standard | June 2005 |
| 4139 | Requirements for Generalized MPLS (GMPLS) Signaling Usage and Extensions for Automatically Switched Optical Network (ASON)D. Papadimitriou, J. Drake, J. Ash, A. Farrel, L. Ong | Informational | July 2005 |
| 4201 | Link Bundling in MPLS Traffic Engineering (TE)K. Kompella, Y. Rekhter, L. Berger | Proposed Standard | October 2005 |
| 4202 | Routing Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4203 | OSPF Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4206 | Label Switched Paths (LSP) Hierarchy with Generalized Multi-Protocol Label Switching (GMPLS) Traffic Engineering (TE)K. Kompella, Y. Rekhter | Proposed Standard | October 2005 |
| 4208 | Generalized Multiprotocol Label Switching (GMPLS) User-Network Interface (UNI): Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) Support for the Overlay ModelG. Swallow, J. Drake, H. Ishimatsu, Y. Rekhter | Proposed Standard | October 2005 |
| 4258 | Requirements for Generalized Multi-Protocol Label Switching (GMPLS) Routing for the Automatically Switched Optical Network (ASON)D. Brungard, Ed. | Informational | November 2005 |
| 4379 | Detecting Multi-Protocol Label Switched (MPLS) Data Plane FailuresK. Kompella, G. Swallow · obsoleted by RFC 8029 | Proposed Standard | February 2006 |
| 4385 | Pseudowire Emulation Edge-to-Edge (PWE3) Control Word for Use over an MPLS PSNS. Bryant, G. Swallow, L. Martini, D. McPherson | Proposed Standard | February 2006 |
| 4426 | Generalized Multi-Protocol Label Switching (GMPLS) Recovery Functional SpecificationJ. Lang, Ed., B. Rajagopalan, Ed., D. Papadimitriou, Ed. | Proposed Standard | March 2006 |
| 4427 | Recovery (Protection and Restoration) Terminology for Generalized Multi-Protocol Label Switching (GMPLS)E. Mannie, Ed., D. Papadimitriou, Ed. | Informational | March 2006 |
| 4447 | Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)L. Martini, Ed., E. Rosen, N. El-Aawar, T. Smith, G. Heron · obsoleted by RFC 8077 | Proposed Standard | April 2006 |
| 4448 | Encapsulation Methods for Transport of Ethernet over MPLS NetworksL. Martini, Ed., E. Rosen, N. El-Aawar, G. Heron | Proposed Standard | April 2006 |
| 4553 | Structure-Agnostic Time Division Multiplexing (TDM) over Packet (SAToP)A. Vainshtein, Ed., YJ. Stein, Ed. | Proposed Standard | June 2006 |
| 4618 | Encapsulation Methods for Transport of PPP/High-Level Data Link Control (HDLC) over MPLS NetworksL. Martini, E. Rosen, G. Heron, A. Malis | Proposed Standard | September 2006 |
| 4619 | Encapsulation Methods for Transport of Frame Relay over Multiprotocol Label Switching (MPLS) NetworksL. Martini, Ed., C. Kawa, Ed., A. Malis, Ed. | Proposed Standard | September 2006 |
| 4655 | A Path Computation Element (PCE)-Based ArchitectureA. Farrel, J.-P. Vasseur, J. Ash | Informational | August 2006 |
| 4783 | GMPLS - Communication of Alarm InformationL. Berger, Ed. | Proposed Standard | December 2006 |
| 4802 | Generalized Multiprotocol Label Switching (GMPLS) Traffic Engineering Management Information BaseT. Nadeau, Ed., A. Farrel, Ed. | Proposed Standard | February 2007 |
| 4803 | Generalized Multiprotocol Label Switching (GMPLS) Label Switching Router (LSR) Management Information BaseT. Nadeau, Ed., A. Farrel, Ed. | Proposed Standard | February 2007 |
| 4816 | Pseudowire Emulation Edge-to-Edge (PWE3) Asynchronous Transfer Mode (ATM) Transparent Cell Transport ServiceA. Malis, L. Martini, J. Brayley, T. Walsh | Proposed Standard | February 2007 |
| 4842 | Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) Circuit Emulation over Packet (CEP)A. Malis, P. Pate, R. Cohen, Ed., D. Zelig | Proposed Standard | April 2007 |
| 4863 | Wildcard Pseudowire TypeL. Martini, G. Swallow | Proposed Standard | May 2007 |
| 4872 | RSVP-TE Extensions in Support of End-to-End Generalized Multi-Protocol Label Switching (GMPLS) RecoveryJ.P. Lang, Ed., Y. Rekhter, Ed., D. Papadimitriou, Ed. | Proposed Standard | May 2007 |
| 4873 | GMPLS Segment RecoveryL. Berger, I. Bryskin, D. Papadimitriou, A. Farrel | Proposed Standard | May 2007 |
| 4875 | Extensions to Resource Reservation Protocol - Traffic Engineering (RSVP-TE) for Point-to-Multipoint TE Label Switched Paths (LSPs)R. Aggarwal, Ed., D. Papadimitriou, Ed., S. Yasukawa, Ed. | Proposed Standard | May 2007 |
| 4929 | Change Process for Multiprotocol Label Switching (MPLS) and Generalized MPLS (GMPLS) Protocols and ProceduresL. Andersson, Ed., A. Farrel, Ed. | Best Current Practice | June 2007 |
| 4974 | Generalized MPLS (GMPLS) RSVP-TE Signaling Extensions in Support of CallsD. Papadimitriou, A. Farrel | Proposed Standard | August 2007 |
| 5003 | Attachment Individual Identifier (AII) Types for AggregationC. Metz, L. Martini, F. Balus, J. Sugimoto | Proposed Standard | September 2007 |
| 5036 | LDP SpecificationL. Andersson, Ed., I. Minei, Ed., B. Thomas, Ed. | Draft Standard | October 2007 |
| 5063 | Extensions to GMPLS Resource Reservation Protocol (RSVP) Graceful RestartA. Satyanarayana, Ed., R. Rahman, Ed. | Proposed Standard | October 2007 |
| 5085 | Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for PseudowiresT. Nadeau, Ed., C. Pignataro, Ed. | Proposed Standard | December 2007 |
| 5145 | Framework for MPLS-TE to GMPLS MigrationK. Shiomoto, Ed. | Informational | March 2008 |
| 5151 | Inter-Domain MPLS and GMPLS Traffic Engineering -- Resource Reservation Protocol-Traffic Engineering (RSVP-TE) ExtensionsA. Farrel, Ed., A. Ayyangar, JP. Vasseur | Proposed Standard | February 2008 |
| 5287 | Control Protocol Extensions for the Setup of Time-Division Multiplexing (TDM) Pseudowires in MPLS NetworksA. Vainshtein, Y(J). Stein | Proposed Standard | August 2008 |
| 5305 | IS-IS Extensions for Traffic EngineeringT. Li, H. Smit | Proposed Standard | October 2008 |
| 5307 | IS-IS Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2008 |
| 5316 | ISIS Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic EngineeringM. Chen, R. Zhang, X. Duan · obsoleted by RFC 9346 | Proposed Standard | December 2008 |
| 5392 | OSPF Extensions in Support of Inter-Autonomous System (AS) MPLS and GMPLS Traffic EngineeringM. Chen, R. Zhang, X. Duan | Proposed Standard | January 2009 |
| 5440 | Path Computation Element (PCE) Communication Protocol (PCEP)JP. Vasseur, Ed., JL. Le Roux, Ed. | Proposed Standard | March 2009 |
| 5462 | Multiprotocol Label Switching (MPLS) Label Stack Entry: "EXP" Field Renamed to "Traffic Class" FieldL. Andersson, R. Asati | Proposed Standard | February 2009 |
| 5467 | GMPLS Asymmetric Bandwidth Bidirectional Label Switched Paths (LSPs)L. Berger, A. Takacs, D. Caviglia, D. Fedyk, J. Meuric · obsoleted by RFC 6387 | Experimental | March 2009 |
| 5493 | Requirements for the Conversion between Permanent Connections and Switched Connections in a Generalized Multiprotocol Label Switching (GMPLS) NetworkD. Caviglia, D. Bramanti, D. Li, D. McDysan | Informational | April 2009 |
| 5586 | MPLS Generic Associated ChannelM. Bocci, Ed., M. Vigoureux, Ed., S. Bryant, Ed. | Proposed Standard | June 2009 |
| 5654 | Requirements of an MPLS Transport ProfileB. Niven-Jenkins, Ed., D. Brungard, Ed., M. Betts, Ed., N. Sprecher, S. Ueno | Proposed Standard | September 2009 |
| 5659 | An Architecture for Multi-Segment Pseudowire Emulation Edge-to-EdgeM. Bocci, S. Bryant | Informational | October 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5787 | OSPFv2 Routing Protocols Extensions for Automatically Switched Optical Network (ASON) RoutingD. Papadimitriou · obsoleted by RFC 6827 | Experimental | March 2010 |
| 5852 | RSVP-TE Signaling Extension for LSP Handover from the Management Plane to the Control Plane in a GMPLS-Enabled Transport NetworkD. Caviglia, D. Ceccarelli, D. Bramanti, D. Li, S. Bardalai | Proposed Standard | April 2010 |
| 5860 | Requirements for Operations, Administration, and Maintenance (OAM) in MPLS Transport NetworksM. Vigoureux, Ed., D. Ward, Ed., M. Betts, Ed. | Proposed Standard | May 2010 |
| 5884 | Bidirectional Forwarding Detection (BFD) for MPLS Label Switched Paths (LSPs)R. Aggarwal, K. Kompella, T. Nadeau, G. Swallow | Proposed Standard | June 2010 |
| 5885 | Bidirectional Forwarding Detection (BFD) for the Pseudowire Virtual Circuit Connectivity Verification (VCCV)T. Nadeau, Ed., C. Pignataro, Ed. | Proposed Standard | June 2010 |
| 5920 | Security Framework for MPLS and GMPLS NetworksL. Fang, Ed. | Informational | July 2010 |
| 5921 | A Framework for MPLS in Transport NetworksM. Bocci, Ed., S. Bryant, Ed., D. Frost, Ed., L. Levrau, L. Berger | Informational | July 2010 |
| 5951 | Network Management Requirements for MPLS-based Transport NetworksK. Lam, S. Mansfield, E. Gray | Proposed Standard | September 2010 |
| 5960 | MPLS Transport Profile Data Plane ArchitectureD. Frost, Ed., S. Bryant, Ed., M. Bocci, Ed. | Proposed Standard | August 2010 |
| 6001 | Generalized MPLS (GMPLS) Protocol Extensions for Multi-Layer and Multi-Region Networks (MLN/MRN)D. Papadimitriou, M. Vigoureux, K. Shiomoto, D. Brungard, JL. Le Roux | Proposed Standard | October 2010 |
| 6073 | Segmented PseudowireL. Martini, C. Metz, T. Nadeau, M. Bocci, M. Aissaoui | Proposed Standard | January 2011 |
| 6107 | Procedures for Dynamically Signaled Hierarchical Label Switched PathsK. Shiomoto, Ed., A. Farrel, Ed. | Proposed Standard | February 2011 |
| 6215 | MPLS Transport Profile User-to-Network and Network-to-Network InterfacesM. Bocci, L. Levrau, D. Frost | Informational | April 2011 |
| 6370 | MPLS Transport Profile (MPLS-TP) IdentifiersM. Bocci, G. Swallow, E. Gray | Proposed Standard | September 2011 |
| 6371 | Operations, Administration, and Maintenance Framework for MPLS-Based Transport NetworksI. Busi, Ed., D. Allan, Ed. | Informational | September 2011 |
| 6372 | MPLS Transport Profile (MPLS-TP) Survivability FrameworkN. Sprecher, Ed., A. Farrel, Ed. | Informational | September 2011 |