| 792 | Internet Control Message ProtocolJ. Postel | Internet Standard | September 1981 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3031 | Multiprotocol Label Switching ArchitectureE. Rosen, A. Viswanathan, R. Callon | Proposed Standard | January 2001 |
| 3209 | RSVP-TE: Extensions to RSVP for LSP TunnelsD. Awduche, L. Berger, D. Gan, T. Li, V. Srinivasan, G. Swallow | Proposed Standard | December 2001 |
| 3916 | Requirements for Pseudo-Wire Emulation Edge-to-Edge (PWE3)X. Xiao, Ed., D. McPherson, Ed., P. Pate, Ed. | Informational | October 2004 |
| 3931 | Layer Two Tunneling Protocol - Version 3 (L2TPv3)J. Lau, Ed., M. Townsley, Ed., I. Goyret, Ed. | Proposed Standard | March 2005 |
| 3985 | Pseudo Wire Emulation Edge-to-Edge (PWE3) ArchitectureS. Bryant, Ed., P. Pate, Ed. | Informational | March 2005 |
| 4023 | Encapsulating MPLS in IP or Generic Routing Encapsulation (GRE)T. Worster, Y. Rekhter, E. Rosen, Ed. | Proposed Standard | March 2005 |
| 4377 | Operations and Management (OAM) Requirements for Multi-Protocol Label Switched (MPLS) NetworksT. Nadeau, M. Morrow, G. Swallow, D. Allan, S. Matsushima | Informational | February 2006 |
| 4379 | Detecting Multi-Protocol Label Switched (MPLS) Data Plane FailuresK. Kompella, G. Swallow · obsoleted by RFC 8029 | Proposed Standard | February 2006 |
| 4385 | Pseudowire Emulation Edge-to-Edge (PWE3) Control Word for Use over an MPLS PSNS. Bryant, G. Swallow, L. Martini, D. McPherson | Proposed Standard | February 2006 |
| 4446 | IANA Allocations for Pseudowire Edge to Edge Emulation (PWE3)L. Martini | Best Current Practice | April 2006 |
| 4447 | Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)L. Martini, Ed., E. Rosen, N. El-Aawar, T. Smith, G. Heron · obsoleted by RFC 8077 | Proposed Standard | April 2006 |
| 4454 | Asynchronous Transfer Mode (ATM) over Layer 2 Tunneling Protocol Version 3 (L2TPv3)S. Singh, M. Townsley, C. Pignataro | Proposed Standard | May 2006 |
| 4553 | Structure-Agnostic Time Division Multiplexing (TDM) over Packet (SAToP)A. Vainshtein, Ed., YJ. Stein, Ed. | Proposed Standard | June 2006 |
| 4591 | Frame Relay over Layer 2 Tunneling Protocol Version 3 (L2TPv3)M. Townsley, G. Wilkie, S. Booth, S. Bryant, J. Lau | Proposed Standard | August 2006 |
| 4619 | Encapsulation Methods for Transport of Frame Relay over Multiprotocol Label Switching (MPLS) NetworksL. Martini, Ed., C. Kawa, Ed., A. Malis, Ed. | Proposed Standard | September 2006 |
| 4717 | Encapsulation Methods for Transport of Asynchronous Transfer Mode (ATM) over MPLS NetworksL. Martini, J. Jayakumar, M. Bocci, N. El-Aawar, J. Brayley, G. Koleyni | Proposed Standard | December 2006 |
| 4842 | Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) Circuit Emulation over Packet (CEP)A. Malis, P. Pate, R. Cohen, Ed., D. Zelig | Proposed Standard | April 2007 |
| 5036 | LDP SpecificationL. Andersson, Ed., I. Minei, Ed., B. Thomas, Ed. | Draft Standard | October 2007 |
| 5085 | Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for PseudowiresT. Nadeau, Ed., C. Pignataro, Ed. | Proposed Standard | December 2007 |
| 5086 | Structure-Aware Time Division Multiplexed (TDM) Circuit Emulation Service over Packet Switched Network (CESoPSN)A. Vainshtein, Ed., I. Sasson, E. Metz, T. Frost, P. Pate | Informational | December 2007 |
| 5087 | Time Division Multiplexing over IP (TDMoIP)Y(J). Stein, R. Shashoua, R. Insler, M. Anavi | Informational | December 2007 |
| 5254 | Requirements for Multi-Segment Pseudowire Emulation Edge-to-Edge (PWE3)N. Bitar, Ed., M. Bocci, Ed., L. Martini, Ed. | Informational | October 2008 |
| 5641 | Layer 2 Tunneling Protocol Version 3 (L2TPv3) Extended Circuit Status ValuesN. McGill, C. Pignataro | Proposed Standard | August 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5880 | Bidirectional Forwarding Detection (BFD)D. Katz, D. Ward | Proposed Standard | June 2010 |
| 5885 | Bidirectional Forwarding Detection (BFD) for the Pseudowire Virtual Circuit Connectivity Verification (VCCV)T. Nadeau, Ed., C. Pignataro, Ed. | Proposed Standard | June 2010 |
| 6073 | Segmented PseudowireL. Martini, C. Metz, T. Nadeau, M. Bocci, M. Aissaoui | Proposed Standard | January 2011 |