| 1633 | Integrated Services in the Internet Architecture: an OverviewR. Braden, D. Clark, S. Shenker | Informational | June 1994 |
| 1707 | CATNIP: Common Architecture for the InternetM. McGovern, R. Ullmann | Historic | October 1994 |
| 1710 | Simple Internet Protocol Plus White PaperR. Hinden | Informational | October 1994 |
| 1752 | The Recommendation for the IP Next Generation ProtocolS. Bradner, A. Mankin | Proposed Standard | January 1995 |
| 1809 | Using the Flow Label Field in IPv6C. Partridge | Informational | June 1995 |
| 1883 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 2460 | Proposed Standard | December 1995 |
| 2205 | Resource ReSerVation Protocol (RSVP) -- Version 1 Functional SpecificationR. Braden, Ed., L. Zhang, S. Berson, S. Herzog, S. Jamin | Proposed Standard | September 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 3031 | Multiprotocol Label Switching ArchitectureE. Rosen, A. Viswanathan, R. Callon | Proposed Standard | January 2001 |
| 3140 | Per Hop Behavior Identification CodesD. Black, S. Brim, B. Carpenter, F. Le Faucheur | Proposed Standard | June 2001 |
| 3697 | IPv6 Flow Label SpecificationJ. Rajahalme, A. Conta, B. Carpenter, S. Deering · obsoleted by RFC 6437 | Proposed Standard | March 2004 |
| 3724 | The Rise of the Middle and the Future of End-to-End: Reflections on the Evolution of the Internet ArchitectureJ. Kempf, Ed., R. Austein, Ed., IAB | Informational | March 2004 |
| 4080 | Next Steps in Signaling (NSIS): FrameworkR. Hancock, G. Karagiannis, J. Loughney, S. Van den Bosch | Informational | June 2005 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6089 | Flow Bindings in Mobile IPv6 and Network Mobility (NEMO) Basic SupportG. Tsirtsis, H. Soliman, N. Montavont, G. Giaretta, K. Kuladinithi | Proposed Standard | January 2011 |