| 1700 | Assigned NumbersJ. Reynolds, J. Postel · obsoleted by RFC 3232 | Historic | October 1994 |
| 2003 | IP Encapsulation within IPC. Perkins | Proposed Standard | October 1996 |
| 2004 | Minimal Encapsulation within IPC. Perkins | Proposed Standard | October 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2473 | Generic Packet Tunneling in IPv6 SpecificationA. Conta, S. Deering | Proposed Standard | December 1998 |
| 2526 | Reserved IPv6 Subnet Anycast AddressesD. Johnson, S. Deering | Proposed Standard | March 1999 |
| 2710 | Multicast Listener Discovery (MLD) for IPv6S. Deering, W. Fenner, B. Haberman | Proposed Standard | October 1999 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 3232 | Assigned Numbers: RFC 1700 is Replaced by an On-line DatabaseJ. Reynolds, Ed. | Informational | January 2002 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3484 | Default Address Selection for Internet Protocol version 6 (IPv6)R. Draves · obsoleted by RFC 6724 | Proposed Standard | March 2003 |
| 3627 | Use of /127 Prefix Length Between Routers Considered HarmfulP. Savola · obsoleted by RFC 6547 | Historic | September 2003 |
| 3753 | Mobility Related TerminologyJ. Manner, Ed., M. Kojo, Ed. | Informational | June 2004 |
| 3775 | Mobility Support in IPv6D. Johnson, C. Perkins, J. Arkko · obsoleted by RFC 6275 | Proposed Standard | June 2004 |
| 3776 | Using IPsec to Protect Mobile IPv6 Signaling Between Mobile Nodes and Home AgentsJ. Arkko, V. Devarapalli, F. Dupont | Proposed Standard | June 2004 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4107 | Guidelines for Cryptographic Key ManagementS. Bellovin, R. Housley | Best Current Practice | June 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4225 | Mobile IP Version 6 Route Optimization Security Design BackgroundP. Nikander, J. Arkko, T. Aura, G. Montenegro, E. Nordmark | Informational | December 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4877 | Mobile IPv6 Operation with IKEv2 and the Revised IPsec ArchitectureV. Devarapalli, F. Dupont | Proposed Standard | April 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 5014 | IPv6 Socket API for Source Address SelectionE. Nordmark, S. Chakrabarti, J. Laganier | Informational | September 2007 |
| 5026 | Mobile IPv6 Bootstrapping in Split ScenarioG. Giaretta, Ed., J. Kempf, V. Devarapalli, Ed. | Proposed Standard | October 2007 |
| 5095 | Deprecation of Type 0 Routing Headers in IPv6J. Abley, P. Savola, G. Neville-Neil | Proposed Standard | December 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5944 | IP Mobility Support for IPv4, RevisedC. Perkins, Ed. | Proposed Standard | November 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 6194 | Security Considerations for the SHA-0 and SHA-1 Message-Digest AlgorithmsT. Polk, L. Chen, S. Turner, P. Hoffman | Informational | March 2011 |