| 10049 | Roughtime: A Protocol for Rough Time SynchronizationW. Ladd, M. Dansarie | Experimental | October 2026 |
| 10042 | Post-Quantum/Traditional Hybrid Key Exchange with the Module-Lattice-Based Key-Encapsulation Mechanism for Use in SSHP. Kampanakis, D. Stebila, T. Hansen | Informational | August 2026 |
| 10032 | The AEGIS Authenticated Encryption AlgorithmsF. Denis, S. Lucas | Informational | September 2026 |
| 9962 | A Decentralized Locator/ID Separation Protocol Mapping System (LISP-Decent)D. Farinacci, C. Cantrell | Informational | May 2026 |
| 9946 | The UDP Speed Test Protocol (UDPSTP) for One-Way IP Capacity Metric MeasurementA. Morton, L. Ciavattone, R. Geib, Ed. | Proposed Standard | April 2026 |
| 9941 | Secure Shell (SSH) Key Exchange Method Using Hybrid Streamlined NTRU Prime sntrup761 and X25519 with SHA-512: sntrup761x25519-sha512M. Friedl, J. Mojzis, S. Josefsson | Informational | April 2026 |
| 9923 | The FNV Non-Cryptographic Hash AlgorithmL. Noll, K. Vo, D. Eastlake 3rd, T. Hansen | Informational | February 2026 |
| 9897 | Datagram Congestion Control Protocol (DCCP) Extensions for Multipath Operation with Multiple AddressesM. Amend, Ed., A. Brunstrom, A. Kassler, V. Rakocevic, S. Johnson | Proposed Standard | January 2026 |
| 9842 | Compression Dictionary TransportP. Meenan, Ed., Y. Weiss, Ed. | Proposed Standard | September 2025 |
| 9795 | Personal Assertion Token (PASSporT) Extension for Rich Call DataC. Wendt, J. Peterson | Proposed Standard | July 2025 |
| 9704 | Establishing Local DNS Authority in Validated Split-Horizon EnvironmentsT. Reddy.K, D. Wing, K. Smith, B. Schwartz | Proposed Standard | January 2025 |
| 9679 | CBOR Object Signing and Encryption (COSE) Key ThumbprintK. Isobe, H. Tschofenig, O. Steele | Proposed Standard | December 2024 |
| 9588 | Kerberos Simple Password-Authenticated Key Exchange (SPAKE) Pre-authenticationN. McCallum, S. Sorce, R. Harwood, G. Hudson | Proposed Standard | August 2024 |
| 9580 | OpenPGPP. Wouters, Ed., D. Huigens, J. Winter, Y. Niibe | Proposed Standard | July 2024 |
| 9564 | Faster Than Light Speed Protocol (FLIP)M. Blanchet | Informational | 1 April 2024 |
| 9530 | Digest FieldsR. Polli, L. Pardue | Proposed Standard | February 2024 |
| 9498 | The GNU Name SystemM. Schanzenbach, C. Grothoff, B. Fix | Informational | November 2023 |
| 9475 | Messaging Use Cases and Extensions for Secure Telephone Identity Revisited (STIR)J. Peterson, C. Wendt | Proposed Standard | December 2023 |
| 9464 | Internet Key Exchange Protocol Version 2 (IKEv2) Configuration for Encrypted DNSM. Boucadair, T. Reddy.K, D. Wing, V. Smyslov | Proposed Standard | November 2023 |
| 9431 | Message Queuing Telemetry Transport (MQTT) and Transport Layer Security (TLS) Profile of Authentication and Authorization for Constrained Environments (ACE) FrameworkC. Sengul, A. Kirby | Proposed Standard | July 2023 |
| 9421 | HTTP Message SignaturesA. Backman, Ed., J. Richer, Ed., M. Sporny | Proposed Standard | February 2024 |
| 9383 | SPAKE2+, an Augmented Password-Authenticated Key Exchange (PAKE) ProtocolT. Taubert, C. A. Wood | Informational | September 2023 |
| 9382 | SPAKE2, a Password-Authenticated Key ExchangeW. Ladd | Informational | September 2023 |
| 9381 | Verifiable Random Functions (VRFs)S. Goldberg, L. Reyzin, D. Papadopoulos, J. Včelák | Informational | August 2023 |
| 9303 | Locator/ID Separation Protocol Security (LISP-SEC)F. Maino, V. Ermagan, A. Cabellos, D. Saucez | Proposed Standard | October 2022 |
| 9231 | Additional XML Security Uniform Resource Identifiers (URIs)D. Eastlake 3rd | Proposed Standard | July 2022 |
| 9162 | Certificate Transparency Version 2.0B. Laurie, E. Messeri, R. Stradling | Experimental | December 2021 |
| 9150 | TLS 1.3 Authentication and Integrity-Only Cipher SuitesN. Cam-Winget, J. Visoky | Informational | April 2022 |
| 9142 | Key Exchange (KEX) Method Updates and Recommendations for Secure Shell (SSH)M. Baushke | Proposed Standard | January 2022 |
| 9140 | Nimble Out-of-Band Authentication for EAP (EAP-NOOB)T. Aura, M. Sethi, A. Peltonen | Proposed Standard | December 2021 |
| 9132 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationM. Boucadair, Ed., J. Shallow, T. Reddy.K | Proposed Standard | September 2021 |
| 9022 | Domain Name Registration Data (DNRD) Objects MappingG. Lozano, J. Gould, C. Thippeswamy | Proposed Standard | May 2021 |
| 8976 | Message Digest for DNS ZonesD. Wessels, P. Barber, M. Weinberg, W. Kumari, W. Hardaker | Proposed Standard | February 2021 |
| 8974 | Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP)K. Hartke, M. Richardson | Proposed Standard | January 2021 |
| 8967 | MAC Authentication for the Babel Routing ProtocolC. Dô, W. Kolodziejak, J. Chroboczek | Proposed Standard | January 2021 |
| 8945 | Secret Key Transaction Authentication for DNS (TSIG)F. Dupont, S. Morris, P. Vixie, D. Eastlake 3rd, O. Gudmundsson, B. Wellington | Internet Standard | November 2020 |
| 8928 | Address-Protected Neighbor Discovery for Low-Power and Lossy NetworksP. Thubert, Ed., B. Sarikaya, M. Sethi, R. Struik | Proposed Standard | November 2020 |
| 8844 | Unknown Key-Share Attacks on Uses of TLS with the Session Description Protocol (SDP)M. Thomson, E. Rescorla | Proposed Standard | January 2021 |
| 8823 | Extensions to Automatic Certificate Management Environment for End-User S/MIME CertificatesA. Melnikov | Informational | April 2021 |
| 8802 | The Quality for Service (Q4S) ProtocolJ.J. Aranda, M. Cortes, J. Salvachúa, M. Narganes, I. Martínez-Sarriegui | Informational | July 2020 |
| 8793 | Information-Centric Networking (ICN): Content-Centric Networking (CCNx) and Named Data Networking (NDN) TerminologyB. Wissingh, C. Wood, A. Afanasyev, L. Zhang, D. Oran, C. Tschudin | Informational | June 2020 |
| 8782 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationT. Reddy.K, Ed., M. Boucadair, Ed., P. Patil, A. Mortensen, N. Teague · obsoleted by RFC 9132 | Proposed Standard | May 2020 |
| 8732 | Generic Security Service Application Program Interface (GSS-API) Key Exchange with SHA-2S. Sorce, H. Kario | Proposed Standard | February 2020 |
| 8731 | Secure Shell (SSH) Key Exchange Method Using Curve25519 and Curve448A. Adamantiadis, S. Josefsson, M. Baushke | Proposed Standard | February 2020 |
| 8684 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure, C. Paasch | Proposed Standard | March 2020 |
| 8636 | Public Key Cryptography for Initial Authentication in Kerberos (PKINIT) Algorithm AgilityL. Hornquist Astrand, L. Zhu, M. Cullen, G. Hudson | Proposed Standard | July 2019 |
| 8572 | Secure Zero Touch Provisioning (SZTP)K. Watsen, I. Farrer, M. Abrahamsson | Proposed Standard | April 2019 |
| 8493 | The BagIt File Packaging Format (V1.0)J. Kunze, J. Littman, E. Madden, J. Scancella, C. Adams | Informational | October 2018 |
| 8458 | Using National Bibliography Numbers as Uniform Resource NamesJ. Hakala | Informational | October 2018 |
| 8419 | Use of Edwards-Curve Digital Signature Algorithm (EdDSA) Signatures in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | August 2018 |
| 8315 | Cancel-Locks in Netnews ArticlesM. Baeuerle | Proposed Standard | February 2018 |
| 8268 | More Modular Exponentiation (MODP) Diffie-Hellman (DH) Key Exchange (KEX) Groups for Secure Shell (SSH)M. Baushke | Proposed Standard | December 2017 |
| 8032 | Edwards-Curve Digital Signature Algorithm (EdDSA)S. Josefsson, I. Liusvaara | Informational | January 2017 |
| 7978 | Transparent Interconnection of Lots of Links (TRILL): RBridge Channel Header ExtensionD. Eastlake 3rd, M. Umair, Y. Li | Proposed Standard | September 2016 |
| 7937 | Content Distribution Network Interconnection (CDNI) Logging InterfaceF. Le Faucheur, Ed., G. Bertrand, Ed., I. Oprescu, Ed., R. Peterkofsky | Proposed Standard | August 2016 |
| 7925 | Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. Fossati | Proposed Standard | July 2016 |
| 7924 | Transport Layer Security (TLS) Cached Information ExtensionS. Santesson, H. Tschofenig | Proposed Standard | July 2016 |
| 7914 | The scrypt Password-Based Key Derivation FunctionC. Percival, S. Josefsson | Informational | August 2016 |
| 7873 | Domain Name System (DNS) CookiesD. Eastlake 3rd, M. Andrews | Proposed Standard | May 2016 |
| 7860 | HMAC-SHA-2 Authentication Protocols in User-Based Security Model (USM) for SNMPv3J. Merkle, Ed., M. Lochter | Proposed Standard | April 2016 |
| 7858 | Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. Hoffman | Proposed Standard | May 2016 |
| 7804 | Salted Challenge Response HTTP Authentication MechanismA. Melnikov | Experimental | March 2016 |
| 7788 | Home Networking Control ProtocolM. Stenberg, S. Barth, P. Pfister | Proposed Standard | April 2016 |
| 7787 | Distributed Node Consensus ProtocolM. Stenberg, S. Barth | Proposed Standard | April 2016 |
| 7781 | Transparent Interconnection of Lots of Links (TRILL): Pseudo-Nickname for Active-Active AccessH. Zhai, T. Senevirathne, R. Perlman, M. Zhang, Y. Li | Proposed Standard | February 2016 |
| 7693 | The BLAKE2 Cryptographic Hash and Message Authentication Code (MAC)M-J. Saarinen, Ed., J-P. Aumasson | Informational | November 2015 |
| 7677 | SCRAM-SHA-256 and SCRAM-SHA-256-PLUS Simple Authentication and Security Layer (SASL) MechanismsT. Hansen | Proposed Standard | November 2015 |
| 7636 | Proof Key for Code Exchange by OAuth Public ClientsN. Sakimura, Ed., J. Bradley, N. Agarwal | Proposed Standard | September 2015 |
| 7630 | HMAC-SHA-2 Authentication Protocols in the User-based Security Model (USM) for SNMPv3J. Merkle, Ed., M. Lochter · obsoleted by RFC 7860 | Proposed Standard | October 2015 |
| 7469 | Public Key Pinning Extension for HTTPC. Evans, C. Palmer, R. Sleevi | Proposed Standard | April 2015 |
| 7425 | Adobe's RTMFP Profile for Flash CommunicationM. Thornburgh | Informational | December 2014 |
| 7357 | Transparent Interconnection of Lots of Links (TRILL): End Station Address Distribution Information (ESADI) ProtocolH. Zhai, F. Hu, R. Perlman, D. Eastlake 3rd, O. Stokes | Proposed Standard | September 2014 |
| 7218 | Adding Acronyms to Simplify Conversations about DNS-Based Authentication of Named Entities (DANE)O. Gudmundsson | Proposed Standard | April 2014 |
| 7175 | Transparent Interconnection of Lots of Links (TRILL): Bidirectional Forwarding Detection (BFD) SupportV. Manral, D. Eastlake 3rd, D. Ward, A. Banerjee | Proposed Standard | May 2014 |
| 6968 | FCAST: Object Delivery for the Asynchronous Layered Coding (ALC) and NACK-Oriented Reliable Multicast (NORM) ProtocolsV. Roca, B. Adamson | Experimental | July 2013 |
| 6955 | Diffie-Hellman Proof-of-Possession AlgorithmsJ. Schaad, H. Prafullchandra | Proposed Standard | May 2013 |
| 6940 | REsource LOcation And Discovery (RELOAD) Base ProtocolC. Jennings, B. Lowekamp, Ed., E. Rescorla, S. Baset, H. Schulzrinne | Proposed Standard | January 2014 |
| 6931 | Additional XML Security Uniform Resource Identifiers (URIs)D. Eastlake 3rd · obsoleted by RFC 9231 | Proposed Standard | April 2013 |
| 6833 | Locator/ID Separation Protocol (LISP) Map-Server InterfaceV. Fuller, D. Farinacci · obsoleted by RFC 9301 | Experimental | January 2013 |
| 6824 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure · obsoleted by RFC 8684 | Experimental | January 2013 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6668 | SHA-2 Data Integrity Verification for the Secure Shell (SSH) Transport Layer ProtocolD. Bider, M. Baushke | Proposed Standard | July 2012 |
| 6605 | Elliptic Curve Digital Signature Algorithm (DSA) for DNSSECP. Hoffman, W.C.A. Wijngaards | Proposed Standard | April 2012 |
| 6506 | Supporting Authentication Trailer for OSPFv3M. Bhatia, V. Manral, A. Lindem · obsoleted by RFC 7166 | Proposed Standard | February 2012 |