| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2475 | An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. Weiss | Informational | December 1998 |
| 2597 | Assured Forwarding PHB GroupJ. Heinanen, F. Baker, W. Weiss, J. Wroclawski | Proposed Standard | June 1999 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2854 | The 'text/html' Media TypeD. Connolly, L. Masinter | Informational | June 2000 |
| 3022 | Traditional IP Network Address Translator (Traditional NAT)P. Srisuresh, K. Egevang | Informational | January 2001 |
| 3140 | Per Hop Behavior Identification CodesD. Black, S. Brim, B. Carpenter, F. Le Faucheur | Proposed Standard | June 2001 |
| 3246 | An Expedited Forwarding PHB (Per-Hop Behavior)B. Davie, A. Charny, J.C.R. Bennet, K. Benson, J.Y. Le Boudec, W. Courtney, S. Davari, V. Firoiu, D. Stiliadis | Proposed Standard | March 2002 |
| 3260 | New Terminology and Clarifications for DiffservD. Grossman | Informational | April 2002 |
| 3360 | Inappropriate TCP Resets Considered HarmfulS. Floyd | Best Current Practice | August 2002 |
| 3507 | Internet Content Adaptation Protocol (ICAP)J. Elson, A. Cerpa | Informational | April 2003 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4329 | Scripting Media TypesB. Hoehrmann · obsoleted by RFC 9239 | Informational | April 2006 |
| 4594 | Configuration Guidelines for DiffServ Service ClassesJ. Babiarz, K. Chan, F. Baker | Informational | August 2006 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |