| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 1337 | TIME-WAIT Assassination Hazards in TCPR. Braden | Informational | May 1992 |
| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2473 | Generic Packet Tunneling in IPv6 SpecificationA. Conta, S. Deering | Proposed Standard | December 1998 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 2993 | Architectural Implications of NATT. Hain | Informational | November 2000 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3704 | Ingress Filtering for Multihomed NetworksF. Baker, P. Savola | Best Current Practice | March 2004 |
| 3775 | Mobility Support in IPv6D. Johnson, C. Perkins, J. Arkko · obsoleted by RFC 6275 | Proposed Standard | June 2004 |
| 3828 | The Lightweight User Datagram Protocol (UDP-Lite)L-A. Larzon, M. Degermark, S. Pink, L-E. Jonsson, Ed., G. Fairhurst, Ed. | Proposed Standard | July 2004 |
| 3879 | Deprecating Site Local AddressesC. Huitema, B. Carpenter | Proposed Standard | September 2004 |
| 4007 | IPv6 Scoped Address ArchitectureS. Deering, B. Haberman, T. Jinmei, E. Nordmark, B. Zill | Proposed Standard | March 2005 |
| 4080 | Next Steps in Signaling (NSIS): FrameworkR. Hancock, G. Karagiannis, J. Loughney, S. Van den Bosch | Informational | June 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4294 | IPv6 Node RequirementsJ. Loughney, Ed. · obsoleted by RFC 6434 | Informational | April 2006 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4787 | Network Address Translation (NAT) Behavioral Requirements for Unicast UDPF. Audet, Ed., C. Jennings | Best Current Practice | January 2007 |
| 4864 | Local Network Protection for IPv6G. Van de Velde, T. Hain, R. Droms, B. Carpenter, E. Klein | Informational | May 2007 |
| 4890 | Recommendations for Filtering ICMPv6 Messages in FirewallsE. Davies, J. Mohacsi | Informational | May 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 5095 | Deprecation of Type 0 Routing Headers in IPv6J. Abley, P. Savola, G. Neville-Neil | Proposed Standard | December 2007 |
| 5156 | Special-Use IPv6 AddressesM. Blanchet · obsoleted by RFC 6890 | Informational | April 2008 |
| 5189 | Middlebox Communication (MIDCOM) Protocol SemanticsM. Stiemerling, J. Quittek, T. Taylor | Proposed Standard | March 2008 |
| 5201 | Host Identity ProtocolR. Moskowitz, P. Nikander, P. Jokela, Ed., T. Henderson · obsoleted by RFC 7401 | Experimental | April 2008 |
| 5382 | NAT Behavioral Requirements for TCPS. Guha, Ed., K. Biswas, B. Ford, S. Sivakumar, P. Srisuresh | Best Current Practice | October 2008 |
| 5386 | Better-Than-Nothing Security: An Unauthenticated Mode of IPsecN. Williams, M. Richardson | Proposed Standard | November 2008 |
| 5389 | Session Traversal Utilities for NAT (STUN)J. Rosenberg, R. Mahy, P. Matthews, D. Wing · obsoleted by RFC 8489 | Proposed Standard | October 2008 |
| 5533 | Shim6: Level 3 Multihoming Shim Protocol for IPv6E. Nordmark, M. Bagnulo | Proposed Standard | June 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |