| 2026 | The Internet Standards Process -- Revision 3S. Bradner | Best Current Practice | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2394 | IP Payload Compression Using DEFLATER. Pereira | Informational | December 1998 |
| 2395 | IP Payload Compression Using LZSR. Friend, R. Monsour | Informational | December 1998 |
| 2401 | Security Architecture for the Internet ProtocolS. Kent, R. Atkinson · obsoleted by RFC 4301 | Proposed Standard | November 1998 |
| 2402 | IP Authentication HeaderS. Kent, R. Atkinson · obsoleted by RFC 4302, RFC 4305 | Proposed Standard | November 1998 |
| 2403 | The Use of HMAC-MD5-96 within ESP and AHC. Madson, R. Glenn | Proposed Standard | November 1998 |
| 2404 | The Use of HMAC-SHA-1-96 within ESP and AHC. Madson, R. Glenn | Proposed Standard | November 1998 |
| 2405 | The ESP DES-CBC Cipher Algorithm With Explicit IVC. Madson, N. Doraswamy | Proposed Standard | November 1998 |
| 2406 | IP Encapsulating Security Payload (ESP)S. Kent, R. Atkinson · obsoleted by RFC 4303, RFC 4305 | Proposed Standard | November 1998 |
| 2407 | The Internet IP Security Domain of Interpretation for ISAKMPD. Piper · obsoleted by RFC 4306 | Historic | November 1998 |
| 2408 | Internet Security Association and Key Management Protocol (ISAKMP)D. Maughan, M. Schertler, M. Schneider, J. Turner · obsoleted by RFC 4306 | Historic | November 1998 |
| 2409 | The Internet Key Exchange (IKE)D. Harkins, D. Carrel · obsoleted by RFC 4306 | Historic | November 1998 |
| 2410 | The NULL Encryption Algorithm and Its Use With IPsecR. Glenn, S. Kent | Proposed Standard | November 1998 |
| 2411 | IP Security Document RoadmapR. Thayer, N. Doraswamy, R. Glenn · obsoleted by RFC 6071 | Informational | November 1998 |
| 2412 | The OAKLEY Key Determination ProtocolH. Orman | Informational | November 1998 |
| 2451 | The ESP CBC-Mode Cipher AlgorithmsR. Pereira, R. Adams | Proposed Standard | November 1998 |
| 2521 | ICMP Security Failures MessagesP. Karn, W. Simpson | Experimental | March 1999 |
| 2709 | Security Model with Tunnel-mode IPsec for NAT DomainsP. Srisuresh | Informational | October 1999 |
| 2857 | The Use of HMAC-RIPEMD-160-96 within ESP and AHA. Keromytis, N. Provos | Proposed Standard | June 2000 |
| 3051 | IP Payload Compression Using ITU-T V.44 Packet MethodJ. Heath, J. Border | Informational | January 2001 |
| 3056 | Connection of IPv6 Domains via IPv4 CloudsB. Carpenter, K. Moore | Proposed Standard | February 2001 |
| 3095 | RObust Header Compression (ROHC): Framework and four profiles: RTP, UDP, ESP, and uncompressedC. Bormann, C. Burmeister, M. Degermark, H. Fukushima, H. Hannu, L-E. Jonsson, R. Hakenberg, T. Koren, K. Le, Z. Liu, A. Martensson, A. Miyazaki, K. Svanbro, T. Wiebke, T. Yoshimura, H. Zheng | Proposed Standard | July 2001 |
| 3129 | Requirements for Kerberized Internet Negotiation of KeysM. Thomas | Informational | June 2001 |
| 3173 | IP Payload Compression Protocol (IPComp)A. Shacham, B. Monsour, R. Pereira, M. Thomas | Proposed Standard | September 2001 |
| 3329 | Security Mechanism Agreement for the Session Initiation Protocol (SIP)J. Arkko, V. Torvinen, G. Camarillo, A. Niemi, T. Haukka | Proposed Standard | January 2003 |
| 3456 | Dynamic Host Configuration Protocol (DHCPv4) Configuration of IPsec Tunnel ModeB. Patel, B. Aboba, S. Kelly, V. Gupta | Proposed Standard | January 2003 |
| 3457 | Requirements for IPsec Remote Access ScenariosS. Kelly, S. Ramamoorthi | Informational | January 2003 |
| 3526 | More Modular Exponential (MODP) Diffie-Hellman groups for Internet Key Exchange (IKE)T. Kivinen, M. Kojo | Proposed Standard | May 2003 |
| 3547 | The Group Domain of InterpretationM. Baugher, B. Weis, T. Hardjono, H. Harney · obsoleted by RFC 6407 | Proposed Standard | July 2003 |
| 3554 | On the Use of Stream Control Transmission Protocol (SCTP) with IPsecS. Bellovin, J. Ioannidis, A. Keromytis, R. Stewart | Proposed Standard | July 2003 |
| 3566 | The AES-XCBC-MAC-96 Algorithm and Its Use With IPsecS. Frankel, H. Herbert | Proposed Standard | September 2003 |
| 3585 | IPsec Configuration Policy Information ModelJ. Jason, L. Rafalow, E. Vyncke | Proposed Standard | August 2003 |
| 3586 | IP Security Policy (IPSP) RequirementsM. Blaze, A. Keromytis, M. Richardson, L. Sanchez | Proposed Standard | August 2003 |
| 3602 | The AES-CBC Cipher Algorithm and Its Use with IPsecS. Frankel, R. Glenn, S. Kelly | Proposed Standard | September 2003 |
| 3686 | Using Advanced Encryption Standard (AES) Counter Mode With IPsec Encapsulating Security Payload (ESP)R. Housley | Proposed Standard | January 2004 |
| 3706 | A Traffic-Based Method of Detecting Dead Internet Key Exchange (IKE) PeersG. Huang, S. Beaulieu, D. Rochefort | Informational | February 2004 |
| 3715 | IPsec-Network Address Translation (NAT) Compatibility RequirementsB. Aboba, W. Dixon | Informational | March 2004 |
| 3740 | The Multicast Group Security ArchitectureT. Hardjono, B. Weis | Informational | March 2004 |
| 3776 | Using IPsec to Protect Mobile IPv6 Signaling Between Mobile Nodes and Home AgentsJ. Arkko, V. Devarapalli, F. Dupont | Proposed Standard | June 2004 |
| 3830 | MIKEY: Multimedia Internet KEYingJ. Arkko, E. Carrara, F. Lindholm, M. Naslund, K. Norrman | Proposed Standard | August 2004 |
| 3884 | Use of IPsec Transport Mode for Dynamic RoutingJ. Touch, L. Eggert, Y. Wang | Informational | September 2004 |
| 3947 | Negotiation of NAT-Traversal in the IKET. Kivinen, B. Swander, A. Huttunen, V. Volpe | Proposed Standard | January 2005 |
| 3948 | UDP Encapsulation of IPsec ESP PacketsA. Huttunen, B. Swander, V. Volpe, L. DiBurro, M. Stenberg | Proposed Standard | January 2005 |
| 4025 | A Method for Storing IPsec Keying Material in DNSM. Richardson | Proposed Standard | March 2005 |
| 4046 | Multicast Security (MSEC) Group Key Management ArchitectureM. Baugher, R. Canetti, L. Dondeti, F. Lindholm | Informational | May 2005 |
| 4093 | Problem Statement: Mobile IPv4 Traversal of Virtual Private Network (VPN) GatewaysF. Adrangi, Ed., H. Levkowetz, Ed. | Informational | August 2005 |
| 4106 | The Use of Galois/Counter Mode (GCM) in IPsec Encapsulating Security Payload (ESP)J. Viega, D. McGrew | Proposed Standard | June 2005 |
| 4109 | Algorithms for Internet Key Exchange version 1 (IKEv1)P. Hoffman | Proposed Standard | May 2005 |
| 4196 | The SEED Cipher Algorithm and Its Use with IPsecH.J. Lee, J.H. Yoon, S.L. Lee, J.I. Lee | Proposed Standard | October 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4304 | Extended Sequence Number (ESN) Addendum to IPsec Domain of Interpretation (DOI) for Internet Security Association and Key Management Protocol (ISAKMP)S. Kent | Proposed Standard | December 2005 |
| 4305 | Cryptographic Algorithm Implementation Requirements for Encapsulating Security Payload (ESP) and Authentication Header (AH)D. Eastlake 3rd · obsoleted by RFC 4835 | Proposed Standard | December 2005 |
| 4306 | Internet Key Exchange (IKEv2) ProtocolC. Kaufman, Ed. · obsoleted by RFC 5996 | Proposed Standard | December 2005 |
| 4307 | Cryptographic Algorithms for Use in the Internet Key Exchange Version 2 (IKEv2)J. Schiller · obsoleted by RFC 8247 | Proposed Standard | December 2005 |
| 4308 | Cryptographic Suites for IPsecP. Hoffman | Proposed Standard | December 2005 |
| 4309 | Using Advanced Encryption Standard (AES) CCM Mode with IPsec Encapsulating Security Payload (ESP)R. Housley | Proposed Standard | December 2005 |
| 4312 | The Camellia Cipher Algorithm and Its Use With IPsecA. Kato, S. Moriai, M. Kanda | Proposed Standard | December 2005 |
| 4322 | Opportunistic Encryption using the Internet Key Exchange (IKE)M. Richardson, D.H. Redelmeier | Informational | December 2005 |
| 4359 | The Use of RSA/SHA-1 Signatures within Encapsulating Security Payload (ESP) and Authentication Header (AH)B. Weis | Proposed Standard | January 2006 |
| 4430 | Kerberized Internet Negotiation of Keys (KINK)S. Sakane, K. Kamada, M. Thomas, J. Vilhuber | Proposed Standard | March 2006 |
| 4434 | The AES-XCBC-PRF-128 Algorithm for the Internet Key Exchange Protocol (IKE)P. Hoffman | Proposed Standard | February 2006 |
| 4478 | Repeated Authentication in Internet Key Exchange (IKEv2) ProtocolY. Nir | Experimental | April 2006 |
| 4494 | The AES-CMAC-96 Algorithm and Its Use with IPsecJH. Song, R. Poovendran, J. Lee | Proposed Standard | June 2006 |
| 4535 | GSAKMP: Group Secure Association Key Management ProtocolH. Harney, U. Meth, A. Colegrove, G. Gross | Proposed Standard | June 2006 |
| 4543 | The Use of Galois Message Authentication Code (GMAC) in IPsec ESP and AHD. McGrew, J. Viega | Proposed Standard | May 2006 |
| 4552 | Authentication/Confidentiality for OSPFv3M. Gupta, N. Melam | Proposed Standard | June 2006 |
| 4555 | IKEv2 Mobility and Multihoming Protocol (MOBIKE)P. Eronen | Proposed Standard | June 2006 |
| 4595 | Use of IKEv2 in the Fibre Channel Security Association Management ProtocolF. Maino, D. Black | Informational | July 2006 |
| 4615 | The Advanced Encryption Standard-Cipher-based Message Authentication Code-Pseudo-Random Function-128 (AES-CMAC-PRF-128) Algorithm for the Internet Key Exchange Protocol (IKE)J. Song, R. Poovendran, J. Lee, T. Iwata | Proposed Standard | August 2006 |
| 4621 | Design of the IKEv2 Mobility and Multihoming (MOBIKE) ProtocolT. Kivinen, H. Tschofenig | Informational | August 2006 |
| 4705 | GigaBeam High-Speed Radio Link EncryptionR. Housley, A. Corry | Informational | October 2006 |
| 4718 | IKEv2 Clarifications and Implementation GuidelinesP. Eronen, P. Hoffman · obsoleted by RFC 5996 | Informational | October 2006 |
| 4739 | Multiple Authentication Exchanges in the Internet Key Exchange (IKEv2) ProtocolP. Eronen, J. Korhonen | Experimental | November 2006 |
| 4753 | ECP Groups For IKE and IKEv2D. Fu, J. Solinas · obsoleted by RFC 5903 | Informational | January 2007 |
| 4754 | IKE and IKEv2 Authentication Using the Elliptic Curve Digital Signature Algorithm (ECDSA)D. Fu, J. Solinas | Proposed Standard | January 2007 |
| 4806 | Online Certificate Status Protocol (OCSP) Extensions to IKEv2M. Myers, H. Tschofenig | Proposed Standard | February 2007 |
| 4807 | IPsec Security Policy Database Configuration MIBM. Baer, R. Charlet, W. Hardaker, R. Story, C. Wang | Proposed Standard | March 2007 |
| 4809 | Requirements for an IPsec Certificate Management ProfileC. Bonatti, Ed., S. Turner, Ed., G. Lebovitz, Ed. | Informational | February 2007 |
| 4835 | Cryptographic Algorithm Implementation Requirements for Encapsulating Security Payload (ESP) and Authentication Header (AH)V. Manral · obsoleted by RFC 7321 | Proposed Standard | April 2007 |
| 4868 | Using HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512 with IPsecS. Kelly, S. Frankel | Proposed Standard | May 2007 |
| 4869 | Suite B Cryptographic Suites for IPsecL. Law, J. Solinas · obsoleted by RFC 6379 | Historic | May 2007 |
| 4877 | Mobile IPv6 Operation with IKEv2 and the Revised IPsec ArchitectureV. Devarapalli, F. Dupont | Proposed Standard | April 2007 |
| 4891 | Using IPsec to Secure IPv6-in-IPv4 TunnelsR. Graveman, M. Parthasarathy, P. Savola, H. Tschofenig | Informational | May 2007 |
| 4894 | Use of Hash Algorithms in Internet Key Exchange (IKE) and IPsecP. Hoffman | Informational | May 2007 |
| 4945 | The Internet IP Security PKI Profile of IKEv1/ISAKMP, IKEv2, and PKIXB. Korver | Proposed Standard | August 2007 |
| 5026 | Mobile IPv6 Bootstrapping in Split ScenarioG. Giaretta, Ed., J. Kempf, V. Devarapalli, Ed. | Proposed Standard | October 2007 |
| 5106 | The Extensible Authentication Protocol-Internet Key Exchange Protocol version 2 (EAP-IKEv2) MethodH. Tschofenig, D. Kroeselberg, A. Pashalidis, Y. Ohba, F. Bersani | Experimental | February 2008 |
| 5114 | Additional Diffie-Hellman Groups for Use with IETF StandardsM. Lepinski, S. Kent | Informational | January 2008 |
| 5201 | Host Identity ProtocolR. Moskowitz, P. Nikander, P. Jokela, Ed., T. Henderson · obsoleted by RFC 7401 | Experimental | April 2008 |
| 5202 | Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)P. Jokela, R. Moskowitz, P. Nikander · obsoleted by RFC 7402 | Experimental | April 2008 |
| 5206 | End-Host Mobility and Multihoming with the Host Identity ProtocolP. Nikander, T. Henderson, Ed., C. Vogt, J. Arkko · obsoleted by RFC 8046 | Experimental | April 2008 |
| 5207 | NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) CommunicationM. Stiemerling, J. Quittek, L. Eggert | Informational | April 2008 |
| 5213 | Proxy Mobile IPv6S. Gundavelli, Ed., K. Leung, V. Devarapalli, K. Chowdhury, B. Patil | Proposed Standard | August 2008 |
| 5225 | RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-LiteG. Pelletier, K. Sandlund | Proposed Standard | April 2008 |
| 5265 | Mobile IPv4 Traversal across IPsec-Based VPN GatewaysS. Vaarala, E. Klovning | Proposed Standard | June 2008 |
| 5266 | Secure Connectivity and Mobility Using Mobile IPv4 and IKEv2 Mobility and Multihoming (MOBIKE)V. Devarapalli, P. Eronen | Best Current Practice | June 2008 |
| 5282 | Using Authenticated Encryption Algorithms with the Encrypted Payload of the Internet Key Exchange version 2 (IKEv2) ProtocolD. Black, D. McGrew | Proposed Standard | August 2008 |
| 5374 | Multicast Extensions to the Security Architecture for the Internet ProtocolB. Weis, G. Gross, D. Ignjatic | Proposed Standard | November 2008 |
| 5380 | Hierarchical Mobile IPv6 (HMIPv6) Mobility ManagementH. Soliman, C. Castelluccia, K. ElMalki, L. Bellier | Proposed Standard | October 2008 |
| 5386 | Better-Than-Nothing Security: An Unauthenticated Mode of IPsecN. Williams, M. Richardson | Proposed Standard | November 2008 |
| 5387 | Problem and Applicability Statement for Better-Than-Nothing Security (BTNS)J. Touch, D. Black, Y. Wang | Informational | November 2008 |
| 5406 | Guidelines for Specifying the Use of IPsec Version 2S. Bellovin | Best Current Practice | February 2009 |
| 5529 | Modes of Operation for Camellia for Use with IPsecA. Kato, M. Kanda, S. Kanno | Proposed Standard | April 2009 |
| 5566 | BGP IPsec Tunnel Encapsulation AttributeL. Berger, R. White, E. Rosen · obsoleted by RFC 9012 | Proposed Standard | June 2009 |
| 5568 | Mobile IPv6 Fast HandoversR. Koodli, Ed. | Proposed Standard | July 2009 |
| 5570 | Common Architecture Label IPv6 Security Option (CALIPSO)M. StJohns, R. Atkinson, G. Thomas | Informational | July 2009 |
| 5660 | IPsec Channels: Connection LatchingN. Williams | Proposed Standard | October 2009 |
| 5685 | Redirect Mechanism for the Internet Key Exchange Protocol Version 2 (IKEv2)V. Devarapalli, K. Weniger | Proposed Standard | November 2009 |
| 5723 | Internet Key Exchange Protocol Version 2 (IKEv2) Session ResumptionY. Sheffer, H. Tschofenig | Proposed Standard | January 2010 |
| 5739 | IPv6 Configuration in Internet Key Exchange Protocol Version 2 (IKEv2)P. Eronen, J. Laganier, C. Madson | Experimental | February 2010 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5840 | Wrapped Encapsulating Security Payload (ESP) for Traffic VisibilityK. Grewal, G. Montenegro, M. Bhatia | Proposed Standard | April 2010 |
| 5856 | Integration of Robust Header Compression over IPsec Security AssociationsE. Ertekin, R. Jasani, C. Christou, C. Bormann | Informational | May 2010 |
| 5857 | IKEv2 Extensions to Support Robust Header Compression over IPsecE. Ertekin, C. Christou, R. Jasani, T. Kivinen, C. Bormann | Proposed Standard | May 2010 |
| 5858 | IPsec Extensions to Support Robust Header Compression over IPsecE. Ertekin, C. Christou, C. Bormann | Proposed Standard | May 2010 |
| 5879 | Heuristics for Detecting ESP-NULL PacketsT. Kivinen, D. McDonald | Informational | May 2010 |
| 5903 | Elliptic Curve Groups modulo a Prime (ECP Groups) for IKE and IKEv2D. Fu, J. Solinas | Informational | June 2010 |
| 5930 | Using Advanced Encryption Standard Counter Mode (AES-CTR) with the Internet Key Exchange version 02 (IKEv2) ProtocolS. Shen, Y. Mao, NSS. Murthy | Informational | July 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 5998 | An Extension for EAP-Only Authentication in IKEv2P. Eronen, H. Tschofenig, Y. Sheffer | Proposed Standard | September 2010 |
| 6027 | IPsec Cluster Problem StatementY. Nir | Informational | October 2010 |