| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 792 | Internet Control Message ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 1812 | Requirements for IP Version 4 RoutersF. Baker, Ed. | Proposed Standard | June 1995 |
| 2003 | IP Encapsulation within IPC. Perkins | Proposed Standard | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2784 | Generic Routing Encapsulation (GRE)D. Farinacci, T. Li, S. Hanks, D. Meyer, P. Traina | Proposed Standard | March 2000 |
| 2988 | Computing TCP's Retransmission TimerV. Paxson, M. Allman · obsoleted by RFC 6298 | Proposed Standard | November 2000 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3522 | The Eifel Detection Algorithm for TCPR. Ludwig, M. Meyer | Experimental | April 2003 |
| 3782 | The NewReno Modification to TCP's Fast Recovery AlgorithmS. Floyd, T. Henderson, A. Gurtov · obsoleted by RFC 6582 | Proposed Standard | April 2004 |
| 3819 | Advice for Internet Subnetwork DesignersP. Karn, Ed., C. Bormann, G. Fairhurst, D. Grossman, R. Ludwig, J. Mahdavi, G. Montenegro, J. Touch, L. Wood | Best Current Practice | July 2004 |
| 4015 | The Eifel Response Algorithm for TCPR. Ludwig, A. Gurtov | Proposed Standard | February 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 5461 | TCP's Reaction to Soft ErrorsF. Gont | Informational | February 2009 |
| 5681 | TCP Congestion ControlM. Allman, V. Paxson, E. Blanton | Draft Standard | September 2009 |
| 5682 | Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCPP. Sarolahti, M. Kojo, K. Yamamoto, M. Hata | Proposed Standard | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5927 | ICMP Attacks against TCPF. Gont | Informational | July 2010 |