| 10053 | A Framework for Computing-Aware Traffic Steering (CATS)C. Li, Ed., Z. Du, M. Boucadair, Ed., L. M. Contreras, J. Drake | Informational | October 2026 |
| 9950 | A YANG Data Model for Terminal Access Controller Access-Control System Plus (TACACS+)M. Boucadair, Ed., B. Wu | Proposed Standard | March 2026 |
| 9930 | Tunnel Extensible Authentication Protocol (TEAP) Version 1A. DeKok, Ed. | Proposed Standard | February 2026 |
| 9887 | Terminal Access Controller Access-Control System Plus (TACACS+) over TLS 1.3T. Dahm, J. Heasley, D.C. Medway Gash, A. Ota | Proposed Standard | December 2025 |
| 9846 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla | Proposed Standard | July 2026 |
| 9761 | Manufacturer Usage Description (MUD) for TLS and DTLS Profiles for Internet of Things (IoT) DevicesT. Reddy.K, D. Wing, B. Anderson | Proposed Standard | April 2025 |
| 9726 | Operational Considerations for Use of DNS in Internet of Things (IoT) DevicesM. Richardson, W. Pan | Best Current Practice | March 2025 |
| 9525 | Service Identity in TLSP. Saint-Andre, R. Salz | Proposed Standard | November 2023 |
| 9505 | A Survey of Worldwide Censorship TechniquesJ. L. Hall, M. D. Aaron, A. Andersdotter, B. Jones, N. Feamster, M. Knodel | Informational | November 2023 |
| 9498 | The GNU Name SystemM. Schanzenbach, C. Grothoff, B. Fix | Informational | November 2023 |
| 9460 | Service Binding and Parameter Specification via the DNS (SVCB and HTTPS Resource Records)B. Schwartz, M. Bishop, E. Nygren | Proposed Standard | November 2023 |
| 9431 | Message Queuing Telemetry Transport (MQTT) and Transport Layer Security (TLS) Profile of Authentication and Authorization for Constrained Environments (ACE) FrameworkC. Sengul, A. Kirby | Proposed Standard | July 2023 |
| 9325 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, P. Saint-Andre, T. Fossati | Best Current Practice | November 2022 |
| 9312 | Manageability of the QUIC Transport ProtocolM. Kühlewind, B. Trammell | Informational | September 2022 |
| 9261 | Exported Authenticators in TLSN. Sullivan | Proposed Standard | July 2022 |
| 9257 | Guidance for External Pre-Shared Key (PSK) Usage in TLSR. Housley, J. Hoyland, M. Sethi, C. A. Wood | Informational | July 2022 |
| 9191 | Handling Large Certificates and Long Certificate Chains in TLS-Based EAP MethodsM. Sethi, J. Preuß Mattsson, S. Turner | Informational | February 2022 |
| 9190 | EAP-TLS 1.3: Using the Extensible Authentication Protocol with TLS 1.3J. Preuß Mattsson, M. Sethi | Proposed Standard | February 2022 |
| 9174 | Delay-Tolerant Networking TCP Convergence-Layer Protocol Version 4B. Sipos, M. Demmer, J. Ott, S. Perreault | Proposed Standard | January 2022 |
| 9170 | Long-Term Viability of Protocol Extension MechanismsM. Thomson, T. Pauly | Informational | December 2021 |
| 9162 | Certificate Transparency Version 2.0B. Laurie, E. Messeri, R. Stradling | Experimental | December 2021 |
| 9147 | The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. Modadugu | Proposed Standard | April 2022 |
| 9132 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationM. Boucadair, Ed., J. Shallow, T. Reddy.K | Proposed Standard | September 2021 |
| 9114 | HTTP/3M. Bishop, Ed. | Proposed Standard | June 2022 |
| 9113 | HTTP/2M. Thomson, Ed., C. Benfield, Ed. | Proposed Standard | June 2022 |
| 9102 | TLS DNSSEC Chain ExtensionV. Dukhovni, S. Huque, W. Toorop, P. Wouters, M. Shore | Experimental | August 2021 |
| 8908 | Captive Portal APIT. Pauly, Ed., D. Thakore, Ed. | Proposed Standard | September 2020 |
| 8782 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationT. Reddy.K, Ed., M. Boucadair, Ed., P. Patil, A. Mortensen, N. Teague · obsoleted by RFC 9132 | Proposed Standard | May 2020 |
| 8765 | DNS Push NotificationsT. Pusateri, S. Cheshire | Proposed Standard | June 2020 |
| 8744 | Issues and Requirements for Server Name Identification (SNI) Encryption in TLSC. Huitema | Informational | July 2020 |
| 8739 | Support for Short-Term, Automatically Renewed (STAR) Certificates in the Automated Certificate Management Environment (ACME)Y. Sheffer, D. Lopez, O. Gonzalez de Dios, A. Pastor Perales, T. Fossati | Proposed Standard | March 2020 |
| 8738 | Automated Certificate Management Environment (ACME) IP Identifier Validation ExtensionR.B. Shoemaker | Proposed Standard | February 2020 |
| 8737 | Automated Certificate Management Environment (ACME) TLS Application-Layer Protocol Negotiation (ALPN) Challenge ExtensionR.B. Shoemaker | Proposed Standard | February 2020 |
| 8705 | OAuth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access TokensB. Campbell, J. Bradley, N. Sakimura, T. Lodderstedt | Proposed Standard | February 2020 |
| 8461 | SMTP MTA Strict Transport Security (MTA-STS)D. Margolis, M. Risher, B. Ramakrishnan, A. Brotman, J. Jones | Proposed Standard | September 2018 |
| 8449 | Record Size Limit Extension for TLSM. Thomson | Proposed Standard | August 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8336 | The ORIGIN HTTP/2 FrameM. Nottingham, E. Nygren | Proposed Standard | March 2018 |
| 8323 | CoAP (Constrained Application Protocol) over TCP, TLS, and WebSocketsC. Bormann, S. Lemay, H. Tschofenig, K. Hartke, B. Silverajan, B. Raymor, Ed. | Proposed Standard | February 2018 |
| 8314 | Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and AccessK. Moore, C. Newman | Proposed Standard | January 2018 |
| 8253 | PCEPS: Usage of TLS to Provide a Secure Transport for the Path Computation Element Communication Protocol (PCEP)D. Lopez, O. Gonzalez de Dios, Q. Wu, D. Dhody | Proposed Standard | October 2017 |
| 8143 | Using Transport Layer Security (TLS) with Network News Transfer Protocol (NNTP)J. Elie | Proposed Standard | April 2017 |
| 8094 | DNS over Datagram Transport Layer Security (DTLS)T. Reddy, D. Wing, P. Patil | Experimental | February 2017 |
| 7925 | Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. Fossati | Proposed Standard | July 2016 |
| 7924 | Transport Layer Security (TLS) Cached Information ExtensionS. Santesson, H. Tschofenig | Proposed Standard | July 2016 |
| 7838 | HTTP Alternative ServicesM. Nottingham, P. McManus, J. Reschke | Proposed Standard | April 2016 |
| 7831 | Application Bridging for Federated Access Beyond Web (ABFAB) ArchitectureJ. Howlett, S. Hartman, H. Tschofenig, J. Schaad | Informational | May 2016 |
| 7817 | Updated Transport Layer Security (TLS) Server Identity Check Procedure for Email-Related ProtocolsA. Melnikov | Proposed Standard | March 2016 |
| 7712 | Domain Name Associations (DNA) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, M. Miller, P. Hancke | Proposed Standard | November 2015 |
| 7673 | Using DNS-Based Authentication of Named Entities (DANE) TLSA Records with SRV RecordsT. Finch, M. Miller, P. Saint-Andre | Proposed Standard | October 2015 |
| 7672 | SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)V. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7671 | The DNS-Based Authentication of Named Entities (DANE) Protocol: Updates and Operational GuidanceV. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7633 | X.509v3 Transport Layer Security (TLS) Feature ExtensionP. Hallam-Baker | Proposed Standard | October 2015 |
| 7605 | Recommendations on Using Assigned Transport Port NumbersJ. Touch | Best Current Practice | August 2015 |
| 7590 | Use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, T. Alkemade | Proposed Standard | June 2015 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7366 | Encrypt-then-MAC for Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Gutmann | Proposed Standard | September 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7251 | AES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLSD. McGrew, D. Bailey, M. Campagna, R. Dugal | Informational | June 2014 |
| 7170 | Tunnel Extensible Authentication Protocol (TEAP) Version 1H. Zhou, N. Cam-Winget, J. Salowey, S. Hanna · obsoleted by RFC 9930 | Proposed Standard | May 2014 |
| 7151 | File Transfer Protocol HOST Command for Virtual HostsP. Hethmon, R. McMurray | Proposed Standard | March 2014 |
| 7055 | A GSS-API Mechanism for the Extensible Authentication ProtocolS. Hartman, Ed., J. Howlett | Proposed Standard | December 2013 |
| 7030 | Enrollment over Secure TransportM. Pritikin, Ed., P. Yee, Ed., D. Harkins, Ed. | Proposed Standard | October 2013 |
| 6962 | Certificate TransparencyB. Laurie, A. Langley, E. Kasper · obsoleted by RFC 9162 | Experimental | June 2013 |
| 6961 | The Transport Layer Security (TLS) Multiple Certificate Status Request ExtensionY. Pettersen · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | June 2013 |
| 6943 | Issues in Identifier Comparison for Security PurposesD. Thaler, Ed. | Informational | May 2013 |
| 6797 | HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. Barth | Proposed Standard | November 2012 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6678 | Requirements for a Tunnel-Based Extensible Authentication Protocol (EAP) MethodK. Hoeper, S. Hanna, H. Zhou, J. Salowey, Ed. | Informational | July 2012 |
| 6655 | AES-CCM Cipher Suites for Transport Layer Security (TLS)D. McGrew, D. Bailey | Proposed Standard | July 2012 |
| 6614 | Transport Layer Security (TLS) Encryption for RADIUSS. Winter, M. McCauley, S. Venaas, K. Wierenga | Experimental | May 2012 |
| 6520 | Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat ExtensionR. Seggelmann, M. Tuexen, M. Williams | Proposed Standard | February 2012 |
| 6455 | The WebSocket ProtocolI. Fette, A. Melnikov | Proposed Standard | December 2011 |
| 6186 | Use of SRV Records for Locating Email Submission/Access ServicesC. Daboo | Proposed Standard | March 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6120 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre | Proposed Standard | March 2011 |
| 6091 | Using OpenPGP Keys for Transport Layer Security (TLS) AuthenticationN. Mavrogiannopoulos, D. Gillmor | Informational | February 2011 |