| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 3023 | XML Media TypesM. Murata, S. St. Laurent, D. Kohn · obsoleted by RFC 7303 | Proposed Standard | January 2001 |
| 3394 | Advanced Encryption Standard (AES) Key Wrap AlgorithmJ. Schaad, R. Housley | Informational | October 2002 |
| 3575 | IANA Considerations for RADIUS (Remote Authentication Dial In User Service)B. Aboba | Proposed Standard | July 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4013 | SASLprep: Stringprep Profile for User Names and PasswordsK. Zeilenga · obsoleted by RFC 7613 | Proposed Standard | March 2005 |
| 4210 | Internet X.509 Public Key Infrastructure Certificate Management Protocol (CMP)C. Adams, S. Farrell, T. Kause, T. Mononen · obsoleted by RFC 9810 | Proposed Standard | September 2005 |
| 4758 | Cryptographic Token Key Initialization Protocol (CT-KIP) Version 1.0 Revision 1M. Nystroem | Informational | November 2006 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5272 | Certificate Management over CMS (CMC)J. Schaad, M. Myers · obsoleted by RFC 10002 | Proposed Standard | June 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5649 | Advanced Encryption Standard (AES) Key Wrap with Padding AlgorithmR. Housley, M. Dworkin | Informational | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6030 | Portable Symmetric Key Container (PSKC)P. Hoyer, M. Pei, S. Machani | Proposed Standard | October 2010 |
| 6031 | Cryptographic Message Syntax (CMS) Symmetric Key Package Content TypeS. Turner, R. Housley | Proposed Standard | December 2010 |