| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1058 | Routing Information ProtocolC.L. Hedrick | Historic | June 1988 |
| 1195 | Use of OSI IS-IS for routing in TCP/IP and dual environmentsR. Callon | Proposed Standard | December 1990 |
| 1321 | The MD5 Message-Digest AlgorithmR. Rivest | Informational | April 1992 |
| 1388 | RIP Version 2 Carrying Additional InformationG. Malkin · obsoleted by RFC 1723 | Proposed Standard | January 1993 |
| 1723 | RIP Version 2 - Carrying Additional InformationG. Malkin · obsoleted by RFC 2453 | Internet Standard | November 1994 |
| 1923 | RIPv1 Applicability Statement for Historic StatusJ. Halpern, S. Bradner | Informational | March 1996 |
| 2082 | RIP-2 MD5 AuthenticationF. Baker, R. Atkinson · obsoleted by RFC 4822 | Proposed Standard | January 1997 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2154 | OSPF with Digital SignaturesS. Murphy, M. Badger, B. Wellington | Experimental | June 1997 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 2385 | Protection of BGP Sessions via the TCP MD5 Signature OptionA. Heffernan · obsoleted by RFC 5925 | Proposed Standard | August 1998 |
| 2410 | The NULL Encryption Algorithm and Its Use With IPsecR. Glenn, S. Kent | Proposed Standard | November 1998 |
| 2453 | RIP Version 2G. Malkin | Internet Standard | November 1998 |
| 3562 | Key Management Considerations for the TCP MD5 Signature OptionM. Leech | Informational | July 2003 |
| 4270 | Attacks on Cryptographic Hashes in Internet ProtocolsP. Hoffman, B. Schneier | Informational | December 2005 |
| 4271 | A Border Gateway Protocol 4 (BGP-4)Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed. | Draft Standard | January 2006 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4306 | Internet Key Exchange (IKEv2) ProtocolC. Kaufman, Ed. · obsoleted by RFC 5996 | Proposed Standard | December 2005 |
| 4552 | Authentication/Confidentiality for OSPFv3M. Gupta, N. Melam | Proposed Standard | June 2006 |
| 4822 | RIPv2 Cryptographic AuthenticationR. Atkinson, M. Fanto | Proposed Standard | February 2007 |
| 5304 | IS-IS Cryptographic AuthenticationT. Li, R. Atkinson | Proposed Standard | October 2008 |
| 5310 | IS-IS Generic Cryptographic AuthenticationM. Bhatia, V. Manral, T. Li, R. Atkinson, R. White, M. Fanto | Proposed Standard | February 2009 |
| 5340 | OSPF for IPv6R. Coltun, D. Ferguson, J. Moy, A. Lindem | Proposed Standard | July 2008 |
| 5709 | OSPFv2 HMAC-SHA Cryptographic AuthenticationM. Bhatia, V. Manral, M. Fanto, R. White, M. Barnes, T. Li, R. Atkinson | Proposed Standard | October 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5880 | Bidirectional Forwarding Detection (BFD)D. Katz, D. Ward | Proposed Standard | June 2010 |
| 5881 | Bidirectional Forwarding Detection (BFD) for IPv4 and IPv6 (Single Hop)D. Katz, D. Ward | Proposed Standard | June 2010 |
| 5883 | Bidirectional Forwarding Detection (BFD) for Multihop PathsD. Katz, D. Ward | Proposed Standard | June 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |