| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2205 | Resource ReSerVation Protocol (RSVP) -- Version 1 Functional SpecificationR. Braden, Ed., L. Zhang, S. Berson, S. Herzog, S. Jamin | Proposed Standard | September 1997 |
| 2210 | The Use of RSVP with IETF Integrated ServicesJ. Wroclawski | Proposed Standard | September 1997 |
| 2997 | Specification of the Null Service TypeY. Bernet, A. Smith, B. Davie | Proposed Standard | November 2000 |
| 3471 | Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional DescriptionL. Berger, Ed. | Proposed Standard | February 2003 |
| 3473 | Generalized Multi-Protocol Label Switching (GMPLS) Signaling Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) ExtensionsL. Berger, Ed. | Proposed Standard | February 2003 |
| 3477 | Signalling Unnumbered Links in Resource ReSerVation Protocol - Traffic Engineering (RSVP-TE)K. Kompella, Y. Rekhter | Proposed Standard | February 2003 |
| 3630 | Traffic Engineering (TE) Extensions to OSPF Version 2D. Katz, K. Kompella, D. Yeung | Proposed Standard | October 2003 |
| 3945 | Generalized Multi-Protocol Label Switching (GMPLS) ArchitectureE. Mannie, Ed. | Proposed Standard | November 2004 |
| 4201 | Link Bundling in MPLS Traffic Engineering (TE)K. Kompella, Y. Rekhter, L. Berger | Proposed Standard | October 2005 |
| 4202 | Routing Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4203 | OSPF Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4206 | Label Switched Paths (LSP) Hierarchy with Generalized Multi-Protocol Label Switching (GMPLS) Traffic Engineering (TE)K. Kompella, Y. Rekhter | Proposed Standard | October 2005 |
| 4606 | Generalized Multi-Protocol Label Switching (GMPLS) Extensions for Synchronous Optical Network (SONET) and Synchronous Digital Hierarchy (SDH) ControlE. Mannie, D. Papadimitriou | Proposed Standard | August 2006 |
| 4874 | Exclude Routes - Extension to Resource ReserVation Protocol-Traffic Engineering (RSVP-TE)CY. Lee, A. Farrel, S. De Cnodder | Proposed Standard | April 2007 |
| 4974 | Generalized MPLS (GMPLS) RSVP-TE Signaling Extensions in Support of CallsD. Papadimitriou, A. Farrel | Proposed Standard | August 2007 |
| 5212 | Requirements for GMPLS-Based Multi-Region and Multi-Layer Networks (MRN/MLN)K. Shiomoto, D. Papadimitriou, JL. Le Roux, M. Vigoureux, D. Brungard | Informational | July 2008 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5305 | IS-IS Extensions for Traffic EngineeringT. Li, H. Smit | Proposed Standard | October 2008 |
| 5307 | IS-IS Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2008 |
| 5339 | Evaluation of Existing GMPLS Protocols against Multi-Layer and Multi-Region Networks (MLN/MRN)JL. Le Roux, Ed., D. Papadimitriou, Ed. | Informational | September 2008 |
| 5420 | Encoding of Attributes for MPLS LSP Establishment Using Resource Reservation Protocol Traffic Engineering (RSVP-TE)A. Farrel, Ed., D. Papadimitriou, JP. Vasseur, A. Ayyangar | Proposed Standard | February 2009 |
| 5710 | PathErr Message Triggered MPLS and GMPLS LSP ReroutesL. Berger, D. Papadimitriou, JP. Vasseur | Proposed Standard | January 2010 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5817 | Graceful Shutdown in MPLS and Generalized MPLS Traffic Engineering NetworksZ. Ali, JP. Vasseur, A. Zamfir, J. Newton | Informational | April 2010 |
| 5920 | Security Framework for MPLS and GMPLS NetworksL. Fang, Ed. | Informational | July 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |