rfc.dk

Cited in: RFC 5996

61 RFCs mentioned in the text of RFC 5996 (Internet Key Exchange Protocol Version 2 (IKEv2))

RFCTitleStatusDate
791Internet ProtocolJ. PostelInternet StandardSeptember 1981
822STANDARD FOR THE FORMAT OF ARPA INTERNET TEXT MESSAGESD. Crocker · obsoleted by RFC 2822Internet StandardAugust 1982
1321The MD5 Message-Digest AlgorithmR. RivestInformationalApril 1992
1958Architectural Principles of the InternetB. Carpenter, Ed.InformationalJune 1996
2104HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. CanettiInformationalFebruary 1997
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
2367PF_KEY Key Management API, Version 2D. McDonald, C. Metz, B. PhanInformationalJuly 1998
2394IP Payload Compression Using DEFLATER. PereiraInformationalDecember 1998
2395IP Payload Compression Using LZSR. Friend, R. MonsourInformationalDecember 1998
2401Security Architecture for the Internet ProtocolS. Kent, R. Atkinson · obsoleted by RFC 4301Proposed StandardNovember 1998
2403The Use of HMAC-MD5-96 within ESP and AHC. Madson, R. GlennProposed StandardNovember 1998
2404The Use of HMAC-SHA-1-96 within ESP and AHC. Madson, R. GlennProposed StandardNovember 1998
2405The ESP DES-CBC Cipher Algorithm With Explicit IVC. Madson, N. DoraswamyProposed StandardNovember 1998
2407The Internet IP Security Domain of Interpretation for ISAKMPD. Piper · obsoleted by RFC 4306HistoricNovember 1998
2408Internet Security Association and Key Management Protocol (ISAKMP)D. Maughan, M. Schertler, M. Schneider, J. Turner · obsoleted by RFC 4306HistoricNovember 1998
2409The Internet Key Exchange (IKE)D. Harkins, D. Carrel · obsoleted by RFC 4306HistoricNovember 1998
2410The NULL Encryption Algorithm and Its Use With IPsecR. Glenn, S. KentProposed StandardNovember 1998
2412The OAKLEY Key Determination ProtocolH. OrmanInformationalNovember 1998
2451The ESP CBC-Mode Cipher AlgorithmsR. Pereira, R. AdamsProposed StandardNovember 1998
2474Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. BlackProposed StandardDecember 1998
2475An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. WeissInformationalDecember 1998
2522Photuris: Session-Key Management ProtocolP. Karn, W. SimpsonExperimentalMarch 1999
2616Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235Draft StandardJune 1999
2775Internet TransparencyB. CarpenterInformationalFebruary 2000
2983Differentiated Services and TunnelsD. BlackInformationalOctober 2000
3051IP Payload Compression Using ITU-T V.44 Packet MethodJ. Heath, J. BorderInformationalJanuary 2001
3168The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. BlackProposed StandardSeptember 2001
3173IP Payload Compression Protocol (IPComp)A. Shacham, B. Monsour, R. Pereira, M. ThomasProposed StandardSeptember 2001
3439Some Internet Architectural Guidelines and PhilosophyR. Bush, D. MeyerInformationalDecember 2002
3447Public-Key Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.1J. Jonsson, B. Kaliski · obsoleted by RFC 8017InformationalFebruary 2003
3526More Modular Exponential (MODP) Diffie-Hellman groups for Internet Key Exchange (IKE)T. Kivinen, M. KojoProposed StandardMay 2003
3566The AES-XCBC-MAC-96 Algorithm and Its Use With IPsecS. Frankel, H. HerbertProposed StandardSeptember 2003
3602The AES-CBC Cipher Algorithm and Its Use with IPsecS. Frankel, R. Glenn, S. KellyProposed StandardSeptember 2003
3686Using Advanced Encryption Standard (AES) Counter Mode With IPsec Encapsulating Security Payload (ESP)R. HousleyProposed StandardJanuary 2004
3715IPsec-Network Address Translation (NAT) Compatibility RequirementsB. Aboba, W. DixonInformationalMarch 2004
3748Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed.Proposed StandardJune 2004
3775Mobility Support in IPv6D. Johnson, C. Perkins, J. Arkko · obsoleted by RFC 6275Proposed StandardJune 2004
3810Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777Proposed StandardJune 2004
3948UDP Encapsulation of IPsec ESP PacketsA. Huttunen, B. Swander, V. Volpe, L. DiBurro, M. StenbergProposed StandardJanuary 2005
3986Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. MasinterInternet StandardJanuary 2005
4086Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. CrockerBest Current PracticeJune 2005
4282The Network Access IdentifierB. Aboba, M. Beadles, J. Arkko, P. Eronen · obsoleted by RFC 7542Proposed StandardDecember 2005
4291IP Version 6 Addressing ArchitectureR. Hinden, S. DeeringDraft StandardFebruary 2006
4301Security Architecture for the Internet ProtocolS. Kent, K. SeoProposed StandardDecember 2005
4302IP Authentication HeaderS. KentProposed StandardDecember 2005
4303IP Encapsulating Security Payload (ESP)S. KentProposed StandardDecember 2005
4306Internet Key Exchange (IKEv2) ProtocolC. Kaufman, Ed. · obsoleted by RFC 5996Proposed StandardDecember 2005
4307Cryptographic Algorithms for Use in the Internet Key Exchange Version 2 (IKEv2)J. Schiller · obsoleted by RFC 8247Proposed StandardDecember 2005
4434The AES-XCBC-PRF-128 Algorithm for the Internet Key Exchange Protocol (IKE)P. HoffmanProposed StandardFebruary 2006
4478Repeated Authentication in Internet Key Exchange (IKEv2) ProtocolY. NirExperimentalApril 2006
4555IKEv2 Mobility and Multihoming Protocol (MOBIKE)P. EronenProposed StandardJune 2006
4615The Advanced Encryption Standard-Cipher-based Message Authentication Code-Pseudo-Random Function-128 (AES-CMAC-PRF-128) Algorithm for the Internet Key Exchange Protocol (IKE)J. Song, R. Poovendran, J. Lee, T. IwataProposed StandardAugust 2006
4718IKEv2 Clarifications and Implementation GuidelinesP. Eronen, P. Hoffman · obsoleted by RFC 5996InformationalOctober 2006
5280Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. PolkProposed StandardMay 2008
5282Using Authenticated Encryption Algorithms with the Encrypted Payload of the Internet Key Exchange version 2 (IKEv2) ProtocolD. Black, D. McGrewProposed StandardAugust 2008
5322Internet Message FormatP. Resnick, Ed.Draft StandardOctober 2008
5335Internationalized Email HeadersA. Yang, Ed. · obsoleted by RFC 6532ExperimentalSeptember 2008
5739IPv6 Configuration in Internet Key Exchange Protocol Version 2 (IKEv2)P. Eronen, J. Laganier, C. MadsonExperimentalFebruary 2010
5741RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841InformationalDecember 2009
5857IKEv2 Extensions to Support Robust Header Compression over IPsecE. Ertekin, C. Christou, R. Jasani, T. Kivinen, C. BormannProposed StandardMay 2010
5890Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. KlensinProposed StandardAugust 2010