| 7670 | Generic Raw Public-Key Support for IKEv2T. Kivinen, P. Wouters, H. Tschofenig | Proposed Standard | January 2016 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |
| 7166 | Supporting Authentication Trailer for OSPFv3M. Bhatia, V. Manral, A. Lindem | Proposed Standard | March 2014 |
| 7146 | Securing Block Storage Protocols over IP: RFC 3723 Requirements Update for IPsec v3D. Black, P. Koning | Proposed Standard | April 2014 |
| 7143 | Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)M. Chadalapaka, J. Satran, K. Meth, D. Black | Proposed Standard | April 2014 |
| 7126 | Recommendations on Filtering of IPv4 Packets Containing IPv4 OptionsF. Gont, R. Atkinson, C. Pignataro | Best Current Practice | February 2014 |
| 7039 | Source Address Validation Improvement (SAVI) FrameworkJ. Wu, J. Bi, M. Bagnulo, F. Baker, C. Vogt, Ed. | Informational | October 2013 |
| 6989 | Additional Diffie-Hellman Tests for the Internet Key Exchange Protocol Version 2 (IKEv2)Y. Sheffer, S. Fluhrer | Proposed Standard | July 2013 |
| 6954 | Using the Elliptic Curve Cryptography (ECC) Brainpool Curves for the Internet Key Exchange Protocol Version 2 (IKEv2)J. Merkle, M. Lochter | Informational | July 2013 |
| 6952 | Analysis of BGP, LDP, PCEP, and MSDP Issues According to the Keying and Authentication for Routing Protocols (KARP) Design GuideM. Jethanandani, K. Patel, L. Zheng | Informational | May 2013 |
| 6898 | Link Management Protocol Behavior Negotiation and Configuration ModificationsD. Li, D. Ceccarelli, L. Berger | Proposed Standard | March 2013 |
| 6883 | IPv6 Guidance for Internet Content Providers and Application Service ProvidersB. Carpenter, S. Jiang | Informational | March 2013 |
| 6879 | IPv6 Enterprise Network Renumbering Scenarios, Considerations, and MethodsS. Jiang, B. Liu, B. Carpenter | Informational | February 2013 |
| 6867 | An Internet Key Exchange Protocol Version 2 (IKEv2) Extension to Support EAP Re-authentication Protocol (ERP)Y. Nir, Q. Wu | Experimental | January 2013 |
| 6786 | Encrypting the Protocol for Carrying Authentication for Network Access (PANA) Attribute-Value PairsA. Yegin, R. Cragie | Proposed Standard | November 2012 |
| 6738 | Diameter IKEv2 SK: Using Shared Keys to Support Interaction between IKEv2 Servers and Diameter ServersV. Cakulev, A. Lior, S. Mizikovsky | Proposed Standard | October 2012 |
| 6709 | Design Considerations for Protocol ExtensionsB. Carpenter, B. Aboba, Ed., S. Cheshire | Informational | September 2012 |
| 6696 | EAP Extensions for the EAP Re-authentication Protocol (ERP)Z. Cao, B. He, Y. Shi, Q. Wu, Ed., G. Zorn, Ed. | Proposed Standard | July 2012 |
| 6632 | An Overview of the IETF Network Management StandardsM. Ersue, Ed., B. Claise | Informational | June 2012 |
| 6631 | Password Authenticated Connection Establishment with the Internet Key Exchange Protocol version 2 (IKEv2)D. Kuegler, Y. Sheffer | Experimental | June 2012 |
| 6628 | Efficient Augmented Password-Only Authentication and Key Exchange for IKEv2S. Shin, K. Kobara | Experimental | June 2012 |
| 6618 | Mobile IPv6 Security Framework Using Transport Layer Security for Communication between the Mobile Node and Home AgentJ. Korhonen, Ed., B. Patil, H. Tschofenig, D. Kroeselberg | Experimental | May 2012 |
| 6617 | Secure Pre-Shared Key (PSK) Authentication for the Internet Key Exchange Protocol (IKE)D. Harkins | Experimental | June 2012 |
| 6606 | Problem Statement and Requirements for IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) RoutingE. Kim, D. Kaspar, C. Gomez, C. Bormann | Informational | May 2012 |
| 6568 | Design and Application Spaces for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)E. Kim, D. Kaspar, JP. Vasseur | Informational | April 2012 |
| 6506 | Supporting Authentication Trailer for OSPFv3M. Bhatia, V. Manral, A. Lindem · obsoleted by RFC 7166 | Proposed Standard | February 2012 |
| 6467 | Secure Password Framework for Internet Key Exchange Version 2 (IKEv2)T. Kivinen | Informational | December 2011 |
| 6463 | Runtime Local Mobility Anchor (LMA) Assignment Support for Proxy Mobile IPv6J. Korhonen, Ed., S. Gundavelli, H. Yokota, X. Cui | Proposed Standard | February 2012 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |
| 6407 | The Group Domain of InterpretationB. Weis, S. Rowles, T. Hardjono · obsoleted by RFC 9838 | Proposed Standard | October 2011 |
| 6380 | Suite B Profile for Internet Protocol Security (IPsec)K. Burgin, M. Peck | Historic | October 2011 |
| 6379 | Suite B Cryptographic Suites for IPsecL. Law, J. Solinas | Historic | October 2011 |
| 6320 | Protocol for Access Node Control Mechanism in Broadband NetworksS. Wadhwa, J. Moisand, T. Haag, N. Voigt, T. Taylor, Ed. | Proposed Standard | October 2011 |
| 6311 | Protocol Support for High Availability of IKEv2/IPsecR. Singh, Ed., G. Kalyani, Y. Nir, Y. Sheffer, D. Zhang | Proposed Standard | July 2011 |
| 6296 | IPv6-to-IPv6 Network Prefix TranslationM. Wasserman, F. Baker | Experimental | June 2011 |
| 6290 | A Quick Crash Detection Method for the Internet Key Exchange Protocol (IKE)Y. Nir, Ed., D. Wierbowski, F. Detienne, P. Sethi | Proposed Standard | June 2011 |
| 6281 | Understanding Apple's Back to My Mac (BTMM) ServiceS. Cheshire, Z. Zhu, R. Wakikawa, L. Zhang | Informational | June 2011 |
| 6275 | Mobility Support in IPv6C. Perkins, Ed., D. Johnson, J. Arkko | Proposed Standard | July 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |
| 6269 | Issues with IP Address SharingM. Ford, Ed., M. Boucadair, A. Durand, P. Levis, P. Roberts | Informational | June 2011 |
| 6253 | Host Identity Protocol CertificatesT. Heer, S. Varjonen · obsoleted by RFC 8002 | Experimental | May 2011 |
| 6193 | Media Description for the Internet Key Exchange Protocol (IKE) in the Session Description Protocol (SDP)M. Saito, D. Wing, M. Toyama | Informational | April 2011 |
| 6142 | ANSI C12.22, IEEE 1703, and MC12.22 Transport Over IPA. Moise, J. Brodkin | Informational | March 2011 |
| 6124 | An EAP Authentication Method Based on the Encrypted Key Exchange (EKE) ProtocolY. Sheffer, G. Zorn, H. Tschofenig, S. Fluhrer | Informational | February 2011 |
| 6097 | Local Mobility Anchor (LMA) Discovery for Proxy Mobile IPv6J. Korhonen, V. Devarapalli | Informational | February 2011 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6090 | Fundamental Elliptic Curve Cryptography AlgorithmsD. McGrew, K. Igoe, M. Salter | Informational | February 2011 |
| 6089 | Flow Bindings in Mobile IPv6 and Network Mobility (NEMO) Basic SupportG. Tsirtsis, H. Soliman, N. Montavont, G. Giaretta, K. Kuladinithi | Proposed Standard | January 2011 |
| 6071 | IP Security (IPsec) and Internet Key Exchange (IKE) Document RoadmapS. Frankel, S. Krishnan | Informational | February 2011 |
| 6054 | Using Counter Modes with Encapsulating Security Payload (ESP) and Authentication Header (AH) to Protect Group TrafficD. McGrew, B. Weis | Proposed Standard | November 2010 |
| 6040 | Tunnelling of Explicit Congestion NotificationB. Briscoe | Proposed Standard | November 2010 |
| 6027 | IPsec Cluster Problem StatementY. Nir | Informational | October 2010 |
| 6023 | A Childless Initiation of the Internet Key Exchange Version 2 (IKEv2) Security Association (SA)Y. Nir, H. Tschofenig, H. Deng, R. Singh | Experimental | October 2010 |
| 6001 | Generalized MPLS (GMPLS) Protocol Extensions for Multi-Layer and Multi-Region Networks (MLN/MRN)D. Papadimitriou, M. Vigoureux, K. Shiomoto, D. Brungard, JL. Le Roux | Proposed Standard | October 2010 |
| 5998 | An Extension for EAP-Only Authentication in IKEv2P. Eronen, H. Tschofenig, Y. Sheffer | Proposed Standard | September 2010 |
| 5981 | Authorization for NSIS Signaling Layer ProtocolsJ. Manner, M. Stiemerling, H. Tschofenig, R. Bless, Ed. | Experimental | February 2011 |