| 2026 | The Internet Standards Process -- Revision 3S. Bradner | Best Current Practice | October 1996 |
| 2068 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, T. Berners-Lee · obsoleted by RFC 2616 | Proposed Standard | January 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2231 | MIME Parameter Value and Encoded Word Extensions: Character Sets, Languages, and ContinuationsN. Freed, K. Moore | Proposed Standard | November 1997 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2817 | Upgrading to TLS Within HTTP/1.1R. Khare, S. Lawrence | Proposed Standard | May 2000 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 3864 | Registration Procedures for Message Header FieldsG. Klyne, M. Nottingham, J. Mogul | Best Current Practice | September 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 3987 | Internationalized Resource Identifiers (IRIs)M. Duerst, M. Suignard | Proposed Standard | January 2005 |
| 4287 | The Atom Syndication FormatM. Nottingham, Ed., R. Sayre, Ed. | Proposed Standard | December 2005 |
| 4288 | Media Type Specifications and Registration ProceduresN. Freed, J. Klensin · obsoleted by RFC 6838 | Best Current Practice | December 2005 |
| 4685 | Atom Threading ExtensionsJ. Snell | Proposed Standard | September 2006 |
| 4946 | Atom License ExtensionJ. Snell | Experimental | July 2007 |
| 5005 | Feed Paging and ArchivingM. Nottingham | Proposed Standard | September 2007 |
| 5023 | The Atom Publishing ProtocolJ. Gregorio, Ed., B. de hOra, Ed. | Proposed Standard | October 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5646 | Tags for Identifying LanguagesA. Phillips, Ed., M. Davis, Ed. | Best Current Practice | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5829 | Link Relation Types for Simple Version Navigation between Web ResourcesA. Brown, G. Clemm, J. Reschke, Ed. | Informational | April 2010 |
| 5987 | Character Set and Language Encoding for Hypertext Transfer Protocol (HTTP) Header Field ParametersJ. Reschke · obsoleted by RFC 8187 | Historic | August 2010 |