| 9423 | Constrained RESTful Environments (CoRE) Target Attributes RegistryC. Bormann | Informational | April 2024 |
| 9264 | Linkset: Media Types and a Link Relation Type for Link SetsE. Wilde, H. Van de Sompel | Proposed Standard | July 2022 |
| 9083 | JSON Responses for the Registration Data Access Protocol (RDAP)S. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 8574 | cite-as: A Link Relation to Convey a Preferred URI for ReferencingH. Van de Sompel, M. Nelson, G. Bilder, J. Kunze, S. Warner | Informational | April 2019 |
| 8288 | Web LinkingM. Nottingham | Proposed Standard | October 2017 |
| 8187 | Indicating Character Encoding and Language for HTTP Header Field ParametersJ. Reschke | Proposed Standard | September 2017 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8030 | Generic Event Delivery Using HTTP PushM. Thomson, E. Damaggio, B. Raymor, Ed. | Proposed Standard | December 2016 |
| 7807 | Problem Details for HTTP APIsM. Nottingham, E. Wilde · obsoleted by RFC 9457 | Proposed Standard | March 2016 |
| 7725 | An HTTP Status Code to Report Legal ObstaclesT. Bray | Proposed Standard | February 2016 |
| 7641 | Observing Resources in the Constrained Application Protocol (CoAP)K. Hartke | Proposed Standard | September 2015 |
| 7565 | The 'acct' URI SchemeP. Saint-Andre | Proposed Standard | May 2015 |
| 7483 | JSON Responses for the Registration Data Access Protocol (RDAP)A. Newton, S. Hollenbeck · obsoleted by RFC 9083 | Proposed Standard | March 2015 |
| 7395 | An Extensible Messaging and Presence Protocol (XMPP) Subprotocol for WebSocketL. Stout, Ed., J. Moffitt, E. Cestari | Proposed Standard | October 2014 |
| 7320 | URI Design and OwnershipM. Nottingham · obsoleted by RFC 8820 | Best Current Practice | July 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7089 | HTTP Framework for Time-Based Access to Resource States -- MementoH. Van de Sompel, M. Nelson, R. Sanderson | Informational | December 2013 |
| 7033 | WebFingerP. Jones, G. Salgueiro, M. Jones, J. Smarr | Proposed Standard | September 2013 |
| 6919 | Further Key Words for Use in RFCs to Indicate Requirement LevelsR. Barnes, S. Kent, E. Rescorla | Experimental | 1 April 2013 |
| 6906 | The 'profile' Link Relation TypeE. Wilde | Informational | March 2013 |
| 6903 | Additional Link Relation TypesJ. Snell | Informational | March 2013 |
| 6892 | The 'describes' Link Relation TypeE. Wilde | Informational | March 2013 |
| 6861 | The "create-form" and "edit-form" Link RelationsI. Dzmanashvili | Informational | January 2013 |
| 6690 | Constrained RESTful Environments (CoRE) Link FormatZ. Shelby | Proposed Standard | August 2012 |
| 6596 | The Canonical Link RelationM. Ohye, J. Kupke | Informational | April 2012 |
| 6579 | The 'disclosure' Link Relation TypeM. Yevstifeyev | Informational | March 2012 |
| 6573 | The Item and Collection Link RelationsM. Amundsen | Informational | April 2012 |
| 6415 | Web Host MetadataE. Hammer-Lahav, Ed., B. Cook | Proposed Standard | October 2011 |
| 6249 | Metalink/HTTP: Mirrors and HashesA. Bryan, N. McNab, T. Tsujikawa, P. Poeml, H. Nordstrom | Proposed Standard | June 2011 |
| 5989 | A SIP Event Package for Subscribing to Changes to an HTTP ResourceA.B. Roach | Proposed Standard | October 2010 |