| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3447 | Public-Key Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.1J. Jonsson, B. Kaliski · obsoleted by RFC 8017 | Informational | February 2003 |
| 3520 | Session Authorization Policy ElementL-N. Hamer, B. Gage, B. Kosinski, H. Shieh | Proposed Standard | April 2003 |
| 3521 | Framework for Session Set-up with Media AuthorizationL-N. Hamer, B. Gage, H. Shieh | Informational | April 2003 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4080 | Next Steps in Signaling (NSIS): FrameworkR. Hancock, G. Karagiannis, J. Loughney, S. Van den Bosch | Informational | June 2005 |
| 4081 | Security Threats for Next Steps in Signaling (NSIS)H. Tschofenig, D. Kroeselberg | Informational | June 2005 |
| 4120 | The Kerberos Network Authentication Service (V5)C. Neuman, T. Yu, S. Hartman, K. Raeburn | Proposed Standard | July 2005 |
| 4514 | Lightweight Directory Access Protocol (LDAP): String Representation of Distinguished NamesK. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4868 | Using HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512 with IPsecS. Kelly, S. Frankel | Proposed Standard | May 2007 |
| 4880 | OpenPGP Message FormatJ. Callas, L. Donnerhacke, H. Finney, D. Shaw, R. Thayer · obsoleted by RFC 9580 | Proposed Standard | November 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5652 | Cryptographic Message Syntax (CMS)R. Housley | Internet Standard | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5905 | Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. Kasch | Proposed Standard | June 2010 |
| 5971 | GIST: General Internet Signalling TransportH. Schulzrinne, R. Hancock | Experimental | October 2010 |
| 5973 | NAT/Firewall NSIS Signaling Layer Protocol (NSLP)M. Stiemerling, H. Tschofenig, C. Aoun, E. Davies | Experimental | October 2010 |
| 5974 | NSIS Signaling Layer Protocol (NSLP) for Quality-of-Service SignalingJ. Manner, G. Karagiannis, A. McDonald | Experimental | October 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |