| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1812 | Requirements for IP Version 4 RoutersF. Baker, Ed. | Proposed Standard | June 1995 |
| 2113 | IP Router Alert OptionD. Katz | Proposed Standard | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2205 | Resource ReSerVation Protocol (RSVP) -- Version 1 Functional SpecificationR. Braden, Ed., L. Zhang, S. Berson, S. Herzog, S. Jamin | Proposed Standard | September 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2711 | IPv6 Router Alert OptionC. Partridge, A. Jackson | Proposed Standard | October 1999 |
| 2746 | RSVP Operation Over IP TunnelsA. Terzis, J. Krawczyk, J. Wroclawski, L. Zhang | Proposed Standard | January 2000 |
| 2765 | Stateless IP/ICMP Translation Algorithm (SIIT)E. Nordmark · obsoleted by RFC 6145 | Proposed Standard | February 2000 |
| 3056 | Connection of IPv6 Domains via IPv4 CloudsB. Carpenter, K. Moore | Proposed Standard | February 2001 |
| 3068 | An Anycast Prefix for 6to4 Relay RoutersC. Huitema · obsoleted by RFC 7526 | Historic | June 2001 |
| 3175 | Aggregation of RSVP for IPv4 and IPv6 ReservationsF. Baker, C. Iturralde, F. Le Faucheur, B. Davie | Proposed Standard | September 2001 |
| 3209 | RSVP-TE: Extensions to RSVP for LSP TunnelsD. Awduche, L. Berger, D. Gan, T. Li, V. Srinivasan, G. Swallow | Proposed Standard | December 2001 |
| 3212 | Constraint-Based LSP Setup using LDPB. Jamoussi, Ed., L. Andersson, R. Callon, R. Dantu, L. Wu, P. Doolan, T. Worster, N. Feldman, A. Fredette, M. Girish, E. Gray, J. Heinanen, T. Kilty, A. Malis | Proposed Standard | January 2002 |
| 3260 | New Terminology and Clarifications for DiffservD. Grossman | Informational | April 2002 |
| 3329 | Security Mechanism Agreement for the Session Initiation Protocol (SIP)J. Arkko, V. Torvinen, G. Camarillo, A. Niemi, T. Haukka | Proposed Standard | January 2003 |
| 3588 | Diameter Base ProtocolP. Calhoun, J. Loughney, E. Guttman, G. Zorn, J. Arkko · obsoleted by RFC 6733 | Proposed Standard | September 2003 |
| 3692 | Assigning Experimental and Testing Numbers Considered UsefulT. Narten | Best Current Practice | January 2004 |
| 4080 | Next Steps in Signaling (NSIS): FrameworkR. Hancock, G. Karagiannis, J. Loughney, S. Van den Bosch | Informational | June 2005 |
| 4081 | Security Threats for Next Steps in Signaling (NSIS)H. Tschofenig, D. Kroeselberg | Informational | June 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4213 | Basic Transition Mechanisms for IPv6 Hosts and RoutersE. Nordmark, R. Gilligan | Proposed Standard | October 2005 |
| 4225 | Mobile IP Version 6 Route Optimization Security Design BackgroundP. Nikander, J. Arkko, T. Aura, G. Montenegro, E. Nordmark | Informational | December 2005 |
| 4279 | Pre-Shared Key Ciphersuites for Transport Layer Security (TLS)P. Eronen, Ed., H. Tschofenig, Ed. | Proposed Standard | December 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4787 | Network Address Translation (NAT) Behavioral Requirements for Unicast UDPF. Audet, Ed., C. Jennings | Best Current Practice | January 2007 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 4966 | Reasons to Move the Network Address Translator - Protocol Translator (NAT-PT) to Historic StatusC. Aoun, E. Davies | Informational | July 2007 |
| 5082 | The Generalized TTL Security Mechanism (GTSM)V. Gill, J. Heasley, D. Meyer, P. Savola, Ed., C. Pignataro | Proposed Standard | October 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5389 | Session Traversal Utilities for NAT (STUN)J. Rosenberg, R. Mahy, P. Matthews, D. Wing · obsoleted by RFC 8489 | Proposed Standard | October 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5766 | Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)R. Mahy, P. Matthews, J. Rosenberg · obsoleted by RFC 8656 | Proposed Standard | April 2010 |
| 5978 | Using and Extending the NSIS Protocol FamilyJ. Manner, R. Bless, J. Loughney, E. Davies, Ed. | Informational | October 2010 |