| 9911 | Common YANG Data TypesJ. Schönwälder, Ed. | Proposed Standard | December 2025 |
| 9889 | A Realization of Network Slices for 5G Networks Using Current IP/MPLS TechnologiesK. Szarkowicz, Ed., R. Roberts, Ed., J. Lucek, M. Boucadair, Ed., LM. Contreras | Informational | November 2025 |
| 9844 | Entering IPv6 Zone Identifiers in User InterfacesB. Carpenter, R. Hinden | Proposed Standard | August 2025 |
| 9460 | Service Binding and Parameter Specification via the DNS (SVCB and HTTPS Resource Records)B. Schwartz, M. Bishop, E. Nygren | Proposed Standard | November 2023 |
| 9456 | Updates to the TLS Transport Model for SNMPK. Vaughn, Ed. | Proposed Standard | November 2023 |
| 9327 | Control Messages Protocol for Use with Network Time Protocol Version 4B. Haberman, Ed. | Historic | November 2022 |
| 9246 | URI Signing for Content Delivery Network Interconnection (CDNI)R. van Brandenburg, K. Leung, P. Sorber | Proposed Standard | June 2022 |
| 9240 | An Extension for Application-Layer Traffic Optimization (ALTO): Entity Property MapsW. Roome, S. Randriamasy, Y. Yang, J. Zhang, K. Gao | Proposed Standard | July 2022 |
| 9224 | Finding the Authoritative Registration Data Access Protocol (RDAP) ServiceM. Blanchet | Internet Standard | March 2022 |
| 9099 | Operational Security Considerations for IPv6 NetworksÉ. Vyncke, K. Chittimaneni, M. Kaeo, E. Rey | Informational | August 2021 |
| 9083 | JSON Responses for the Registration Data Access Protocol (RDAP)S. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9082 | Registration Data Access Protocol (RDAP) Query FormatS. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9022 | Domain Name Registration Data (DNRD) Objects MappingG. Lozano, J. Gould, C. Thippeswamy | Proposed Standard | May 2021 |
| 8907 | The Terminal Access Controller Access-Control System Plus (TACACS+) ProtocolT. Dahm, A. Ota, D.C. Medway Gash, D. Carrel, L. Grant | Informational | September 2020 |
| 8866 | SDP: Session Description ProtocolA. Begen, P. Kyzivat, C. Perkins, M. Handley | Proposed Standard | January 2021 |
| 8805 | A Format for Self-Published IP Geolocation FeedsE. Kline, K. Duleba, Z. Szamonek, S. Moser, W. Kumari | Informational | August 2020 |
| 8771 | The Internationalized Deliberately Unreadable Network NOtation (I-DUNNO)A. Mayrhofer, J. Hague | Experimental | 1 April 2020 |
| 8738 | Automated Certificate Management Environment (ACME) IP Identifier Validation ExtensionR.B. Shoemaker | Proposed Standard | February 2020 |
| 8705 | OAuth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access TokensB. Campbell, J. Bradley, N. Sakimura, T. Lodderstedt | Proposed Standard | February 2020 |
| 8612 | DDoS Open Threat Signaling (DOTS) RequirementsA. Mortensen, T. Reddy, R. Moskowitz | Informational | May 2019 |
| 8519 | YANG Data Model for Network Access Control Lists (ACLs)M. Jethanandani, S. Agarwal, L. Huang, D. Blair | Proposed Standard | March 2019 |
| 8506 | Diameter Credit-Control ApplicationL. Bertz, Ed., D. Dolson, Ed., Y. Lifshitz, Ed. | Proposed Standard | March 2019 |
| 8504 | IPv6 Node RequirementsT. Chown, J. Loughney, T. Winters | Best Current Practice | January 2019 |
| 8460 | SMTP TLS ReportingD. Margolis, A. Brotman, B. Ramakrishnan, J. Jones, M. Risher | Proposed Standard | September 2018 |
| 8428 | Sensor Measurement Lists (SenML)C. Jennings, Z. Shelby, J. Arkko, A. Keranen, C. Bormann | Proposed Standard | August 2018 |
| 8427 | Representing DNS Messages in JSONP. Hoffman | Informational | July 2018 |
| 8416 | Simplified Local Internet Number Resource Management with the RPKI (SLURM)D. Ma, D. Mandelberg, T. Bruijnzeels | Proposed Standard | August 2018 |
| 8006 | Content Delivery Network Interconnection (CDNI) MetadataB. Niven-Jenkins, R. Murray, M. Caulfield, K. Ma | Proposed Standard | December 2016 |
| 7975 | Request Routing Redirection Interface for Content Delivery Network (CDN) InterconnectionB. Niven-Jenkins, Ed., R. van Brandenburg, Ed. | Proposed Standard | October 2016 |
| 7970 | The Incident Object Description Exchange Format Version 2R. Danyliw | Proposed Standard | November 2016 |
| 7909 | Securing Routing Policy Specification Language (RPSL) Objects with Resource Public Key Infrastructure (RPKI) SignaturesR. Kisteleki, B. Haberman | Proposed Standard | June 2016 |
| 7846 | Peer-to-Peer Streaming Tracker Protocol (PPSTP)R. Cruz, M. Nunes, J. Xia, R. Huang, Ed., J. Taveira, D. Lingli | Proposed Standard | May 2016 |
| 7483 | JSON Responses for the Registration Data Access Protocol (RDAP)A. Newton, S. Hollenbeck · obsoleted by RFC 9083 | Proposed Standard | March 2015 |
| 7482 | Registration Data Access Protocol (RDAP) Query FormatA. Newton, S. Hollenbeck · obsoleted by RFC 9082 | Proposed Standard | March 2015 |
| 7390 | Group Communication for the Constrained Application Protocol (CoAP)A. Rahman, Ed., E. Dijk, Ed. | Experimental | October 2014 |
| 7381 | Enterprise IPv6 Deployment GuidelinesK. Chittimaneni, T. Chown, L. Howard, V. Kuarsingh, Y. Pouffary, E. Vyncke | Informational | October 2014 |
| 7373 | Textual Representation of IP Flow Information Export (IPFIX) Abstract Data TypesB. Trammell | Proposed Standard | September 2014 |
| 7371 | Updates to the IPv6 Multicast Addressing ArchitectureM. Boucadair, S. Venaas | Proposed Standard | September 2014 |
| 7285 | Application-Layer Traffic Optimization (ALTO) ProtocolR. Alimi, Ed., R. Penno, Ed., Y. Yang, Ed., S. Kiesel, S. Previdi, W. Roome, S. Shalunov, R. Woundy | Proposed Standard | September 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7239 | Forwarded HTTP ExtensionA. Petersson, M. Nilsson | Proposed Standard | June 2014 |
| 7105 | Using Device-Provided Location-Related Measurements in Location Configuration ProtocolsM. Thomson, J. Winterbottom | Proposed Standard | January 2014 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 6943 | Issues in Identifier Comparison for Security PurposesD. Thaler, Ed. | Informational | May 2013 |
| 6940 | REsource LOcation And Discovery (RELOAD) Base ProtocolC. Jennings, B. Lowekamp, Ed., E. Rescorla, S. Baset, H. Schulzrinne | Proposed Standard | January 2014 |
| 6883 | IPv6 Guidance for Internet Content Providers and Application Service ProvidersB. Carpenter, S. Jiang | Informational | March 2013 |
| 6874 | Representing IPv6 Zone Identifiers in Address Literals and Uniform Resource IdentifiersB. Carpenter, S. Cheshire, R. Hinden · obsoleted by RFC 9844 | Proposed Standard | February 2013 |
| 6873 | Format for the Session Initiation Protocol (SIP) Common Log Format (CLF)G. Salgueiro, V. Gurbani, A. B. Roach | Proposed Standard | February 2013 |
| 6714 | Connection Establishment for Media Anchoring (CEMA) for the Message Session Relay Protocol (MSRP)C. Holmberg, S. Blau, E. Burger | Proposed Standard | August 2012 |
| 6492 | A Protocol for Provisioning Resource CertificatesG. Huston, R. Loomans, B. Ellacott, R. Austein | Proposed Standard | February 2012 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |
| 6353 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)W. Hardaker | Internet Standard | July 2011 |
| 6217 | Regional Broadcast Using an Atmospheric Link LayerT. Ritter | Experimental | 31 March 2011 |
| 6155 | Use of Device Identity in HTTP-Enabled Location Delivery (HELD)J. Winterbottom, M. Thomson, H. Tschofenig, R. Barnes | Proposed Standard | March 2011 |
| 6122 | Extensible Messaging and Presence Protocol (XMPP): Address FormatP. Saint-Andre · obsoleted by RFC 7622 | Proposed Standard | March 2011 |
| 6120 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre | Proposed Standard | March 2011 |
| 6052 | IPv6 Addressing of IPv4/IPv6 TranslatorsC. Bao, C. Huitema, M. Bagnulo, M. Boucadair, X. Li | Proposed Standard | October 2010 |
| 6021 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 6991 | Proposed Standard | October 2010 |
| 5954 | Essential Correction for IPv6 ABNF and URI Comparison in RFC 3261V. Gurbani, Ed., B. Carpenter, Ed., B. Tate, Ed. | Proposed Standard | August 2010 |
| 5953 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)W. Hardaker · obsoleted by RFC 6353 | Proposed Standard | August 2010 |