| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 925 | Multi-LAN address resolutionJ. Postel | Unknown | October 1984 |
| 1144 | Compressing TCP/IP Headers for Low-Speed Serial LinksV. Jacobson | Proposed Standard | February 1990 |
| 1256 | ICMP Router Discovery MessagesS. Deering, Ed. | Proposed Standard | September 1991 |
| 1321 | The MD5 Message-Digest AlgorithmR. Rivest | Informational | April 1992 |
| 1332 | The PPP Internet Protocol Control Protocol (IPCP)G. McGregor | Proposed Standard | May 1992 |
| 1661 | The Point-to-Point Protocol (PPP)W. Simpson, Ed. | Internet Standard | July 1994 |
| 2002 | IP Mobility SupportC. Perkins, Ed. · obsoleted by RFC 3220 | Proposed Standard | October 1996 |
| 2003 | IP Encapsulation within IPC. Perkins | Proposed Standard | October 1996 |
| 2004 | Minimal Encapsulation within IPC. Perkins | Proposed Standard | October 1996 |
| 2005 | Applicability Statement for IP Mobility SupportJ. Solomon | Proposed Standard | October 1996 |
| 2006 | The Definitions of Managed Objects for IP Mobility Support using SMIv2D. Cong, M. Hamlen, C. Perkins | Proposed Standard | October 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2290 | Mobile-IPv4 Configuration Option for PPP IPCPJ. Solomon, S. Glass | Proposed Standard | February 1998 |
| 2356 | Sun's SKIP Firewall Traversal for Mobile IPG. Montenegro, V. Gupta | Informational | June 1998 |
| 2757 | Long Thin NetworksG. Montenegro, S. Dawkins, M. Kojo, V. Magret, N. Vaidya | Informational | January 2000 |
| 2784 | Generic Routing Encapsulation (GRE)D. Farinacci, T. Li, S. Hanks, D. Meyer, P. Traina | Proposed Standard | March 2000 |
| 2794 | Mobile IP Network Access Identifier Extension for IPv4P. Calhoun, C. Perkins | Proposed Standard | March 2000 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 2863 | The Interfaces Group MIBK. McCloghrie, F. Kastenholz | Draft Standard | June 2000 |
| 2988 | Computing TCP's Retransmission TimerV. Paxson, M. Allman · obsoleted by RFC 6298 | Proposed Standard | November 2000 |
| 3024 | Reverse Tunneling for Mobile IP, revisedG. Montenegro, Ed. | Proposed Standard | January 2001 |
| 3115 | Mobile IP Vendor/Organization-Specific ExtensionsG. Dommety, K. Leung | Proposed Standard | April 2001 |
| 3135 | Performance Enhancing Proxies Intended to Mitigate Link-Related DegradationsJ. Border, M. Kojo, J. Griner, G. Montenegro, Z. Shelby | Informational | June 2001 |
| 3155 | End-to-end Performance Implications of Links with ErrorsS. Dawkins, G. Montenegro, M. Kojo, V. Magret, N. Vaidya | Best Current Practice | August 2001 |
| 3220 | IP Mobility Support for IPv4C. Perkins, Ed. · obsoleted by RFC 3344 | Proposed Standard | January 2002 |
| 3344 | IP Mobility Support for IPv4C. Perkins, Ed. · obsoleted by RFC 5944 | Proposed Standard | August 2002 |
| 3519 | Mobile IP Traversal of Network Address Translation (NAT) DevicesH. Levkowetz, S. Vaarala | Proposed Standard | May 2003 |
| 3543 | Registration Revocation in Mobile IPv4S. Glass, M. Chandra | Proposed Standard | August 2003 |
| 3957 | Authentication, Authorization, and Accounting (AAA) Registration Keys for Mobile IPv4C. Perkins, P. Calhoun | Proposed Standard | March 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4721 | Mobile IPv4 Challenge/Response Extensions (Revised)C. Perkins, P. Calhoun, J. Bharatia | Proposed Standard | January 2007 |
| 4857 | Mobile IPv4 Regional RegistrationE. Fogelstroem, A. Jonsson, C. Perkins | Experimental | June 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5905 | Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. Kasch | Proposed Standard | June 2010 |